aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoraraujo <araujo@FreeBSD.org>2009-08-19 08:42:10 +0800
committeraraujo <araujo@FreeBSD.org>2009-08-19 08:42:10 +0800
commita7a38d9e67816ae128cc03f90dd1ea2c90446f1d (patch)
treefc064c50c7d55c53f17389d30948913db0f9498a
parent4357feda426b758b5cfe8f21134567d697d011ba (diff)
downloadfreebsd-ports-gnome-a7a38d9e67816ae128cc03f90dd1ea2c90446f1d.tar.gz
freebsd-ports-gnome-a7a38d9e67816ae128cc03f90dd1ea2c90446f1d.tar.zst
freebsd-ports-gnome-a7a38d9e67816ae128cc03f90dd1ea2c90446f1d.zip
- Use SF macro.
- Pass maintainer to submitter. PR: ports/137889 Submitted by: Sylvio Cesar <scjamorim@bsd.com.br>
-rw-r--r--www/bluefish/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/www/bluefish/Makefile b/www/bluefish/Makefile
index cac1e97beaad..4f5007b54953 100644
--- a/www/bluefish/Makefile
+++ b/www/bluefish/Makefile
@@ -10,10 +10,10 @@ PORTNAME= bluefish
PORTVERSION= 1.0.7
PORTREVISION= 6
CATEGORIES= www editors
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITES= SF
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= scjamorim@bsd.com.br
COMMENT= HTML editor designed for the experienced web designer
LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre \
@@ -27,7 +27,6 @@ RUN_DEPENDS+= tidy:${PORTSDIR}/www/tidy
.endif
USE_BZIP2= yes
-USE_GETTEXT= yes
USE_GNOME= gnomeprefix gtk20 gnomevfs2 gnomemimedata desktopfileutils
WANT_GNOME= yes
GNU_CONFIGURE= yes
@@ -71,4 +70,12 @@ pre-install:
USE_GNOME+= libgnomeui
.endif
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
+
.include <bsd.port.post.mk>