aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2008-05-06 13:03:26 +0800
committerosa <osa@FreeBSD.org>2008-05-06 13:03:26 +0800
commita7f7cf7148e5512abe10a7e1527db1933f9cfb8b (patch)
treeaac4ba911226f6a9f97ffb736c96867d8e5a6bfd
parentb181f7c2795dc2f22dfa987f1d7a0939cbaf8807 (diff)
downloadfreebsd-ports-gnome-a7f7cf7148e5512abe10a7e1527db1933f9cfb8b.tar.gz
freebsd-ports-gnome-a7f7cf7148e5512abe10a7e1527db1933f9cfb8b.tar.zst
freebsd-ports-gnome-a7f7cf7148e5512abe10a7e1527db1933f9cfb8b.zip
Add libraw a library for reading RAW files obtained from digital photo
cameras (CRW/CR2, NEF, RAF, DNG, and others). LibRaw is based on the source codes of the dcraw utility, where part of drawbacks have already been eliminated and part will be fixed in future. The users of the library are provided with API to be built into their software programs. WWW: http://www.libraw.org http://www.libraw.su
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/libraw/Makefile35
-rw-r--r--graphics/libraw/distinfo3
-rw-r--r--graphics/libraw/files/patch-Makefile104
-rw-r--r--graphics/libraw/pkg-descr14
-rw-r--r--graphics/libraw/pkg-plist13
6 files changed, 170 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 4dcf2e4616b2..a832e480023e 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -402,6 +402,7 @@
SUBDIR += libpuzzle
SUBDIR += libqglviewer
SUBDIR += libqrencode
+ SUBDIR += libraw
SUBDIR += librsvg
SUBDIR += librsvg2
SUBDIR += libspiro
diff --git a/graphics/libraw/Makefile b/graphics/libraw/Makefile
new file mode 100644
index 000000000000..fb0c23180b7b
--- /dev/null
+++ b/graphics/libraw/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: raw images library
+# Date created: 26 Apr 2008
+# Whom: osa
+#
+# $FreeBSD$
+#
+
+PORTNAME= libraw
+PORTVERSION= 0.5.3
+CATEGORIES= graphics
+MASTER_SITES= http://www.libraw.su/data/
+DISTNAME= LibRaw-${PORTVERSION}
+
+MAINTAINER= osa@FreeBSD.org
+COMMENT= Library for manipulating raw images
+
+MAKE_ENV+= CXX="${CXX}" CC="${CC}" CFLAGS="${CFLAGS}" \
+ PTHREAD_CFLAGS=${PTHREAD_CFLAGS} PTHREAD_LIBS=${PTHREAD_LIBS}
+
+USE_LDCONFIG= yes
+
+do-install:
+ @${MKDIR} ${PREFIX}/include/libraw
+
+.for f in libraw.h libraw_alloc.h libraw_const.h libraw_internal.h libraw_io.h libraw_types.h
+ @${INSTALL_DATA} ${WRKSRC}/${PORTNAME}/${f} ${PREFIX}/include/libraw
+.endfor
+.for f in libraw.a libraw.so.0 libraw_r.a libraw_r.so.0
+ @${INSTALL_DATA} ${WRKSRC}/lib/${f} ${PREFIX}/lib
+.endfor
+.for f in libraw libraw_r
+ @ cd ${PREFIX}/lib ; ${LN} -sf ${f}.so.0 ${f}.so
+.endfor
+
+.include <bsd.port.mk>
diff --git a/graphics/libraw/distinfo b/graphics/libraw/distinfo
new file mode 100644
index 000000000000..4a9e19afdfd9
--- /dev/null
+++ b/graphics/libraw/distinfo
@@ -0,0 +1,3 @@
+MD5 (LibRaw-0.5.3.tar.gz) = ff482295f68a5dfd8609485dfee89ab4
+SHA256 (LibRaw-0.5.3.tar.gz) = f0c784df471f88867e141508d9a934d8c728eeafe9f05801383d040f85da0cfd
+SIZE (LibRaw-0.5.3.tar.gz) = 160389
diff --git a/graphics/libraw/files/patch-Makefile b/graphics/libraw/files/patch-Makefile
new file mode 100644
index 000000000000..cc46fa90d111
--- /dev/null
+++ b/graphics/libraw/files/patch-Makefile
@@ -0,0 +1,104 @@
+--- Makefile.orig Sat Apr 19 17:21:37 2008
++++ Makefile Tue Apr 29 15:32:48 2008
+@@ -1,12 +1,12 @@
+ all: library all_samples
+
+
+-CFLAGS=-O4 -I. -w
++CFLAGS+=-I. -w
+
+ DCRAW_LIB_OBJECTS=object/dcraw_common.o object/foveon.o object/io.o object/libraw_cxx.o object/libraw_c_api.o
+ DCRAW_LIB_MT_OBJECTS=object/dcraw_common_mt.o object/foveon_mt.o object/io_mt.o object/libraw_cxx_mt.o object/libraw_c_api_mt.o
+
+-library: lib/libraw.a lib/libraw_r.a
++library: lib/libraw.a lib/libraw_r.a lib/libraw.so.0 lib/libraw_r.so.0
+
+ all_samples: bin/identify bin/simple_dcraw bin/dcraw_emu bin/dcraw_half bin/half_mt
+
+@@ -18,40 +18,40 @@
+ @if [ -d /usr/local/bin ] ; then cp bin/[a-z]* /usr/local/bin/ ; else echo 'no /usr/local/bin' ; fi
+
+ bin/identify: lib/libraw.a samples/identify.cpp
+- g++ ${CFLAGS} -o bin/identify samples/identify.cpp -L./lib -lraw -lm
++ ${CXX} ${CFLAGS} -o bin/identify samples/identify.cpp -L./lib -lraw -lm
+
+ bin/simple_dcraw: lib/libraw.a samples/simple_dcraw.cpp
+- g++ ${CFLAGS} -o bin/simple_dcraw samples/simple_dcraw.cpp -L./lib -lraw -lm
++ ${CXX} ${CFLAGS} -o bin/simple_dcraw samples/simple_dcraw.cpp -L./lib -lraw -lm
+
+ bin/dcraw_half: lib/libraw.a object/dcraw_half.o
+- gcc ${CFLAGS} -o bin/dcraw_half object/dcraw_half.o -L./lib -lraw -lm -lstdc++
++ ${CC} ${CFLAGS} -o bin/dcraw_half object/dcraw_half.o -L./lib -lraw -lm -lstdc++
+
+ bin/half_mt: lib/libraw_r.a object/half_mt.o
+- gcc -pthread ${CFLAGS} -o bin/half_mt object/half_mt.o -L./lib -lraw_r -lm -lstdc++
++ ${CC} ${PTHREAD_LIBS} ${CFLAGS} -o bin/half_mt object/half_mt.o -L./lib -lraw_r -lm -lstdc++
+
+ bin/dcraw_emu: lib/libraw.a samples/dcraw_emu.cpp
+- g++ ${CFLAGS} -o bin/dcraw_emu samples/dcraw_emu.cpp -L./lib -lraw -lm
++ ${CXX} ${CFLAGS} -o bin/dcraw_emu samples/dcraw_emu.cpp -L./lib -lraw -lm
+
+ object/dcraw_common.o: internal/dcraw_common.cpp
+- g++ -c ${CFLAGS} -o object/dcraw_common.o internal/dcraw_common.cpp
++ ${CXX} -c ${CFLAGS} -o object/dcraw_common.o internal/dcraw_common.cpp
+
+ object/foveon.o: internal/foveon.cpp
+- g++ -c ${CFLAGS} -o object/foveon.o internal/foveon.cpp
++ ${CXX} -c ${CFLAGS} -o object/foveon.o internal/foveon.cpp
+
+ object/io.o: src/io.c
+- gcc -c ${CFLAGS} -DUSE_MMAP_IO -o object/io.o src/io.c
++ ${CC} -c ${CFLAGS} -DUSE_MMAP_IO -o object/io.o src/io.c
+
+ object/libraw_cxx.o: src/libraw_cxx.cpp
+- g++ -c ${CFLAGS} -o object/libraw_cxx.o src/libraw_cxx.cpp
++ ${CXX} -c ${CFLAGS} -o object/libraw_cxx.o src/libraw_cxx.cpp
+
+ object/libraw_c_api.o: src/libraw_c_api.cpp
+- g++ -c ${CFLAGS} -o object/libraw_c_api.o src/libraw_c_api.cpp
++ ${CXX} -c ${CFLAGS} -o object/libraw_c_api.o src/libraw_c_api.cpp
+
+ object/dcraw_half.o: samples/dcraw_half.c
+- gcc -c ${CFLAGS} -o object/dcraw_half.o samples/dcraw_half.c
++ ${CC} -c ${CFLAGS} -o object/dcraw_half.o samples/dcraw_half.c
+
+ object/half_mt.o: samples/half_mt.c
+- gcc -c -pthread ${CFLAGS} -DLIBRAW_THREADS -o object/half_mt.o samples/half_mt.c
++ ${CC} -c ${PTHREAD_CFLAGS} ${CFLAGS} -DLIBRAW_THREADS -o object/half_mt.o samples/half_mt.c
+
+
+ lib/libraw.a: ${DCRAW_LIB_OBJECTS}
+@@ -64,20 +64,28 @@
+ ar crv lib/libraw_r.a ${DCRAW_LIB_MT_OBJECTS}
+ ranlib lib/libraw_r.a
+
++lib/libraw.so.0: ${DCRAW_LIB_OBJECTS}
++ rm -f lib/libraw.so.0
++ ${CC} ${CFLAGS} -shared -Wl,-soname,libraw.so.0 -o lib/libraw.so.0 ${DCRAW_LIB_OBJECTS}
++
++lib/libraw_r.so.0: ${DCRAW_LIB_MT_OBJECTS}
++ rm -f lib/libraw_r.so.0
++ ${CC} ${CFLAGS} -shared -Wl,-soname,libraw_r.so.0 -o lib/libraw_r.so.0 ${DCRAW_LIB_MT_OBJECTS}
++
+ object/dcraw_common_mt.o: internal/dcraw_common.cpp
+- g++ -c -pthread -DLIBRAW_THREADS ${CFLAGS} -o object/dcraw_common_mt.o internal/dcraw_common.cpp
++ ${CXX} -c ${PTHREAD_CFLAGS} -DLIBRAW_THREADS ${CFLAGS} -o object/dcraw_common_mt.o internal/dcraw_common.cpp
+
+ object/foveon_mt.o: internal/foveon.cpp
+- g++ -c -DLIBRAW_THREADS -pthread ${CFLAGS} -o object/foveon_mt.o internal/foveon.cpp
++ ${CXX} -c -DLIBRAW_THREADS ${PTHREAD_CFLAGS} ${CFLAGS} -o object/foveon_mt.o internal/foveon.cpp
+
+ object/io_mt.o: src/io.c
+- gcc -c -DLIBRAW_THREADS -pthread ${CFLAGS} -DUSE_MMAP_IO -o object/io_mt.o src/io.c
++ ${CC} -c -DLIBRAW_THREADS ${PTHREAD_CFLAGS} ${CFLAGS} -DUSE_MMAP_IO -o object/io_mt.o src/io.c
+
+ object/libraw_cxx_mt.o: src/libraw_cxx.cpp
+- g++ -c -DLIBRAW_THREADS -pthread ${CFLAGS} -o object/libraw_cxx_mt.o src/libraw_cxx.cpp
++ ${CXX} -c -DLIBRAW_THREADS ${PTHREAD_CFLAGS} ${CFLAGS} -o object/libraw_cxx_mt.o src/libraw_cxx.cpp
+
+ object/libraw_c_api_mt.o: src/libraw_c_api.cpp
+- g++ -c -DLIBRAW_THREADS -pthread ${CFLAGS} -o object/libraw_c_api_mt.o src/libraw_c_api.cpp
++ ${CXX} -c -DLIBRAW_THREADS ${PTHREAD_CFLAGS} ${CFLAGS} -o object/libraw_c_api_mt.o src/libraw_c_api.cpp
+
+ clean:
+ rm -fr bin/*.dSYM
diff --git a/graphics/libraw/pkg-descr b/graphics/libraw/pkg-descr
new file mode 100644
index 000000000000..29b3df4e0010
--- /dev/null
+++ b/graphics/libraw/pkg-descr
@@ -0,0 +1,14 @@
+LibRaw is a library for reading RAW files obtained from digital photo
+cameras (CRW/CR2, NEF, RAF, DNG, and others).
+
+LibRaw is based on the source codes of the dcraw utility, where part
+of drawbacks have already been eliminated and part will be fixed in
+future. The users of the library are provided with API to be built
+into their software programs.
+
+LibRaw is intended to be used in any software that involves RAW file
+processing for a variety of purposes: RAW converters, data analyzers,
+panorama stitchers, noise suppressors, etc.
+
+WWW: http://www.libraw.org/
+ http://www.libraw.su/
diff --git a/graphics/libraw/pkg-plist b/graphics/libraw/pkg-plist
new file mode 100644
index 000000000000..7e3266cbc3ec
--- /dev/null
+++ b/graphics/libraw/pkg-plist
@@ -0,0 +1,13 @@
+include/libraw/libraw.h
+include/libraw/libraw_alloc.h
+include/libraw/libraw_const.h
+include/libraw/libraw_internal.h
+include/libraw/libraw_io.h
+include/libraw/libraw_types.h
+lib/libraw.a
+lib/libraw.so
+lib/libraw.so.0
+lib/libraw_r.a
+lib/libraw_r.so
+lib/libraw_r.so.0
+@dirrm include/libraw