aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjadawin <jadawin@FreeBSD.org>2009-02-04 17:55:27 +0800
committerjadawin <jadawin@FreeBSD.org>2009-02-04 17:55:27 +0800
commita8246fd451737cbbb48dd9e087b444687e475039 (patch)
tree7d3067fc6acb7ad87cd63fadf1ad60618ef4df62
parent73de4609514e1d0f06aba3607e057a85af797e5c (diff)
downloadfreebsd-ports-gnome-a8246fd451737cbbb48dd9e087b444687e475039.tar.gz
freebsd-ports-gnome-a8246fd451737cbbb48dd9e087b444687e475039.tar.zst
freebsd-ports-gnome-a8246fd451737cbbb48dd9e087b444687e475039.zip
aspects is a lightweight approach to aspect oriented programming (AOP) in
Python.The aspects.py library provides means to intercept function calls. Functions and methods (also in Python standard library and third party code) can be wrapped so that when they are called, the wrap is invoked first. WWW: http://www.cs.tut.fi/~ask/aspects/index.shtml PR: ports/131319 Submitted by: Sofian Brabez <sbrabez at gmail.com>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-aspects/Makefile46
-rw-r--r--devel/py-aspects/distinfo3
-rw-r--r--devel/py-aspects/files/pkg-message.in8
-rw-r--r--devel/py-aspects/pkg-descr6
-rw-r--r--devel/py-aspects/pkg-plist11
6 files changed, 75 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 990b8b72fc5a..4d74d5fd8f79 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2175,6 +2175,7 @@
SUBDIR += py-anonfunc
SUBDIR += py-argparse
SUBDIR += py-asn1
+ SUBDIR += py-aspects
SUBDIR += py-astng
SUBDIR += py-babel
SUBDIR += py-bison
diff --git a/devel/py-aspects/Makefile b/devel/py-aspects/Makefile
new file mode 100644
index 000000000000..0481ac90260b
--- /dev/null
+++ b/devel/py-aspects/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: py-aspects
+# Date created: 2009-02-02
+# Whom: Sofian Brabez <sbrabez@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= aspects
+PORTVERSION= 1.3
+CATEGORIES= devel python
+MASTER_SITES= http://www.cs.tut.fi/~ask/aspects/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= python-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= sbrabez@gmail.com
+COMMENT= Lightweight aspect oriented programming library for Python
+
+USE_GMAKE= yes
+USE_PYTHON= 2.5+
+USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= python-${PORTNAME}
+
+PKGMESSAGE= ${WRKDIR}/pkg-message
+SUB_FILES= pkg-message
+
+EXAMPLESFILES= httpget_example.py timeout_advice.py timeout_example.py \
+ tracer_advice.py tracer_example.py typecheck_advice.py \
+ typecheck_example.py
+EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
+
+do-build:
+ @${GMAKE} -C ${WRKSRC} check
+
+.if !defined(NOPORTEXAMPLES)
+post-install:
+ @${MKDIR} ${EXAMPLESDIR}
+.for f in ${EXAMPLESFILES}
+ @${INSTALL_DATA} ${WRKSRC}/examples/${f} ${EXAMPLESDIR}
+.endfor
+.endif
+
+.if !defined(BATCH)
+ @${CAT} ${PKGMESSAGE}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/py-aspects/distinfo b/devel/py-aspects/distinfo
new file mode 100644
index 000000000000..6ba485c68169
--- /dev/null
+++ b/devel/py-aspects/distinfo
@@ -0,0 +1,3 @@
+MD5 (python-aspects-1.3.tar.gz) = ecbd94aa358f2e21675a88943a175ee2
+SHA256 (python-aspects-1.3.tar.gz) = c012fadc798c3fa0f43b30193d7c0fddcbc0f003f3b51c80d4519112ee15d3ed
+SIZE (python-aspects-1.3.tar.gz) = 24485
diff --git a/devel/py-aspects/files/pkg-message.in b/devel/py-aspects/files/pkg-message.in
new file mode 100644
index 000000000000..a5b8f2e9ab38
--- /dev/null
+++ b/devel/py-aspects/files/pkg-message.in
@@ -0,0 +1,8 @@
+-------------------------------------------------------------
+aspects is installed.
+
+For a quick start:
+ - examples files are in PREFIX/share/examples/py-aspects/
+ - import aspects for using the module
+
+-------------------------------------------------------------
diff --git a/devel/py-aspects/pkg-descr b/devel/py-aspects/pkg-descr
new file mode 100644
index 000000000000..327ea80a77f6
--- /dev/null
+++ b/devel/py-aspects/pkg-descr
@@ -0,0 +1,6 @@
+aspects is a lightweight approach to aspect oriented programming (AOP) in
+Python.The aspects.py library provides means to intercept function calls.
+Functions and methods (also in Python standard library and third party code)
+can be wrapped so that when they are called, the wrap is invoked first.
+
+WWW: http://www.cs.tut.fi/~ask/aspects/index.shtml
diff --git a/devel/py-aspects/pkg-plist b/devel/py-aspects/pkg-plist
new file mode 100644
index 000000000000..19ad1bf0c7c5
--- /dev/null
+++ b/devel/py-aspects/pkg-plist
@@ -0,0 +1,11 @@
+%%PYTHON_SITELIBDIR%%/aspects.py
+%%PYTHON_SITELIBDIR%%/aspects.pyc
+%%PYTHON_SITELIBDIR%%/aspects.pyo
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/httpget_example.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/timeout_advice.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/timeout_example.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tracer_advice.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tracer_example.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/typecheck_advice.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/typecheck_example.py
+@dirrm %%EXAMPLESDIR%%