aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2014-02-06 04:03:02 +0800
committersunpoet <sunpoet@FreeBSD.org>2014-02-06 04:03:02 +0800
commita83eeb84763149d814ad8e0e4a6bdb8e5e9a644b (patch)
tree951988c1d145619f4fcfd6191f59f05f8ea933d3
parentb92898d4a7fde2735430121b17a60a357d17bb67 (diff)
downloadfreebsd-ports-gnome-a83eeb84763149d814ad8e0e4a6bdb8e5e9a644b.tar.gz
freebsd-ports-gnome-a83eeb84763149d814ad8e0e4a6bdb8e5e9a644b.tar.zst
freebsd-ports-gnome-a83eeb84763149d814ad8e0e4a6bdb8e5e9a644b.zip
- Add php-scalar_objects 0.0.20140124
Add support for method calls on primitive types in PHP This extension implements the ability to register a class that handles the method calls to a certain primitive type (string, array, ...). As such it allows implementing APIs like $str->length(). The main purpose of this repo is to provide a proof of concept implementation that can be used to design the new APIs. The switch to object syntax for operations on primitive types is a unique opportunity for PHP to redesign many of its inconsistent core APIs. This repo provides the means to quickly prototype and test new APIs as userland code. Once the APIs are figured out it will be proposed for inclusion into PHP. Note: The ability to register type handlers from userland is just for prototyping. WWW: https://github.com/nikic/scalar_objects PR: ports/186221 Submitted by: Gasol Wu <gasol.wu@gmail.com>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/php-scalar_objects/Makefile25
-rw-r--r--devel/php-scalar_objects/distinfo2
-rw-r--r--devel/php-scalar_objects/pkg-descr17
4 files changed, 45 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index d66aeab266bd..383f7744bf9e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3322,6 +3322,7 @@
SUBDIR += php-java-bridge
SUBDIR += php-libawl
SUBDIR += php-memoize
+ SUBDIR += php-scalar_objects
SUBDIR += php-xdebug
SUBDIR += php5-blitz
SUBDIR += php5-blitz-devel
diff --git a/devel/php-scalar_objects/Makefile b/devel/php-scalar_objects/Makefile
new file mode 100644
index 000000000000..ce6dea228af3
--- /dev/null
+++ b/devel/php-scalar_objects/Makefile
@@ -0,0 +1,25 @@
+# Created by: Gasol Wu <gasol.wu@gmail.com>
+# $FreeBSD$
+
+PORTNAME= scalar_objects
+PORTVERSION= 0.0.20140124
+CATEGORIES= devel
+PKGNAMEPREFIX= php-
+
+MAINTAINER= gasol.wu@gmail.com
+COMMENT= Support method calls on primitive types in PHP
+
+LICENSE= PHP301
+
+USE_GITHUB= yes
+GH_ACCOUNT= nikic
+GH_PROJECT= scalar_objects
+GH_TAGNAME= ${GH_COMMIT}
+GH_COMMIT= baf4985
+
+USE_PHP= yes
+USE_PHPEXT= yes
+USE_PHPIZE= yes
+USE_PHPBUILD= yes
+
+.include <bsd.port.mk>
diff --git a/devel/php-scalar_objects/distinfo b/devel/php-scalar_objects/distinfo
new file mode 100644
index 000000000000..39453f723b3f
--- /dev/null
+++ b/devel/php-scalar_objects/distinfo
@@ -0,0 +1,2 @@
+SHA256 (scalar_objects-0.0.20140124.tar.gz) = 705e563663f3d261eaf1e9c5c4442558cddd0b18cea974c72d3a1a724c067ef7
+SIZE (scalar_objects-0.0.20140124.tar.gz) = 35121
diff --git a/devel/php-scalar_objects/pkg-descr b/devel/php-scalar_objects/pkg-descr
new file mode 100644
index 000000000000..eec81565c725
--- /dev/null
+++ b/devel/php-scalar_objects/pkg-descr
@@ -0,0 +1,17 @@
+Add support for method calls on primitive types in PHP
+
+This extension implements the ability to register a class that handles the
+method calls to a certain primitive type (string, array, ...). As such it
+allows implementing APIs like $str->length().
+
+The main purpose of this repo is to provide a proof of concept implementation
+that can be used to design the new APIs. The switch to object syntax for
+operations on primitive types is a unique opportunity for PHP to redesign many
+of its inconsistent core APIs. This repo provides the means to quickly
+prototype and test new APIs as userland code. Once the APIs are figured out it
+will be proposed for inclusion into PHP.
+
+Note: The ability to register type handlers from userland is just for
+prototyping.
+
+WWW: https://github.com/nikic/scalar_objects