aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2013-05-14 16:54:24 +0800
committergahr <gahr@FreeBSD.org>2013-05-14 16:54:24 +0800
commita96c4903631351a265728620e19333b71de5c32e (patch)
tree3b7a2f9dc23f94cfd0b98afa4b24ede62b6154e7
parent1fedaf9ae15aeed01040785bd90c1d6dd0e17718 (diff)
downloadfreebsd-ports-gnome-a96c4903631351a265728620e19333b71de5c32e.tar.gz
freebsd-ports-gnome-a96c4903631351a265728620e19333b71de5c32e.tar.zst
freebsd-ports-gnome-a96c4903631351a265728620e19333b71de5c32e.zip
- Fix build
Reported by: miwi (Tcl/Tk 86 exp-run)
-rw-r--r--mail/zmailer/Makefile12
-rw-r--r--mail/zmailer/files/patch-include_listutils.h20
-rw-r--r--mail/zmailer/files/patch-libsh_listmalloc.c11
3 files changed, 34 insertions, 9 deletions
diff --git a/mail/zmailer/Makefile b/mail/zmailer/Makefile
index 0582285d0111..868a54a88cdb 100644
--- a/mail/zmailer/Makefile
+++ b/mail/zmailer/Makefile
@@ -20,7 +20,7 @@ USE_PERL5= yes
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MSSL}
+.if !${PORT_OPTIONS:MSSL}
CONFIGURE_ARGS= --without-openssl
.else
.include "${PORTSDIR}/Mk/bsd.openssl.mk"
@@ -61,20 +61,14 @@ SUB_FILES= pkg-install
PKGINSTALL= ${WRKDIR}/pkg-install
USE_RC_SUBR= zmailer
-# local variable (we can't use ${SED} here)
-DOMAIN!= /bin/hostname | ${SED} -e "s:^"`/bin/hostname -s`"\.*::g"
-.if (${DOMAIN} == "")
-DOMAIN= "mydomain.com"
-.endif
-
pre-install:
- cd ${WRKSRC}/man && make install
+ cd ${WRKSRC}/man && make ${INSTALL_TARGET}
post-install:
@${SETENV} PREFIX="${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
# set up the initial mail.conf with reasonable settings.
@${ECHO_CMD} "# Where am I?" > ${PREFIX}/etc/zmailer/mail.conf.sample
- @${ECHO_CMD} "orgdomain="${DOMAIN} >> ${PREFIX}/etc/zmailer/mail.conf.sample
+ @${ECHO_CMD} "orgdomain="`/bin/hostname | cut -d '.' -f 2-` >> ${PREFIX}/etc/zmailer/mail.conf.sample
@${ECHO_CMD} "# Who am I?" >> ${PREFIX}/etc/zmailer/mail.conf.sample
@${ECHO_CMD} "hostname="`/bin/hostname -s`'.$$orgdomain' >> ${PREFIX}/etc/zmailer/mail.conf.sample
@${ECHO_CMD} "# Who do I claim to be?" >> ${PREFIX}/etc/zmailer/mail.conf.sample
diff --git a/mail/zmailer/files/patch-include_listutils.h b/mail/zmailer/files/patch-include_listutils.h
new file mode 100644
index 000000000000..17e9affe6005
--- /dev/null
+++ b/mail/zmailer/files/patch-include_listutils.h
@@ -0,0 +1,20 @@
+--- include/listutils.h.orig 2007-06-29 01:06:06.000000000 +0200
++++ include/listutils.h 2013-05-14 10:21:40.000000000 +0200
+@@ -64,7 +64,7 @@
+
+ /* #undef __GNUC__ */
+
+-#if defined(__GNUC__) && !defined(PROFILING) && defined(__OPTIMIZE__)
++#if defined(__GNUC__) && !defined(PROFILING) && defined(__OPTIMIZE__) && 0
+
+ #ifndef EXTINLINE
+ #define EXTINLINE extern __inline__
+@@ -166,7 +166,7 @@
+
+ #else /* ---- not profiling ---- */
+
+-#if defined(__GNUC__) && !defined(PROFILING) && defined(__OPTIMIZE__)
++#if defined(__GNUC__) && !defined(PROFILING) && defined(__OPTIMIZE__) && 0
+
+ EXTINLINE conscell *copycell(conscell *X) {
+ conscell *tmp = newcell();
diff --git a/mail/zmailer/files/patch-libsh_listmalloc.c b/mail/zmailer/files/patch-libsh_listmalloc.c
new file mode 100644
index 000000000000..be72ee4ffd92
--- /dev/null
+++ b/mail/zmailer/files/patch-libsh_listmalloc.c
@@ -0,0 +1,11 @@
+--- libsh/listmalloc.c.orig 2013-05-14 09:22:34.000000000 +0200
++++ libsh/listmalloc.c 2013-05-14 10:13:43.000000000 +0200
+@@ -273,7 +273,7 @@
+
+ if (depth > deepest_dsw)
+ deepest_dsw = depth;
+- if (depth > 20) *(long*)0 = 0; /* ZAP! */
++ if (depth > 20) abort(); /* ZAP! */
+ while (current && !(current->flags & DSW_MARKER)) {
+ current->flags |= DSW_MARKER;
+ if (!STRING(current))