aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2007-10-30 03:36:50 +0800
committerbeech <beech@FreeBSD.org>2007-10-30 03:36:50 +0800
commita9ffdf56b3299edac5a9aed644df458e45a0e686 (patch)
tree844bc3a60a8f4d4ef35e2ce729a9ba485f0134dc
parent5b06351886a5793438b77f9a551609ca64afb110 (diff)
downloadfreebsd-ports-gnome-a9ffdf56b3299edac5a9aed644df458e45a0e686.tar.gz
freebsd-ports-gnome-a9ffdf56b3299edac5a9aed644df458e45a0e686.tar.zst
freebsd-ports-gnome-a9ffdf56b3299edac5a9aed644df458e45a0e686.zip
- Update to 1.4.0.118
Approved by: sat (mentor)
-rw-r--r--net-im/skype/Makefile59
-rw-r--r--net-im/skype/distinfo6
-rw-r--r--net-im/skype/pkg-plist69
-rw-r--r--net-im/skype20/Makefile59
-rw-r--r--net-im/skype20/distinfo6
-rw-r--r--net-im/skype20/pkg-plist69
-rw-r--r--net/skype/Makefile59
-rw-r--r--net/skype/distinfo6
-rw-r--r--net/skype/pkg-plist69
9 files changed, 186 insertions, 216 deletions
diff --git a/net-im/skype/Makefile b/net-im/skype/Makefile
index 2e22e7421245..9c860c623027 100644
--- a/net-im/skype/Makefile
+++ b/net-im/skype/Makefile
@@ -6,55 +6,42 @@
#
PORTNAME= skype
-PORTVERSION= 1.2.0.18
-PORTREVISION= 4
+PORTVERSION= 1.4.0.118
CATEGORIES= net
-MASTER_SITES= NETBSD
-DISTNAME= skype_staticQT-${PORTVERSION}
+MASTER_SITES= http://download.skype.com/linux/
+DISTNAME= skype_static-${DISTVERSION}-oss
MAINTAINER= beech@FreeBSD.org
COMMENT= P2P VoIP software
RUN_DEPENDS= ${LINUXBASE}/usr/lib/libfontconfig.so.1:${PORTSDIR}/x11-fonts/linux-fontconfig \
- ${LINUXBASE}/usr/lib/libexpat.so.0:${PORTSDIR}/textproc/linux-expat
+ ${LINUXBASE}/usr/lib/libexpat.so.0:${PORTSDIR}/textproc/linux-expat \
+ ${LINUXBASE}/usr/lib/libsigc-2.0.so.0:${PORTSDIR}/devel/linux-libsigc++20
-USE_BZIP2= yes
-USE_LINUX= yes
-USE_X_PREFIX= yes
-ONLY_FOR_ARCHS= i386 amd64
-
-RESTRICTED= Redistribution not allowed.
-
-OPTIONS= NVIDIA_GL "Enable Nvidia Support" off
-
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_NVIDIA_GL)
+.ifdef WITH_NVIDIA_GL
RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
.else
-RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
+USE_GL= linux
.endif
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USE_BZIP2= yes
+USE_LINUX= yes
+ONLY_FOR_ARCHS= i386
+
+RESTRICTED= Redistribution not allowed
+
+WRKSRC= ${WRKDIR}/${PORTNAME}_static-${DISTVERSION}-oss
+DATADIR= ${PREFIX}/share/${PKGBASE}
do-build:
- ${BRANDELF} -t Linux ${WRKSRC}/skype
+ @${BRANDELF} -t Linux ${WRKSRC}/skype
do-install:
- @${MKDIR} ${PREFIX}/share/applications
- @${INSTALL} ${WRKSRC}/skype ${PREFIX}/bin/skype_bin
-# ${INSTALL} ${WRKSRC}/skype-callto-handler ${PREFIX}/bin/
- @${ECHO_CMD} -e "#!/bin/sh\n\nSKYPE_RESOURCES_PATH='${DATADIR}' skype_bin \"\$$@\" 2>&1 | grep -v 'SOUND_MIXER_WRITE_IGAIN failed'" >${PREFIX}/bin/skype
+ @${INSTALL} -d ${PREFIX}/share/applications
+ @${INSTALL} ${WRKSRC}/skype.desktop ${PREFIX}/share/applications/
+ @${INSTALL_PROGRAM} ${WRKSRC}/skype ${PREFIX}/bin/skype
@${CHMOD} a+rx ${PREFIX}/bin/skype
- @${INSTALL_DATA} ${WRKSRC}/skype.desktop ${PREFIX}/share/applications/
- @${INSTALL_DATA} ${WRKSRC}/icons/skype_48_32.png ${PREFIX}/share/pixmaps/skype.png
- @${INSTALL} -d ${DATADIR}/icons ${DATADIR}/lang ${DATADIR}/sound
- @${INSTALL_DATA} ${WRKSRC}/icons/* ${DATADIR}/icons/
- @${INSTALL_DATA} ${WRKSRC}/lang/*.qm ${DATADIR}/lang/
- @${INSTALL_DATA} ${WRKSRC}/sound/*.wav ${DATADIR}/sound/
- @${INSTALL_DATA} ${WRKSRC}/LICENSE ${DATADIR}/
-
-post-install:
- @${ECHO} "There are known problems with some soundcards in 5.x. This is due to a bug in the kernel. It is fixed in 6.x. Additionally there is some further work in the sound subsystem going on which fixes some related problems. This work will not be available in 6.0-RELEASE. If you experience problems update to the most recent 6.x-RELEASE, if this does not fix your problems ask on multimedia@FreeBSD.org." | fmt
-
-.include <bsd.port.post.mk>
+ @cd ${WRKSRC}/&&${COPYTREE_SHARE} "icons sounds lang LICENSE README" ${DATADIR}/
+ @${ECHO} "There are known problems with some soundcards in 5.x. This is due to a bug in the kernel. If you experience problems update to the most recent FreeBSD RELEASE, if this does not fix your problems, ask on multimedia@FreeBSD.org." | fmt
+
+.include <bsd.port.mk>
diff --git a/net-im/skype/distinfo b/net-im/skype/distinfo
index 45a776b79003..af0b214afed4 100644
--- a/net-im/skype/distinfo
+++ b/net-im/skype/distinfo
@@ -1,3 +1,3 @@
-MD5 (skype_staticQT-1.2.0.18.tar.bz2) = bc05f6883e8c0350186e1a376940d5c8
-SHA256 (skype_staticQT-1.2.0.18.tar.bz2) = fa825ff455b7c6fb53bd4090e7fb99038ce426b4078b4f1dda0307fc4fa216b3
-SIZE (skype_staticQT-1.2.0.18.tar.bz2) = 10678284
+MD5 (skype_static-1.4.0.118-oss.tar.bz2) = 00813dd5db73f116fdcf19778bb1234a
+SHA256 (skype_static-1.4.0.118-oss.tar.bz2) = 606bc7ba4b73112f572608d2fd7a2829bd1c3c0c9891063aee9bbeebfbf23821
+SIZE (skype_static-1.4.0.118-oss.tar.bz2) = 19595152
diff --git a/net-im/skype/pkg-plist b/net-im/skype/pkg-plist
index b7763d3ec4ac..b48ce968d735 100644
--- a/net-im/skype/pkg-plist
+++ b/net-im/skype/pkg-plist
@@ -1,40 +1,43 @@
bin/skype
-bin/skype_bin
-%%DATADIR%%/icons/skype_16_32.png
-%%DATADIR%%/icons/skype_32_32.png
-%%DATADIR%%/icons/skype_48_32.png
+%%DATADIR%%/icons/SkypeBlue_16x16.png
+%%DATADIR%%/icons/SkypeBlue_32x32.png
+%%DATADIR%%/icons/SkypeBlue_48x48.png
@dirrm %%DATADIR%%/icons
-%%DATADIR%%/lang/skype_da.qm
-%%DATADIR%%/lang/skype_de.qm
-%%DATADIR%%/lang/skype_el.qm
-%%DATADIR%%/lang/skype_en.qm
-%%DATADIR%%/lang/skype_es.qm
-%%DATADIR%%/lang/skype_es_AR.qm
-%%DATADIR%%/lang/skype_et.qm
-%%DATADIR%%/lang/skype_fi.qm
-%%DATADIR%%/lang/skype_fr.qm
-%%DATADIR%%/lang/skype_it.qm
-%%DATADIR%%/lang/skype_iw.qm
-%%DATADIR%%/lang/skype_ja.qm
-%%DATADIR%%/lang/skype_ko.qm
-%%DATADIR%%/lang/skype_nl.qm
-%%DATADIR%%/lang/skype_no.qm
-%%DATADIR%%/lang/skype_pl.qm
-%%DATADIR%%/lang/skype_pt_BR.qm
-%%DATADIR%%/lang/skype_ro.qm
-%%DATADIR%%/lang/skype_ru.qm
-%%DATADIR%%/lang/skype_sv.qm
-%%DATADIR%%/lang/skype_zh_CN.qm
-%%DATADIR%%/lang/skype_zh_TW.qm
+%%DATADIR%%/lang/skype_de.ts
+%%DATADIR%%/lang/skype_et.ts
+%%DATADIR%%/lang/skype_lv.ts
+%%DATADIR%%/lang/skype_pl.ts
+%%DATADIR%%/lang/skype_pt_pt.ts
+%%DATADIR%%/lang/skype_ro.ts
+%%DATADIR%%/lang/skype_ru.ts
+%%DATADIR%%/lang/skype_tr.ts
+%%DATADIR%%/lang/skype_zh_s.ts
+%%DATADIR%%/lang/skype_zh_t.ts
@dirrm %%DATADIR%%/lang
-%%DATADIR%%/sound/busy4.wav
-%%DATADIR%%/sound/call_in.wav
-%%DATADIR%%/sound/call_out.wav
-%%DATADIR%%/sound/hangup.wav
-%%DATADIR%%/sound/im.wav
-@dirrm %%DATADIR%%/sound
+%%DATADIR%%/sounds/CallBusy.wav
+%%DATADIR%%/sounds/CallConnecting.wav
+%%DATADIR%%/sounds/CallHangup.wav
+%%DATADIR%%/sounds/CallHold.wav
+%%DATADIR%%/sounds/CallRemoteHangup.wav
+%%DATADIR%%/sounds/CallResume.wav
+%%DATADIR%%/sounds/CallRingingIn.wav
+%%DATADIR%%/sounds/CallRingingOut.wav
+%%DATADIR%%/sounds/ChatIncoming.wav
+%%DATADIR%%/sounds/ChatIncomingInitial.wav
+%%DATADIR%%/sounds/ChatOutgoing.wav
+%%DATADIR%%/sounds/ContactAdded.wav
+%%DATADIR%%/sounds/ContactAuthRequest.wav
+%%DATADIR%%/sounds/ContactOffline.wav
+%%DATADIR%%/sounds/ContactOnline.wav
+%%DATADIR%%/sounds/SkypeLogin.wav
+%%DATADIR%%/sounds/SkypeLogout.wav
+%%DATADIR%%/sounds/TransferComplete.wav
+%%DATADIR%%/sounds/TransferFailed.wav
+%%DATADIR%%/sounds/TransferRequest.wav
+%%DATADIR%%/sounds/VoicemailReceived.wav
+@dirrm %%DATADIR%%/sounds
%%DATADIR%%/LICENSE
+%%DATADIR%%/README
@dirrm %%DATADIR%%
share/applications/skype.desktop
-share/pixmaps/skype.png
@dirrmtry share/applications
diff --git a/net-im/skype20/Makefile b/net-im/skype20/Makefile
index 2e22e7421245..9c860c623027 100644
--- a/net-im/skype20/Makefile
+++ b/net-im/skype20/Makefile
@@ -6,55 +6,42 @@
#
PORTNAME= skype
-PORTVERSION= 1.2.0.18
-PORTREVISION= 4
+PORTVERSION= 1.4.0.118
CATEGORIES= net
-MASTER_SITES= NETBSD
-DISTNAME= skype_staticQT-${PORTVERSION}
+MASTER_SITES= http://download.skype.com/linux/
+DISTNAME= skype_static-${DISTVERSION}-oss
MAINTAINER= beech@FreeBSD.org
COMMENT= P2P VoIP software
RUN_DEPENDS= ${LINUXBASE}/usr/lib/libfontconfig.so.1:${PORTSDIR}/x11-fonts/linux-fontconfig \
- ${LINUXBASE}/usr/lib/libexpat.so.0:${PORTSDIR}/textproc/linux-expat
+ ${LINUXBASE}/usr/lib/libexpat.so.0:${PORTSDIR}/textproc/linux-expat \
+ ${LINUXBASE}/usr/lib/libsigc-2.0.so.0:${PORTSDIR}/devel/linux-libsigc++20
-USE_BZIP2= yes
-USE_LINUX= yes
-USE_X_PREFIX= yes
-ONLY_FOR_ARCHS= i386 amd64
-
-RESTRICTED= Redistribution not allowed.
-
-OPTIONS= NVIDIA_GL "Enable Nvidia Support" off
-
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_NVIDIA_GL)
+.ifdef WITH_NVIDIA_GL
RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
.else
-RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
+USE_GL= linux
.endif
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USE_BZIP2= yes
+USE_LINUX= yes
+ONLY_FOR_ARCHS= i386
+
+RESTRICTED= Redistribution not allowed
+
+WRKSRC= ${WRKDIR}/${PORTNAME}_static-${DISTVERSION}-oss
+DATADIR= ${PREFIX}/share/${PKGBASE}
do-build:
- ${BRANDELF} -t Linux ${WRKSRC}/skype
+ @${BRANDELF} -t Linux ${WRKSRC}/skype
do-install:
- @${MKDIR} ${PREFIX}/share/applications
- @${INSTALL} ${WRKSRC}/skype ${PREFIX}/bin/skype_bin
-# ${INSTALL} ${WRKSRC}/skype-callto-handler ${PREFIX}/bin/
- @${ECHO_CMD} -e "#!/bin/sh\n\nSKYPE_RESOURCES_PATH='${DATADIR}' skype_bin \"\$$@\" 2>&1 | grep -v 'SOUND_MIXER_WRITE_IGAIN failed'" >${PREFIX}/bin/skype
+ @${INSTALL} -d ${PREFIX}/share/applications
+ @${INSTALL} ${WRKSRC}/skype.desktop ${PREFIX}/share/applications/
+ @${INSTALL_PROGRAM} ${WRKSRC}/skype ${PREFIX}/bin/skype
@${CHMOD} a+rx ${PREFIX}/bin/skype
- @${INSTALL_DATA} ${WRKSRC}/skype.desktop ${PREFIX}/share/applications/
- @${INSTALL_DATA} ${WRKSRC}/icons/skype_48_32.png ${PREFIX}/share/pixmaps/skype.png
- @${INSTALL} -d ${DATADIR}/icons ${DATADIR}/lang ${DATADIR}/sound
- @${INSTALL_DATA} ${WRKSRC}/icons/* ${DATADIR}/icons/
- @${INSTALL_DATA} ${WRKSRC}/lang/*.qm ${DATADIR}/lang/
- @${INSTALL_DATA} ${WRKSRC}/sound/*.wav ${DATADIR}/sound/
- @${INSTALL_DATA} ${WRKSRC}/LICENSE ${DATADIR}/
-
-post-install:
- @${ECHO} "There are known problems with some soundcards in 5.x. This is due to a bug in the kernel. It is fixed in 6.x. Additionally there is some further work in the sound subsystem going on which fixes some related problems. This work will not be available in 6.0-RELEASE. If you experience problems update to the most recent 6.x-RELEASE, if this does not fix your problems ask on multimedia@FreeBSD.org." | fmt
-
-.include <bsd.port.post.mk>
+ @cd ${WRKSRC}/&&${COPYTREE_SHARE} "icons sounds lang LICENSE README" ${DATADIR}/
+ @${ECHO} "There are known problems with some soundcards in 5.x. This is due to a bug in the kernel. If you experience problems update to the most recent FreeBSD RELEASE, if this does not fix your problems, ask on multimedia@FreeBSD.org." | fmt
+
+.include <bsd.port.mk>
diff --git a/net-im/skype20/distinfo b/net-im/skype20/distinfo
index 45a776b79003..af0b214afed4 100644
--- a/net-im/skype20/distinfo
+++ b/net-im/skype20/distinfo
@@ -1,3 +1,3 @@
-MD5 (skype_staticQT-1.2.0.18.tar.bz2) = bc05f6883e8c0350186e1a376940d5c8
-SHA256 (skype_staticQT-1.2.0.18.tar.bz2) = fa825ff455b7c6fb53bd4090e7fb99038ce426b4078b4f1dda0307fc4fa216b3
-SIZE (skype_staticQT-1.2.0.18.tar.bz2) = 10678284
+MD5 (skype_static-1.4.0.118-oss.tar.bz2) = 00813dd5db73f116fdcf19778bb1234a
+SHA256 (skype_static-1.4.0.118-oss.tar.bz2) = 606bc7ba4b73112f572608d2fd7a2829bd1c3c0c9891063aee9bbeebfbf23821
+SIZE (skype_static-1.4.0.118-oss.tar.bz2) = 19595152
diff --git a/net-im/skype20/pkg-plist b/net-im/skype20/pkg-plist
index b7763d3ec4ac..b48ce968d735 100644
--- a/net-im/skype20/pkg-plist
+++ b/net-im/skype20/pkg-plist
@@ -1,40 +1,43 @@
bin/skype
-bin/skype_bin
-%%DATADIR%%/icons/skype_16_32.png
-%%DATADIR%%/icons/skype_32_32.png
-%%DATADIR%%/icons/skype_48_32.png
+%%DATADIR%%/icons/SkypeBlue_16x16.png
+%%DATADIR%%/icons/SkypeBlue_32x32.png
+%%DATADIR%%/icons/SkypeBlue_48x48.png
@dirrm %%DATADIR%%/icons
-%%DATADIR%%/lang/skype_da.qm
-%%DATADIR%%/lang/skype_de.qm
-%%DATADIR%%/lang/skype_el.qm
-%%DATADIR%%/lang/skype_en.qm
-%%DATADIR%%/lang/skype_es.qm
-%%DATADIR%%/lang/skype_es_AR.qm
-%%DATADIR%%/lang/skype_et.qm
-%%DATADIR%%/lang/skype_fi.qm
-%%DATADIR%%/lang/skype_fr.qm
-%%DATADIR%%/lang/skype_it.qm
-%%DATADIR%%/lang/skype_iw.qm
-%%DATADIR%%/lang/skype_ja.qm
-%%DATADIR%%/lang/skype_ko.qm
-%%DATADIR%%/lang/skype_nl.qm
-%%DATADIR%%/lang/skype_no.qm
-%%DATADIR%%/lang/skype_pl.qm
-%%DATADIR%%/lang/skype_pt_BR.qm
-%%DATADIR%%/lang/skype_ro.qm
-%%DATADIR%%/lang/skype_ru.qm
-%%DATADIR%%/lang/skype_sv.qm
-%%DATADIR%%/lang/skype_zh_CN.qm
-%%DATADIR%%/lang/skype_zh_TW.qm
+%%DATADIR%%/lang/skype_de.ts
+%%DATADIR%%/lang/skype_et.ts
+%%DATADIR%%/lang/skype_lv.ts
+%%DATADIR%%/lang/skype_pl.ts
+%%DATADIR%%/lang/skype_pt_pt.ts
+%%DATADIR%%/lang/skype_ro.ts
+%%DATADIR%%/lang/skype_ru.ts
+%%DATADIR%%/lang/skype_tr.ts
+%%DATADIR%%/lang/skype_zh_s.ts
+%%DATADIR%%/lang/skype_zh_t.ts
@dirrm %%DATADIR%%/lang
-%%DATADIR%%/sound/busy4.wav
-%%DATADIR%%/sound/call_in.wav
-%%DATADIR%%/sound/call_out.wav
-%%DATADIR%%/sound/hangup.wav
-%%DATADIR%%/sound/im.wav
-@dirrm %%DATADIR%%/sound
+%%DATADIR%%/sounds/CallBusy.wav
+%%DATADIR%%/sounds/CallConnecting.wav
+%%DATADIR%%/sounds/CallHangup.wav
+%%DATADIR%%/sounds/CallHold.wav
+%%DATADIR%%/sounds/CallRemoteHangup.wav
+%%DATADIR%%/sounds/CallResume.wav
+%%DATADIR%%/sounds/CallRingingIn.wav
+%%DATADIR%%/sounds/CallRingingOut.wav
+%%DATADIR%%/sounds/ChatIncoming.wav
+%%DATADIR%%/sounds/ChatIncomingInitial.wav
+%%DATADIR%%/sounds/ChatOutgoing.wav
+%%DATADIR%%/sounds/ContactAdded.wav
+%%DATADIR%%/sounds/ContactAuthRequest.wav
+%%DATADIR%%/sounds/ContactOffline.wav
+%%DATADIR%%/sounds/ContactOnline.wav
+%%DATADIR%%/sounds/SkypeLogin.wav
+%%DATADIR%%/sounds/SkypeLogout.wav
+%%DATADIR%%/sounds/TransferComplete.wav
+%%DATADIR%%/sounds/TransferFailed.wav
+%%DATADIR%%/sounds/TransferRequest.wav
+%%DATADIR%%/sounds/VoicemailReceived.wav
+@dirrm %%DATADIR%%/sounds
%%DATADIR%%/LICENSE
+%%DATADIR%%/README
@dirrm %%DATADIR%%
share/applications/skype.desktop
-share/pixmaps/skype.png
@dirrmtry share/applications
diff --git a/net/skype/Makefile b/net/skype/Makefile
index 2e22e7421245..9c860c623027 100644
--- a/net/skype/Makefile
+++ b/net/skype/Makefile
@@ -6,55 +6,42 @@
#
PORTNAME= skype
-PORTVERSION= 1.2.0.18
-PORTREVISION= 4
+PORTVERSION= 1.4.0.118
CATEGORIES= net
-MASTER_SITES= NETBSD
-DISTNAME= skype_staticQT-${PORTVERSION}
+MASTER_SITES= http://download.skype.com/linux/
+DISTNAME= skype_static-${DISTVERSION}-oss
MAINTAINER= beech@FreeBSD.org
COMMENT= P2P VoIP software
RUN_DEPENDS= ${LINUXBASE}/usr/lib/libfontconfig.so.1:${PORTSDIR}/x11-fonts/linux-fontconfig \
- ${LINUXBASE}/usr/lib/libexpat.so.0:${PORTSDIR}/textproc/linux-expat
+ ${LINUXBASE}/usr/lib/libexpat.so.0:${PORTSDIR}/textproc/linux-expat \
+ ${LINUXBASE}/usr/lib/libsigc-2.0.so.0:${PORTSDIR}/devel/linux-libsigc++20
-USE_BZIP2= yes
-USE_LINUX= yes
-USE_X_PREFIX= yes
-ONLY_FOR_ARCHS= i386 amd64
-
-RESTRICTED= Redistribution not allowed.
-
-OPTIONS= NVIDIA_GL "Enable Nvidia Support" off
-
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_NVIDIA_GL)
+.ifdef WITH_NVIDIA_GL
RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
.else
-RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
+USE_GL= linux
.endif
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USE_BZIP2= yes
+USE_LINUX= yes
+ONLY_FOR_ARCHS= i386
+
+RESTRICTED= Redistribution not allowed
+
+WRKSRC= ${WRKDIR}/${PORTNAME}_static-${DISTVERSION}-oss
+DATADIR= ${PREFIX}/share/${PKGBASE}
do-build:
- ${BRANDELF} -t Linux ${WRKSRC}/skype
+ @${BRANDELF} -t Linux ${WRKSRC}/skype
do-install:
- @${MKDIR} ${PREFIX}/share/applications
- @${INSTALL} ${WRKSRC}/skype ${PREFIX}/bin/skype_bin
-# ${INSTALL} ${WRKSRC}/skype-callto-handler ${PREFIX}/bin/
- @${ECHO_CMD} -e "#!/bin/sh\n\nSKYPE_RESOURCES_PATH='${DATADIR}' skype_bin \"\$$@\" 2>&1 | grep -v 'SOUND_MIXER_WRITE_IGAIN failed'" >${PREFIX}/bin/skype
+ @${INSTALL} -d ${PREFIX}/share/applications
+ @${INSTALL} ${WRKSRC}/skype.desktop ${PREFIX}/share/applications/
+ @${INSTALL_PROGRAM} ${WRKSRC}/skype ${PREFIX}/bin/skype
@${CHMOD} a+rx ${PREFIX}/bin/skype
- @${INSTALL_DATA} ${WRKSRC}/skype.desktop ${PREFIX}/share/applications/
- @${INSTALL_DATA} ${WRKSRC}/icons/skype_48_32.png ${PREFIX}/share/pixmaps/skype.png
- @${INSTALL} -d ${DATADIR}/icons ${DATADIR}/lang ${DATADIR}/sound
- @${INSTALL_DATA} ${WRKSRC}/icons/* ${DATADIR}/icons/
- @${INSTALL_DATA} ${WRKSRC}/lang/*.qm ${DATADIR}/lang/
- @${INSTALL_DATA} ${WRKSRC}/sound/*.wav ${DATADIR}/sound/
- @${INSTALL_DATA} ${WRKSRC}/LICENSE ${DATADIR}/
-
-post-install:
- @${ECHO} "There are known problems with some soundcards in 5.x. This is due to a bug in the kernel. It is fixed in 6.x. Additionally there is some further work in the sound subsystem going on which fixes some related problems. This work will not be available in 6.0-RELEASE. If you experience problems update to the most recent 6.x-RELEASE, if this does not fix your problems ask on multimedia@FreeBSD.org." | fmt
-
-.include <bsd.port.post.mk>
+ @cd ${WRKSRC}/&&${COPYTREE_SHARE} "icons sounds lang LICENSE README" ${DATADIR}/
+ @${ECHO} "There are known problems with some soundcards in 5.x. This is due to a bug in the kernel. If you experience problems update to the most recent FreeBSD RELEASE, if this does not fix your problems, ask on multimedia@FreeBSD.org." | fmt
+
+.include <bsd.port.mk>
diff --git a/net/skype/distinfo b/net/skype/distinfo
index 45a776b79003..af0b214afed4 100644
--- a/net/skype/distinfo
+++ b/net/skype/distinfo
@@ -1,3 +1,3 @@
-MD5 (skype_staticQT-1.2.0.18.tar.bz2) = bc05f6883e8c0350186e1a376940d5c8
-SHA256 (skype_staticQT-1.2.0.18.tar.bz2) = fa825ff455b7c6fb53bd4090e7fb99038ce426b4078b4f1dda0307fc4fa216b3
-SIZE (skype_staticQT-1.2.0.18.tar.bz2) = 10678284
+MD5 (skype_static-1.4.0.118-oss.tar.bz2) = 00813dd5db73f116fdcf19778bb1234a
+SHA256 (skype_static-1.4.0.118-oss.tar.bz2) = 606bc7ba4b73112f572608d2fd7a2829bd1c3c0c9891063aee9bbeebfbf23821
+SIZE (skype_static-1.4.0.118-oss.tar.bz2) = 19595152
diff --git a/net/skype/pkg-plist b/net/skype/pkg-plist
index b7763d3ec4ac..b48ce968d735 100644
--- a/net/skype/pkg-plist
+++ b/net/skype/pkg-plist
@@ -1,40 +1,43 @@
bin/skype
-bin/skype_bin
-%%DATADIR%%/icons/skype_16_32.png
-%%DATADIR%%/icons/skype_32_32.png
-%%DATADIR%%/icons/skype_48_32.png
+%%DATADIR%%/icons/SkypeBlue_16x16.png
+%%DATADIR%%/icons/SkypeBlue_32x32.png
+%%DATADIR%%/icons/SkypeBlue_48x48.png
@dirrm %%DATADIR%%/icons
-%%DATADIR%%/lang/skype_da.qm
-%%DATADIR%%/lang/skype_de.qm
-%%DATADIR%%/lang/skype_el.qm
-%%DATADIR%%/lang/skype_en.qm
-%%DATADIR%%/lang/skype_es.qm
-%%DATADIR%%/lang/skype_es_AR.qm
-%%DATADIR%%/lang/skype_et.qm
-%%DATADIR%%/lang/skype_fi.qm
-%%DATADIR%%/lang/skype_fr.qm
-%%DATADIR%%/lang/skype_it.qm
-%%DATADIR%%/lang/skype_iw.qm
-%%DATADIR%%/lang/skype_ja.qm
-%%DATADIR%%/lang/skype_ko.qm
-%%DATADIR%%/lang/skype_nl.qm
-%%DATADIR%%/lang/skype_no.qm
-%%DATADIR%%/lang/skype_pl.qm
-%%DATADIR%%/lang/skype_pt_BR.qm
-%%DATADIR%%/lang/skype_ro.qm
-%%DATADIR%%/lang/skype_ru.qm
-%%DATADIR%%/lang/skype_sv.qm
-%%DATADIR%%/lang/skype_zh_CN.qm
-%%DATADIR%%/lang/skype_zh_TW.qm
+%%DATADIR%%/lang/skype_de.ts
+%%DATADIR%%/lang/skype_et.ts
+%%DATADIR%%/lang/skype_lv.ts
+%%DATADIR%%/lang/skype_pl.ts
+%%DATADIR%%/lang/skype_pt_pt.ts
+%%DATADIR%%/lang/skype_ro.ts
+%%DATADIR%%/lang/skype_ru.ts
+%%DATADIR%%/lang/skype_tr.ts
+%%DATADIR%%/lang/skype_zh_s.ts
+%%DATADIR%%/lang/skype_zh_t.ts
@dirrm %%DATADIR%%/lang
-%%DATADIR%%/sound/busy4.wav
-%%DATADIR%%/sound/call_in.wav
-%%DATADIR%%/sound/call_out.wav
-%%DATADIR%%/sound/hangup.wav
-%%DATADIR%%/sound/im.wav
-@dirrm %%DATADIR%%/sound
+%%DATADIR%%/sounds/CallBusy.wav
+%%DATADIR%%/sounds/CallConnecting.wav
+%%DATADIR%%/sounds/CallHangup.wav
+%%DATADIR%%/sounds/CallHold.wav
+%%DATADIR%%/sounds/CallRemoteHangup.wav
+%%DATADIR%%/sounds/CallResume.wav
+%%DATADIR%%/sounds/CallRingingIn.wav
+%%DATADIR%%/sounds/CallRingingOut.wav
+%%DATADIR%%/sounds/ChatIncoming.wav
+%%DATADIR%%/sounds/ChatIncomingInitial.wav
+%%DATADIR%%/sounds/ChatOutgoing.wav
+%%DATADIR%%/sounds/ContactAdded.wav
+%%DATADIR%%/sounds/ContactAuthRequest.wav
+%%DATADIR%%/sounds/ContactOffline.wav
+%%DATADIR%%/sounds/ContactOnline.wav
+%%DATADIR%%/sounds/SkypeLogin.wav
+%%DATADIR%%/sounds/SkypeLogout.wav
+%%DATADIR%%/sounds/TransferComplete.wav
+%%DATADIR%%/sounds/TransferFailed.wav
+%%DATADIR%%/sounds/TransferRequest.wav
+%%DATADIR%%/sounds/VoicemailReceived.wav
+@dirrm %%DATADIR%%/sounds
%%DATADIR%%/LICENSE
+%%DATADIR%%/README
@dirrm %%DATADIR%%
share/applications/skype.desktop
-share/pixmaps/skype.png
@dirrmtry share/applications