aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjoerg <joerg@FreeBSD.org>2004-04-29 04:24:39 +0800
committerjoerg <joerg@FreeBSD.org>2004-04-29 04:24:39 +0800
commitab75f9eb2d56fe700a04a43db4c016e5228c7026 (patch)
tree4416407b87966aa55d6aa97144e6a7bf3d3cdf28
parent45f14417d9f7f35b19383e06a038c018ce382f62 (diff)
downloadfreebsd-ports-gnome-ab75f9eb2d56fe700a04a43db4c016e5228c7026.tar.gz
freebsd-ports-gnome-ab75f9eb2d56fe700a04a43db4c016e5228c7026.tar.zst
freebsd-ports-gnome-ab75f9eb2d56fe700a04a43db4c016e5228c7026.zip
This is a port of GNU libbfd, the binary file descriptor library from
GNU binutils. It can read/write about any object file format on earth. Soon to be used by devel/avarice. Requires devel/gnulibiberty, since it (alas) uses undocumented internal functions from that library.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libbfd/Makefile30
-rw-r--r--devel/libbfd/distinfo2
-rw-r--r--devel/libbfd/pkg-descr4
-rw-r--r--devel/libbfd/pkg-plist5
5 files changed, 42 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 513cbadf5dd9..8df7f9837056 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -361,6 +361,7 @@
SUBDIR += libassetml
SUBDIR += libast
SUBDIR += libavl
+ SUBDIR += libbfd
SUBDIR += libbonobo
SUBDIR += libbonobomm
SUBDIR += libcache
diff --git a/devel/libbfd/Makefile b/devel/libbfd/Makefile
new file mode 100644
index 000000000000..8ce67ce92692
--- /dev/null
+++ b/devel/libbfd/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: libbfd
+# Date created: 26 Feb 2004
+# Whom: Joerg Wunsch <joerg@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libbfd
+PORTVERSION= 2.14
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEWARE}
+MASTER_SITE_SUBDIR= binutils/releases
+DISTNAME= binutils-${PORTVERSION}
+
+MAINTAINER= joerg@freebsd.org
+COMMENT= Universal BFD library from GNU binutils
+
+WRKSRC= ${WRKDIR}/binutils-${PORTVERSION}/bfd
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+CONFIGURE_ARGS= --enable-install-libbfd \
+ --enable-commonbfdlib \
+ --disable-nls \
+ --enable-targets=all
+USE_LIBTOOL= yes
+
+INFO= bfd
+
+.include <bsd.port.mk>
diff --git a/devel/libbfd/distinfo b/devel/libbfd/distinfo
new file mode 100644
index 000000000000..5e31e03c3586
--- /dev/null
+++ b/devel/libbfd/distinfo
@@ -0,0 +1,2 @@
+MD5 (binutils-2.14.tar.bz2) = 2da8def15d28af3ec6af0982709ae90a
+SIZE (binutils-2.14.tar.bz2) = 10921504
diff --git a/devel/libbfd/pkg-descr b/devel/libbfd/pkg-descr
new file mode 100644
index 000000000000..11b4d4c445e8
--- /dev/null
+++ b/devel/libbfd/pkg-descr
@@ -0,0 +1,4 @@
+Universal BFD library from the GNU binutils
+
+BFD stands for "Binary File Descriptor". This library can handle
+almost any object file format on earth.
diff --git a/devel/libbfd/pkg-plist b/devel/libbfd/pkg-plist
new file mode 100644
index 000000000000..5155fe538d6d
--- /dev/null
+++ b/devel/libbfd/pkg-plist
@@ -0,0 +1,5 @@
+include/ansidecl.h
+include/bfd.h
+include/bfdlink.h
+include/symcat.h
+lib/libbfd.a