aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorcrees <crees@FreeBSD.org>2011-10-31 00:43:22 +0800
committercrees <crees@FreeBSD.org>2011-10-31 00:43:22 +0800
commitab8ab8c134e69bebf071a83639b40cd72ead68b6 (patch)
tree6ed5e4ac315c0ac296a79508caec8ced394333a8
parentbc10adfe2e4dc246793f5f46b29f724f79c1ea1b (diff)
downloadfreebsd-ports-gnome-ab8ab8c134e69bebf071a83639b40cd72ead68b6.tar.gz
freebsd-ports-gnome-ab8ab8c134e69bebf071a83639b40cd72ead68b6.tar.zst
freebsd-ports-gnome-ab8ab8c134e69bebf071a83639b40cd72ead68b6.zip
Zenoss comes with the nagios command check_ping. This zenpack implements that
nagios ping check. The template provides the Round-Trip-Average time along with the packet loss rate. These two graphs are put in the "Performance" tab for each device utilizing this template. WWW: http://community.zenoss.org/docs/DOC-3416 PR: ports/157719 Submitted by: Zenoss <zenoss@experts-exchange.com>
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/zenpack-checkping/Makefile24
-rw-r--r--net-mgmt/zenpack-checkping/distinfo2
-rw-r--r--net-mgmt/zenpack-checkping/files/pkg-deinstall.in10
-rw-r--r--net-mgmt/zenpack-checkping/files/pkg-message.in5
-rw-r--r--net-mgmt/zenpack-checkping/pkg-descr6
-rw-r--r--net-mgmt/zenpack-checkping/pkg-plist2
7 files changed, 50 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 277e397c14f3..e452cecea676 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -298,6 +298,7 @@
SUBDIR += zabbix-server
SUBDIR += zenoss
SUBDIR += zenpack-apachemonitor
+ SUBDIR += zenpack-checkping
SUBDIR += zenpack-dellmon
SUBDIR += zenpack-deviceadvdetail
SUBDIR += zenpack-devicesearch
diff --git a/net-mgmt/zenpack-checkping/Makefile b/net-mgmt/zenpack-checkping/Makefile
new file mode 100644
index 000000000000..9ab21d44e485
--- /dev/null
+++ b/net-mgmt/zenpack-checkping/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: CheckPing
+# Date created: 08 June 2011
+# Whom: Zenoss <zenoss@experts-exchange.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= CheckPing
+PORTVERSION= 1.0
+CATEGORIES= net-mgmt www
+MASTER_SITES= http://zenpacks.zenoss.org/trac-zenpacks/changeset/1002/tags/
+DISTFILES= nagios-check-ping-${PORTVERSION}?old_path=%2F\&format=zip
+
+MAINTAINER= zenoss@experts-exchange.com
+COMMENT= Provides nagios ping check for Zenoss monitoring
+
+USE_ZIP= yes
+ZPACKPREFIX= ZenPacks.Nagios.
+ZPACKGROUP= community
+WRKSRC= ${WRKDIR}/tags/nagios-check-ping-${PORTVERSION}/
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/Mk/bsd.zenoss.mk"
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/zenpack-checkping/distinfo b/net-mgmt/zenpack-checkping/distinfo
new file mode 100644
index 000000000000..efd8a8b21ee7
--- /dev/null
+++ b/net-mgmt/zenpack-checkping/distinfo
@@ -0,0 +1,2 @@
+SHA256 (nagios-check-ping-1.0?old_path=%2F&format=zip) = 1f605381289046b2a2ac0491c908f7804b1d207f9c08bf6db523b934621c4398
+SIZE (nagios-check-ping-1.0?old_path=%2F&format=zip) = 4583
diff --git a/net-mgmt/zenpack-checkping/files/pkg-deinstall.in b/net-mgmt/zenpack-checkping/files/pkg-deinstall.in
new file mode 100644
index 000000000000..a1f84ae8e2cf
--- /dev/null
+++ b/net-mgmt/zenpack-checkping/files/pkg-deinstall.in
@@ -0,0 +1,10 @@
+#!/bin/sh
+
+if [ "$2" = "DEINSTALL" ]; then
+ echo "To de-activate this Zenpack, run the following command as the zenoss user:
+
+%%ZENHOME%%/bin/zenpack --remove %%ZPACKPREFIX%%%%PORTNAME%%
+
+IMPORTANT: De-activating a Zenpack will also remove all its associated data"
+
+fi
diff --git a/net-mgmt/zenpack-checkping/files/pkg-message.in b/net-mgmt/zenpack-checkping/files/pkg-message.in
new file mode 100644
index 000000000000..869bea811264
--- /dev/null
+++ b/net-mgmt/zenpack-checkping/files/pkg-message.in
@@ -0,0 +1,5 @@
+
+To activate this Zenpack, run the following commands as the zenoss user:
+
+%%ZENHOME%%/bin/zenpack --install %%ZPACKHOME%%/%%ZPACK%%
+%%ZENHOME%%/bin/zopectl restart
diff --git a/net-mgmt/zenpack-checkping/pkg-descr b/net-mgmt/zenpack-checkping/pkg-descr
new file mode 100644
index 000000000000..c75fe7b4b004
--- /dev/null
+++ b/net-mgmt/zenpack-checkping/pkg-descr
@@ -0,0 +1,6 @@
+Zenoss comes with the nagios command check_ping. This zenpack implements that
+nagios ping check. The template provides the Round-Trip-Average time along with
+the packet loss rate. These two graphs are put in the "Performance" tab for each
+device utilizing this template.
+
+WWW: http://community.zenoss.org/docs/DOC-3416
diff --git a/net-mgmt/zenpack-checkping/pkg-plist b/net-mgmt/zenpack-checkping/pkg-plist
new file mode 100644
index 000000000000..52307ea0055e
--- /dev/null
+++ b/net-mgmt/zenpack-checkping/pkg-plist
@@ -0,0 +1,2 @@
+zenoss/ZenPack/%%ZPACK%%
+@dirrmtry zenoss/ZenPack