aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjkim <jkim@FreeBSD.org>2018-01-26 07:07:53 +0800
committerjkim <jkim@FreeBSD.org>2018-01-26 07:07:53 +0800
commitababda6825f608d2e19c45712d30676619da60e6 (patch)
tree6c108114941abeed1e129eb51faf3779d148d9f5
parent60608c1d49fcd1594ec50c804f5d89db67f07459 (diff)
downloadfreebsd-ports-gnome-ababda6825f608d2e19c45712d30676619da60e6.tar.gz
freebsd-ports-gnome-ababda6825f608d2e19c45712d30676619da60e6.tar.zst
freebsd-ports-gnome-ababda6825f608d2e19c45712d30676619da60e6.zip
Add a missing run-time dependency, x11/xrandr.
Differential Revision: https://reviews.freebsd.org/D12803
-rw-r--r--emulators/virtualbox-ose-additions/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/emulators/virtualbox-ose-additions/Makefile b/emulators/virtualbox-ose-additions/Makefile
index 0befb4526e16..750a6099c049 100644
--- a/emulators/virtualbox-ose-additions/Makefile
+++ b/emulators/virtualbox-ose-additions/Makefile
@@ -3,6 +3,7 @@
PORTNAME= virtualbox-ose
PORTVERSION= 5.2.6
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= http://download.virtualbox.org/virtualbox/${PORTVERSION}/
PKGNAMESUFFIX?= -additions
@@ -99,7 +100,8 @@ VBOX_LIBS= VBoxEGL.so \
.endif
.if ${PORT_OPTIONS:MX11}
-BUILD_DEPENDS+= ${LOCALBASE}/bin/X:x11-servers/xorg-server
+BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/xorg-server.pc:x11-servers/xorg-server
+RUN_DEPENDS+= xrandr:x11/xrandr
USE_XORG+= inputproto x11 xcursor xext xmu xorg-server xrandr xt
USES+= pkgconfig
VBOX_WITH_X11= 1
@@ -149,6 +151,8 @@ post-patch:
-e 's| -fno-merge-constants||' \
-e 's| -mpreferred-stack-boundary=2||' ${WRKSRC}/Config.kmk
.endif
+ @${REINPLACE_CMD} -e 's|/usr/X11|${LOCALBASE}|g' \
+ ${WRKSRC}/src/VBox/Additions/x11/VBoxClient/display.cpp
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
${WRKSRC}/Config.kmk ${WRKSRC}/configure \
${WRKSRC}/kBuild/header.kmk ${WRKSRC}/kBuild/units/qt4.kmk \