aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2009-06-04 19:20:54 +0800
committerolgeni <olgeni@FreeBSD.org>2009-06-04 19:20:54 +0800
commitabc0fbe7ae43506ae85198441f3f86fc0f7c0218 (patch)
tree5088855dc2c986b64e627e509b90d3695e6899f3
parent11f2e78e2ea58aba2b83e78bb2bdea0492b9ba07 (diff)
downloadfreebsd-ports-gnome-abc0fbe7ae43506ae85198441f3f86fc0f7c0218.tar.gz
freebsd-ports-gnome-abc0fbe7ae43506ae85198441f3f86fc0f7c0218.tar.zst
freebsd-ports-gnome-abc0fbe7ae43506ae85198441f3f86fc0f7c0218.zip
Restore installation of erl_call.
-rw-r--r--lang/erlang/Makefile2
-rw-r--r--lang/erlang/pkg-plist1
-rw-r--r--lang/erlang14/Makefile2
-rw-r--r--lang/erlang14/pkg-plist1
4 files changed, 4 insertions, 2 deletions
diff --git a/lang/erlang/Makefile b/lang/erlang/Makefile
index 589ec8c183f0..08cb38d8fb27 100644
--- a/lang/erlang/Makefile
+++ b/lang/erlang/Makefile
@@ -127,7 +127,7 @@ pre-configure:
# rest, not in share/doc/erlang as it should, because of relative
# links in the documentation.
post-install:
-# @${LN} -sf ${LOCALBASE}/lib/erlang/lib/erl_interface-*/bin/erl_call ${LOCALBASE}/bin/erl_call
+ @${LN} -sf ${LOCALBASE}/lib/erlang/lib/erl_interface-*/bin/erl_call ${LOCALBASE}/bin/erl_call
@${TAR} --unlink -xzpf ${DISTDIR}/${DIST_SUBDIR}/${ERLANG_MAN} \
-C ${PREFIX}/lib/erlang
@${RM} -rf ${PREFIX}/lib/erlang/man/cat?
diff --git a/lang/erlang/pkg-plist b/lang/erlang/pkg-plist
index 16b507002b75..a0f7e5f47607 100644
--- a/lang/erlang/pkg-plist
+++ b/lang/erlang/pkg-plist
@@ -1,6 +1,7 @@
bin/dialyzer
bin/epmd
bin/erl
+bin/erl_call
bin/erlc
bin/escript
bin/run_erl
diff --git a/lang/erlang14/Makefile b/lang/erlang14/Makefile
index 589ec8c183f0..08cb38d8fb27 100644
--- a/lang/erlang14/Makefile
+++ b/lang/erlang14/Makefile
@@ -127,7 +127,7 @@ pre-configure:
# rest, not in share/doc/erlang as it should, because of relative
# links in the documentation.
post-install:
-# @${LN} -sf ${LOCALBASE}/lib/erlang/lib/erl_interface-*/bin/erl_call ${LOCALBASE}/bin/erl_call
+ @${LN} -sf ${LOCALBASE}/lib/erlang/lib/erl_interface-*/bin/erl_call ${LOCALBASE}/bin/erl_call
@${TAR} --unlink -xzpf ${DISTDIR}/${DIST_SUBDIR}/${ERLANG_MAN} \
-C ${PREFIX}/lib/erlang
@${RM} -rf ${PREFIX}/lib/erlang/man/cat?
diff --git a/lang/erlang14/pkg-plist b/lang/erlang14/pkg-plist
index 16b507002b75..a0f7e5f47607 100644
--- a/lang/erlang14/pkg-plist
+++ b/lang/erlang14/pkg-plist
@@ -1,6 +1,7 @@
bin/dialyzer
bin/epmd
bin/erl
+bin/erl_call
bin/erlc
bin/escript
bin/run_erl