aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2016-12-27 20:11:41 +0800
committerrene <rene@FreeBSD.org>2016-12-27 20:11:41 +0800
commitabca7c06d673d70b92f3f0295c2ac080b8a0146f (patch)
treefdc97805a0d515cd7b0298add0988de9fd232e54
parentd009d4ec32aae3d0130b2ae35617290cb7f86163 (diff)
downloadfreebsd-ports-gnome-abca7c06d673d70b92f3f0295c2ac080b8a0146f.tar.gz
freebsd-ports-gnome-abca7c06d673d70b92f3f0295c2ac080b8a0146f.tar.zst
freebsd-ports-gnome-abca7c06d673d70b92f3f0295c2ac080b8a0146f.zip
Remove expired port:
2016-08-20 databases/py-sqlalchemy07: Upstream has declared this version EoL: please migrate to databases/py-sqlalchemy10
-rw-r--r--MOVED1
-rw-r--r--databases/Makefile1
-rw-r--r--databases/py-sqlalchemy07/Makefile90
-rw-r--r--databases/py-sqlalchemy07/distinfo3
-rw-r--r--databases/py-sqlalchemy07/pkg-descr10
5 files changed, 1 insertions, 104 deletions
diff --git a/MOVED b/MOVED
index b46e98184de3..8edcc3272bb4 100644
--- a/MOVED
+++ b/MOVED
@@ -8851,3 +8851,4 @@ www/py35-requests|www/py3-requests|2016-12-26|No need for 4 versions of py-reque
net-mgmt/ccnet|net-mgmt/ccnet-client|2016-12-26|Split into -client and -server parts
net-mgmt/seafile|net-mgmt/seafile-client|2016-12-26|Split into -client and -server parts
comms/libcodec2|audio/codec2|2016-12-26|Removed: Duplicate port use `audio/codec2` instead
+databases/py-sqlalchemy07|databases/py-sqlalchemy10|2016-12-27|Has expired: Upstream has declared this version EoL: please migrate to databases/py-sqlalchemy10
diff --git a/databases/Makefile b/databases/Makefile
index 4f33edc40b74..1bc4994115c1 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -774,7 +774,6 @@
SUBDIR += py-rrdtool_lgpl
SUBDIR += py-south
SUBDIR += py-sqlalchemy-migrate
- SUBDIR += py-sqlalchemy07
SUBDIR += py-sqlalchemy08
SUBDIR += py-sqlalchemy09
SUBDIR += py-sqlalchemy10
diff --git a/databases/py-sqlalchemy07/Makefile b/databases/py-sqlalchemy07/Makefile
deleted file mode 100644
index a3293778bce5..000000000000
--- a/databases/py-sqlalchemy07/Makefile
+++ /dev/null
@@ -1,90 +0,0 @@
-# Created by: Dryice Dong Liu <dryice@dryice.name>
-# $FreeBSD$
-
-PORTNAME= sqlalchemy
-PORTVERSION= 0.7.10
-PORTREVISION= 3
-CATEGORIES= databases python
-MASTER_SITES= CHEESESHOP
-PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-PKGNAMESUFFIX= 07
-DISTNAME= SQLAlchemy-${DISTVERSION}
-
-MAINTAINER= nivit@FreeBSD.org
-COMMENT= Python SQL toolkit and Object Relational Mapper 0.7.x
-
-LICENSE= MIT
-
-DEPRECATED= Upstream has declared this version EoL: please migrate to databases/py-sqlalchemy10
-EXPIRATION_DATE= 2016-08-20
-
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose \
- ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock
-
-USES= python
-USE_PYTHON= autoplist distutils
-
-PY2TO3_CMD= ${LOCALBASE}/bin/2to3-${PYTHON_VER}
-PY2TO3_ARGS= --no-diffs --nobackups --verbose --write
-TEST_TARGET= do-test
-
-CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}sqlalchemy{0[689],10}*
-
-OPTIONS_DEFINE= DOCS EXAMPLES
-OPTIONS_MULTI= BACKEND
-OPTIONS_MULTI_BACKEND= FIREBIRD MSSQL MYSQL PGSQL SQLITE SYBASE
-OPTIONS_DEFAULT= SQLITE
-
-FIREBIRD_DESC= Firebird backend
-MSSQL_DESC= MS SQL Server backend
-SYBASE_DESC= Sybase backend
-
-FIREBIRD_RUN_DEPENDS= ${PYTHON_SITELIBDIR}/kinterbasdb/__init__.py:databases/kinterbasdb
-MSSQL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mssql>0:databases/py-mssql
-PGSQL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}psycopg2>=2.0.8:databases/py-psycopg2
-SQLITE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3
-SYBASE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sybase>0:databases/py-sybase
-
-PORTDOCS= *
-PORTEXAMPLES= *
-
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_REL} < 3000
-MYSQL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}MySQLdb>=1.2.2:databases/py-MySQLdb
-#.else
-# At the moment databases/py-pymysql does not build with Python3
-# See https://github.com/petehunt/PyMySQL#python-3-0-support
-#RUN_DEPENDS+= pymysql>=0.5:databases/py-pymysql
-.endif
-
-post-patch:
- ${REINPLACE_CMD} -e 's/import logging/&.handlers/1' -i.bak ${WRKSRC}/test/engine/test_execute.py
-
-pre-build:
-.if ${PYTHON_REL} >= 3000
- @${PY2TO3_CMD} ${PY2TO3_ARGS} ${WRKSRC}/lib
- @${PY2TO3_CMD} ${PY2TO3_ARGS} ${WRKSRC}/doc
- @${PY2TO3_CMD} ${PY2TO3_ARGS} ${WRKSRC}/examples
-.endif
-
-# C extensions are not supported with all versions of Python, so ignore
-# errors here if there are no .so files to strip.
-post-install:
- -@${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/sqlalchemy/*.so
-
-post-install-DOCS-on:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- cd ${WRKSRC}/doc/ && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
-
-post-install-EXAMPLES-on:
- @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}
-
-do-test:
-.if ${PYTHON_REL} >= 3000
- ${PY2TO3_CMD} ${PY2TO3_ARGS} ${WRKSRC}/test
-.endif
- @cd ${WRKSRC} && ${PYTHON_CMD} sqla_nose.py
-
-.include <bsd.port.post.mk>
diff --git a/databases/py-sqlalchemy07/distinfo b/databases/py-sqlalchemy07/distinfo
deleted file mode 100644
index 74e2f2a617ca..000000000000
--- a/databases/py-sqlalchemy07/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1463753628
-SHA256 (SQLAlchemy-0.7.10.tar.gz) = 77aa39d65c9d043eba6ba329b359ff867424fd6c403b7c0cb112b65e507e1d66
-SIZE (SQLAlchemy-0.7.10.tar.gz) = 3541639
diff --git a/databases/py-sqlalchemy07/pkg-descr b/databases/py-sqlalchemy07/pkg-descr
deleted file mode 100644
index 84d56454ff4e..000000000000
--- a/databases/py-sqlalchemy07/pkg-descr
+++ /dev/null
@@ -1,10 +0,0 @@
-The Python SQL Toolkit and Object Relational Mapper
-
-SQLAlchemy is the Python SQL toolkit and Object Relational Mapper that
-gives application developers the full power and flexibility of SQL.
-
-It provides a full suite of well known enterprise-level persistence
-patterns, designed for efficient and high-performing database access,
-adapted into a simple and Pythonic domain language.
-
-WWW: http://www.sqlalchemy.org/