aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2014-10-05 02:17:41 +0800
committerdemon <demon@FreeBSD.org>2014-10-05 02:17:41 +0800
commitabec698dd956515609341dbd7b996e29bbb8faf3 (patch)
treebb651730d0ac47328230392bbaf660a46607a2c0
parent55e9213394d93c0ab8f14314b36ec7409c47a18c (diff)
downloadfreebsd-ports-gnome-abec698dd956515609341dbd7b996e29bbb8faf3.tar.gz
freebsd-ports-gnome-abec698dd956515609341dbd7b996e29bbb8faf3.tar.zst
freebsd-ports-gnome-abec698dd956515609341dbd7b996e29bbb8faf3.zip
Resurrect protobuf port as of rev. 369705 (last version before update to
2.6.0). devel/hadoop2 needs that specific version.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/protobuf25/Makefile30
-rw-r--r--devel/protobuf25/distinfo2
-rw-r--r--devel/protobuf25/files/patch-src__google__protobuf__testing__zcgunzip.cc10
-rw-r--r--devel/protobuf25/files/patch-src__google__protobuf__testing__zcgzip.cc10
-rw-r--r--devel/protobuf25/pkg-descr5
-rw-r--r--devel/protobuf25/pkg-plist65
7 files changed, 123 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index d11fb152ad95..c288e6b5ccc9 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3493,6 +3493,7 @@
SUBDIR += projectcenter
SUBDIR += protobuf
SUBDIR += protobuf-c
+ SUBDIR += protobuf25
SUBDIR += psptoolchain
SUBDIR += psptoolchain-binutils
SUBDIR += psptoolchain-gcc-stage1
diff --git a/devel/protobuf25/Makefile b/devel/protobuf25/Makefile
new file mode 100644
index 000000000000..75918a85f1f5
--- /dev/null
+++ b/devel/protobuf25/Makefile
@@ -0,0 +1,30 @@
+# Created by: vanilla
+# $FreeBSD$
+
+# devel/hadoop2 needs version 2.5.0
+PORTNAME= protobuf
+PORTVERSION= 2.5.0
+PORTREVISION= 4
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+
+MAINTAINER= demon@FreeBSD.org
+COMMENT= Data interchange format library
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING.txt
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+USES= gmake pathfix pkgconfig tar:bzip2 libtool
+ONLY_FOR_ARCHS= i386 amd64
+INSTALL_TARGET= install-strip
+
+# clang will generate code that just doesn't work with clementine-player
+# if this isn't compiled as though it were C99.
+CFLAGS+= -std=c99 -DGOOGLE_PROTOBUF_NO_RTTI
+
+tests: build
+ @(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check)
+
+.include <bsd.port.mk>
diff --git a/devel/protobuf25/distinfo b/devel/protobuf25/distinfo
new file mode 100644
index 000000000000..d50dcb6f8e63
--- /dev/null
+++ b/devel/protobuf25/distinfo
@@ -0,0 +1,2 @@
+SHA256 (protobuf-2.5.0.tar.bz2) = 13bfc5ae543cf3aa180ac2485c0bc89495e3ae711fc6fab4f8ffe90dfb4bb677
+SIZE (protobuf-2.5.0.tar.bz2) = 1866763
diff --git a/devel/protobuf25/files/patch-src__google__protobuf__testing__zcgunzip.cc b/devel/protobuf25/files/patch-src__google__protobuf__testing__zcgunzip.cc
new file mode 100644
index 000000000000..02f9f051fbde
--- /dev/null
+++ b/devel/protobuf25/files/patch-src__google__protobuf__testing__zcgunzip.cc
@@ -0,0 +1,10 @@
+--- src/google/protobuf/testing/zcgunzip.cc.orig 2014-09-30 23:01:39.718744075 +0800
++++ src/google/protobuf/testing/zcgunzip.cc 2014-09-30 23:02:05.753740335 +0800
+@@ -44,6 +44,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <fcntl.h>
++#include <unistd.h> // for STDOUT_FILENO
+
+ #include <google/protobuf/io/gzip_stream.h>
+ #include <google/protobuf/io/zero_copy_stream_impl.h>
diff --git a/devel/protobuf25/files/patch-src__google__protobuf__testing__zcgzip.cc b/devel/protobuf25/files/patch-src__google__protobuf__testing__zcgzip.cc
new file mode 100644
index 000000000000..648ea705b0f5
--- /dev/null
+++ b/devel/protobuf25/files/patch-src__google__protobuf__testing__zcgzip.cc
@@ -0,0 +1,10 @@
+--- src/google/protobuf/testing/zcgzip.cc.orig 2014-09-30 22:46:34.571804492 +0800
++++ src/google/protobuf/testing/zcgzip.cc 2014-09-30 22:46:50.657816315 +0800
+@@ -43,6 +43,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <fcntl.h>
++#include <unistd.h> // for STDOUT_FILENO
+
+ #include <google/protobuf/io/gzip_stream.h>
+ #include <google/protobuf/io/zero_copy_stream_impl.h>
diff --git a/devel/protobuf25/pkg-descr b/devel/protobuf25/pkg-descr
new file mode 100644
index 000000000000..c9b826497682
--- /dev/null
+++ b/devel/protobuf25/pkg-descr
@@ -0,0 +1,5 @@
+Protocol Buffers are a way of encoding structured data in an efficient yet
+extensible format. Google uses Protocol Buffers for almost all of its
+internal RPC protocols and file formats.
+
+WWW: http://code.google.com/p/protobuf/
diff --git a/devel/protobuf25/pkg-plist b/devel/protobuf25/pkg-plist
new file mode 100644
index 000000000000..4ac7840d623b
--- /dev/null
+++ b/devel/protobuf25/pkg-plist
@@ -0,0 +1,65 @@
+bin/protoc
+include/google/protobuf/compiler/code_generator.h
+include/google/protobuf/compiler/command_line_interface.h
+include/google/protobuf/compiler/cpp/cpp_generator.h
+include/google/protobuf/compiler/importer.h
+include/google/protobuf/compiler/java/java_generator.h
+include/google/protobuf/compiler/parser.h
+include/google/protobuf/compiler/plugin.h
+include/google/protobuf/compiler/plugin.pb.h
+include/google/protobuf/compiler/plugin.proto
+include/google/protobuf/compiler/python/python_generator.h
+include/google/protobuf/descriptor.h
+include/google/protobuf/descriptor.pb.h
+include/google/protobuf/descriptor.proto
+include/google/protobuf/descriptor_database.h
+include/google/protobuf/dynamic_message.h
+include/google/protobuf/extension_set.h
+include/google/protobuf/generated_enum_reflection.h
+include/google/protobuf/generated_message_reflection.h
+include/google/protobuf/generated_message_util.h
+include/google/protobuf/io/coded_stream.h
+include/google/protobuf/io/gzip_stream.h
+include/google/protobuf/io/printer.h
+include/google/protobuf/io/tokenizer.h
+include/google/protobuf/io/zero_copy_stream.h
+include/google/protobuf/io/zero_copy_stream_impl.h
+include/google/protobuf/io/zero_copy_stream_impl_lite.h
+include/google/protobuf/message.h
+include/google/protobuf/message_lite.h
+include/google/protobuf/reflection_ops.h
+include/google/protobuf/repeated_field.h
+include/google/protobuf/service.h
+include/google/protobuf/stubs/atomicops.h
+include/google/protobuf/stubs/atomicops_internals_arm_gcc.h
+include/google/protobuf/stubs/atomicops_internals_arm_qnx.h
+include/google/protobuf/stubs/atomicops_internals_atomicword_compat.h
+include/google/protobuf/stubs/atomicops_internals_macosx.h
+include/google/protobuf/stubs/atomicops_internals_mips_gcc.h
+include/google/protobuf/stubs/atomicops_internals_pnacl.h
+include/google/protobuf/stubs/atomicops_internals_x86_gcc.h
+include/google/protobuf/stubs/atomicops_internals_x86_msvc.h
+include/google/protobuf/stubs/common.h
+include/google/protobuf/stubs/once.h
+include/google/protobuf/stubs/platform_macros.h
+include/google/protobuf/stubs/template_util.h
+include/google/protobuf/stubs/type_traits.h
+include/google/protobuf/text_format.h
+include/google/protobuf/unknown_field_set.h
+include/google/protobuf/wire_format.h
+include/google/protobuf/wire_format_lite.h
+include/google/protobuf/wire_format_lite_inl.h
+lib/libprotobuf-lite.a
+lib/libprotobuf-lite.so
+lib/libprotobuf-lite.so.8
+lib/libprotobuf-lite.so.8.0.0
+lib/libprotobuf.a
+lib/libprotobuf.so
+lib/libprotobuf.so.8
+lib/libprotobuf.so.8.0.0
+lib/libprotoc.a
+lib/libprotoc.so
+lib/libprotoc.so.8
+lib/libprotoc.so.8.0.0
+libdata/pkgconfig/protobuf-lite.pc
+libdata/pkgconfig/protobuf.pc