aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-10-10 19:40:56 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-10-10 19:40:56 +0800
commitacafc24e0caa41e1871d6227890852e9dbed9c23 (patch)
tree4c5dc9e39dfad9b4a7a79a39afc48d3c77199030
parentb2038b197f0e9c5e9ca0d1eabefad418bfe2f1e3 (diff)
downloadfreebsd-ports-gnome-acafc24e0caa41e1871d6227890852e9dbed9c23.tar.gz
freebsd-ports-gnome-acafc24e0caa41e1871d6227890852e9dbed9c23.tar.zst
freebsd-ports-gnome-acafc24e0caa41e1871d6227890852e9dbed9c23.zip
- Add games/gnujump
GNUjump is a clone of the simple yet addictive game Xjump, adding new features like multiplaying, unlimited FPS, smooth floor falling, themable graphics, sounds, replays, ... The goal in this game is to jump to the next floor trying not to fall down. As you go upper in the Falling Tower the floors will fall faster. Try to survive longer get upper than anyone. It might seem too simple but once you've tried you'll realize how addictive this is. WWW: http://gnujump.es.gnu.org/index.php/Main_Page
-rw-r--r--games/Makefile1
-rw-r--r--games/gnujump/Makefile49
-rw-r--r--games/gnujump/distinfo3
-rw-r--r--games/gnujump/files/patch-src_main.c11
-rw-r--r--games/gnujump/pkg-descr11
-rw-r--r--games/gnujump/pkg-plist4
6 files changed, 79 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index aac4ac1a53ee..cb9e09de33bb 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -358,6 +358,7 @@
SUBDIR += gnuchess
SUBDIR += gnudoku
SUBDIR += gnugo
+ SUBDIR += gnujump
SUBDIR += gnurobbo
SUBDIR += gnurobots
SUBDIR += gnushogi
diff --git a/games/gnujump/Makefile b/games/gnujump/Makefile
new file mode 100644
index 000000000000..d95afc11cecd
--- /dev/null
+++ b/games/gnujump/Makefile
@@ -0,0 +1,49 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= gnujump
+PORTVERSION= 1.0.8
+CATEGORIES= games
+MASTER_SITES= GNU
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Platform game where you have to jump up to survive
+
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+GNU_CONFIGURE= yes
+USES= gmake localbase
+USE_SDL= sdl mixer image
+USE_GL= gl
+USE_XORG= x11
+
+LDFLAGS+= -lm
+
+PORTDOCS= AUTHORS README
+PORTDATA= *
+
+DESKTOP_ENTRIES="GNUJump" \
+ "" \
+ "${DATADIR}/skins/default/hero1.0.png" \
+ "${PORTNAME}" \
+ "Game;ArcadeGame;" \
+ ""
+
+OPTIONS_DEFINE= DOCS NLS
+OPTIONS_SUB= yes
+
+NLS_CONFIGURE_ENABLE= nls
+NLS_USES= gettext
+NLS_LDFLAGS= -lintl
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' ${WRKSRC}/src/gnujump.h
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
+.endfor
+
+.include <bsd.port.mk>
diff --git a/games/gnujump/distinfo b/games/gnujump/distinfo
new file mode 100644
index 000000000000..5d369c3fc7b3
--- /dev/null
+++ b/games/gnujump/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1476098272
+SHA256 (gnujump-1.0.8.tar.gz) = 13c3fe5f430eb0c010560c7e438123a573ca61a55c6708aa750cfbf56bf25e17
+SIZE (gnujump-1.0.8.tar.gz) = 2508641
diff --git a/games/gnujump/files/patch-src_main.c b/games/gnujump/files/patch-src_main.c
new file mode 100644
index 000000000000..0845ea2587af
--- /dev/null
+++ b/games/gnujump/files/patch-src_main.c
@@ -0,0 +1,11 @@
+--- src/main.c.orig 2008-09-23 14:17:29 UTC
++++ src/main.c
+@@ -18,6 +18,8 @@
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
++#include <locale.h>
++
+ #include "gnujump.h"
+
+ #include "setup.h"
diff --git a/games/gnujump/pkg-descr b/games/gnujump/pkg-descr
new file mode 100644
index 000000000000..d4cc957ef310
--- /dev/null
+++ b/games/gnujump/pkg-descr
@@ -0,0 +1,11 @@
+GNUjump is a clone of the simple yet addictive game Xjump, adding
+new features like multiplaying, unlimited FPS, smooth floor falling,
+themable graphics, sounds, replays, ...
+
+The goal in this game is to jump to the next floor trying not to
+fall down. As you go upper in the Falling Tower the floors will
+fall faster. Try to survive longer get upper than anyone. It might
+seem too simple but once you've tried you'll realize how addictive
+this is.
+
+WWW: http://gnujump.es.gnu.org/index.php/Main_Page
diff --git a/games/gnujump/pkg-plist b/games/gnujump/pkg-plist
new file mode 100644
index 000000000000..47adf5f6bfb0
--- /dev/null
+++ b/games/gnujump/pkg-plist
@@ -0,0 +1,4 @@
+bin/gnujump
+man/man6/gnujump.6.gz
+%%NLS%%share/locale/it/LC_MESSAGES/gnujump.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/gnujump.mo