aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2006-05-22 20:31:35 +0800
committerehaupt <ehaupt@FreeBSD.org>2006-05-22 20:31:35 +0800
commitacc8a6c8fb9227e95502c5616c55de6ad9bb10b1 (patch)
treed0e4fae07a804c8d5e05f93e765764ed1850b79a
parent4ea5dd612f4b7878e7efe2364392bcd4d9cdc565 (diff)
downloadfreebsd-ports-gnome-acc8a6c8fb9227e95502c5616c55de6ad9bb10b1.tar.gz
freebsd-ports-gnome-acc8a6c8fb9227e95502c5616c55de6ad9bb10b1.tar.zst
freebsd-ports-gnome-acc8a6c8fb9227e95502c5616c55de6ad9bb10b1.zip
Add optional SDL output support.
-rw-r--r--audio/adplay/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/audio/adplay/Makefile b/audio/adplay/Makefile
index 8aeac17ca42f..4fee9d6d6789 100644
--- a/audio/adplay/Makefile
+++ b/audio/adplay/Makefile
@@ -7,7 +7,7 @@
PORTNAME= adplay
PORTVERSION= 1.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= adplug
@@ -21,6 +21,7 @@ COMMENT= AdLib player using adplug library
LIB_DEPENDS= adplug-2.0.0:${PORTSDIR}/audio/libadplug
GNU_CONFIGURE= yes
+WANT_SDL= yes
USE_GCC= 3.4+
DBFILE= adplug.db
@@ -38,8 +39,14 @@ MAN1= adplay.1
PLIST_FILES= bin/adplay %%DATADIR%%/adplug.db
PLIST_DIRS= %%DATADIR%%
+OPTIONS= SDL "Build with SDL output support" off
+
.include <bsd.port.pre.mk>
+.if defined(WITH_SDL)
+USE_SDL= sdl mixer
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|^\(adplug_data_dir.*\)/.*|\1|' \
${WRKSRC}/src/Makefile.in