aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-09-11 08:11:48 +0800
committermarino <marino@FreeBSD.org>2016-09-11 08:11:48 +0800
commitace3d5c371f218f7663f79057cee4cb29b1f6300 (patch)
tree3bbfa35dee2d4fdace4751d9f5e6ea271941d5f2
parent506a615716df25dac6916c26879b96466e069187 (diff)
downloadfreebsd-ports-gnome-ace3d5c371f218f7663f79057cee4cb29b1f6300.tar.gz
freebsd-ports-gnome-ace3d5c371f218f7663f79057cee4cb29b1f6300.tar.zst
freebsd-ports-gnome-ace3d5c371f218f7663f79057cee4cb29b1f6300.zip
net-p2p/mktorrent: Add SSL flags
Approved by: SSL blanket
-rw-r--r--net-p2p/mktorrent/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/net-p2p/mktorrent/Makefile b/net-p2p/mktorrent/Makefile
index 851f4df5ce5b..995a3cb4580c 100644
--- a/net-p2p/mktorrent/Makefile
+++ b/net-p2p/mktorrent/Makefile
@@ -24,6 +24,10 @@ THREADS_DESC= Enable support for pthreads
OPENSSL_DESC= Use OpenSSL for hashing
HASHCHECK_DESC= Verify file hashes
+OPENSSL_USES= ssl
+OPENSSL_CFLAGS= -I${OPENSSLINC}
+OPENSSL_LDFLAGS= -L${OPENSSLLIB}
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MTHREADS}
@@ -32,7 +36,6 @@ MAKE_FLAGS+= USE_PTHREADS=1
.if ${PORT_OPTIONS:MOPENSSL}
MAKE_FLAGS+= USE_OPENSSL=1
-USE_OPENSSL= yes
.endif
.if ! ${PORT_OPTIONS:MHASHCHECK}