aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2016-08-19 01:42:15 +0800
committerswills <swills@FreeBSD.org>2016-08-19 01:42:15 +0800
commitada297e25f2f496348d50a7cb4d4e0735f31b11c (patch)
tree4781953b00500dce83228c844f61acbe4d3d3946
parenta14349d839064ac23267f5fbce6257e6c98d8786 (diff)
downloadfreebsd-ports-gnome-ada297e25f2f496348d50a7cb4d4e0735f31b11c.tar.gz
freebsd-ports-gnome-ada297e25f2f496348d50a7cb4d4e0735f31b11c.tar.zst
freebsd-ports-gnome-ada297e25f2f496348d50a7cb4d4e0735f31b11c.zip
sysutils/consul: fix build with Go 1.7
-rw-r--r--sysutils/consul/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/sysutils/consul/Makefile b/sysutils/consul/Makefile
index 69e457f55c5d..8dc417b309ef 100644
--- a/sysutils/consul/Makefile
+++ b/sysutils/consul/Makefile
@@ -187,7 +187,7 @@ post-patch:
do-build:
@cd ${WRKSRC}/src/github.com/hashicorp/consul; ${SETENV} ${BUILD_ENV} GOPATH=${WRKSRC} go build \
- -ldflags "-X main.GitDescribe v${PORTVERSION}" -o bin/consul
+ -ldflags "-X main.GitDescribe=v${PORTVERSION}" -o bin/consul
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/github.com/hashicorp/consul/bin/consul ${STAGEDIR}${PREFIX}/bin/consul