aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-04-20 06:34:01 +0800
committermiwi <miwi@FreeBSD.org>2008-04-20 06:34:01 +0800
commitadf0736450e85e9d98d2f91ce11a6dc7176cc96a (patch)
tree022139d46cd2635dacd723edc3e0ee7fdb308cd6
parent021dcc8da66ec744df4c616473e7944477f5c7d3 (diff)
downloadfreebsd-ports-gnome-adf0736450e85e9d98d2f91ce11a6dc7176cc96a.tar.gz
freebsd-ports-gnome-adf0736450e85e9d98d2f91ce11a6dc7176cc96a.tar.zst
freebsd-ports-gnome-adf0736450e85e9d98d2f91ce11a6dc7176cc96a.zip
This package can be used to generate tag clouds. The output is HTML and CSS.
And it does not only visualize frequency, but also timeline information. The newer the tag is, the deeper its color will be; older tags will have a lighter color.The main goal of "HTML_TagCloud" is to provide an easy to implement and configureable Tag Cloud solution that is suitable for any PHP-based webapp. WWW: http://pear.php.net/package/HTML_TagCloud/ PR: ports/122577 Submitted by: Wen heping <wenheping at gmail.com>
-rw-r--r--www/Makefile1
-rw-r--r--www/pear-HTML_TagCloud/Makefile30
-rw-r--r--www/pear-HTML_TagCloud/distinfo3
-rw-r--r--www/pear-HTML_TagCloud/pkg-descr8
4 files changed, 42 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 383ccb536873..ebbece5d8800 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1006,6 +1006,7 @@
SUBDIR += paros
SUBDIR += peacock
SUBDIR += pear-HTML_AJAX
+ SUBDIR += pear-HTML_TagCloud
SUBDIR += pear-HTTP
SUBDIR += pear-HTTP_Client
SUBDIR += pear-HTTP_Download
diff --git a/www/pear-HTML_TagCloud/Makefile b/www/pear-HTML_TagCloud/Makefile
new file mode 100644
index 000000000000..10843c07cb96
--- /dev/null
+++ b/www/pear-HTML_TagCloud/Makefile
@@ -0,0 +1,30 @@
+# Ports collection makefile for: pear-HTML_TagCloud
+# Date created: 08 April 2008
+# Whom: Wen heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML_TagCloud
+PORTVERSION= 0.2.2
+CATEGORIES= www devel pear
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Generate TagCloud in HTML And Visualize Tags
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+
+CATEGORY= HTML
+FILES= TagCloud.php
+
+DOCS= examples/TagCloud_example1.php \
+ examples/TagCloud_example2.php \
+ examples/TagCloud_example3.php \
+ examples/TagCloud_example4.php
+
+TESTS= AllTests.php TagCloudTest.php
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/www/pear-HTML_TagCloud/distinfo b/www/pear-HTML_TagCloud/distinfo
new file mode 100644
index 000000000000..89ed72be0c52
--- /dev/null
+++ b/www/pear-HTML_TagCloud/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/HTML_TagCloud-0.2.2.tgz) = b48d31f77b9ceab55f5cf34fa0d65fe0
+SHA256 (PEAR/HTML_TagCloud-0.2.2.tgz) = 0a9429b781a831c92147d8fa8cb09617cedc4ef147065f230185f41700f9d856
+SIZE (PEAR/HTML_TagCloud-0.2.2.tgz) = 10918
diff --git a/www/pear-HTML_TagCloud/pkg-descr b/www/pear-HTML_TagCloud/pkg-descr
new file mode 100644
index 000000000000..63406bb8c4b4
--- /dev/null
+++ b/www/pear-HTML_TagCloud/pkg-descr
@@ -0,0 +1,8 @@
+This package can be used to generate tag clouds. The output is HTML and CSS.
+And it does not only visualize frequency, but also timeline information.
+The newer the tag is, the deeper its color will be; older tags will have
+a lighter color.The main goal of "HTML_TagCloud" is to provide an easy to
+implement and configureable Tag Cloud solution that is suitable for any
+PHP-based webapp.
+
+WWW: http://pear.php.net/package/HTML_TagCloud/