aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2012-07-17 23:13:18 +0800
committergahr <gahr@FreeBSD.org>2012-07-17 23:13:18 +0800
commitae670a8fdf7a2ff2388ac4a6f60e715775fdc0da (patch)
tree96ab404315d04b6943df26cbb3aea140f1709f55
parent90ed7966a26c6d28e29fe291309df0c02facf25f (diff)
downloadfreebsd-ports-gnome-ae670a8fdf7a2ff2388ac4a6f60e715775fdc0da.tar.gz
freebsd-ports-gnome-ae670a8fdf7a2ff2388ac4a6f60e715775fdc0da.tar.zst
freebsd-ports-gnome-ae670a8fdf7a2ff2388ac4a6f60e715775fdc0da.zip
- New port: devel/yajl-tcl
Yajl-tcl is a Tcl wrapper for the Yet Another JSON Library (YAJL). WWW: https://github.com/flightaware/yajl-tcl/
-rw-r--r--devel/yajl-tcl/Makefile36
-rw-r--r--devel/yajl-tcl/distinfo2
-rw-r--r--devel/yajl-tcl/pkg-descr6
3 files changed, 44 insertions, 0 deletions
diff --git a/devel/yajl-tcl/Makefile b/devel/yajl-tcl/Makefile
new file mode 100644
index 000000000000..3fa921623452
--- /dev/null
+++ b/devel/yajl-tcl/Makefile
@@ -0,0 +1,36 @@
+# New ports collection Makefile for: yajl-tcl
+# Date created: 17 July 2012
+# Whom: gahr
+#
+# $FreeBSD$
+#
+
+PORTNAME= yajl-tcl
+PORTVERSION= 1.2
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_LOCAL} \
+ http://people.freebsd.org/~gahr/distfiles/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-${CLONEDATE}
+MASTER_SITE_SUBDIR= gahr
+
+MAINTAIER= gahr@FreeBSD.org
+COMMENT= Tcl bindings for Yet Another JSON Library
+
+LICENSE= BSD
+
+USE_TCL= yes
+USE_AUTOTOOLS= autoconf
+CONFIGURE_ARGS+=--with-tcl=${TCL_LIBDIR} \
+ --with-tclinclude=${TCL_INCLUDEDIR}
+
+PLIST_FILES= lib/yajltcl1.2/libyajltcl.so.1 \
+ lib/yajltcl1.2/pkgIndex.tcl \
+ lib/yajltcl1.2/yajl.tcl
+PLIST_DIRS= lib/yajltcl1.2
+
+CLONEDATE= 20120717
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+LIB_DEPENDS= yajl:${PORTSDIR}/devel/yajl
+
+.include <bsd.port.mk>
diff --git a/devel/yajl-tcl/distinfo b/devel/yajl-tcl/distinfo
new file mode 100644
index 000000000000..bb47d92b4fad
--- /dev/null
+++ b/devel/yajl-tcl/distinfo
@@ -0,0 +1,2 @@
+SHA256 (yajl-tcl-1.2-20120717.tar.gz) = 0ea96f73dd48e85074d8ae3f92528f9313a2ad2ebbeb31a6589cf94d25a99180
+SIZE (yajl-tcl-1.2-20120717.tar.gz) = 1023791
diff --git a/devel/yajl-tcl/pkg-descr b/devel/yajl-tcl/pkg-descr
new file mode 100644
index 000000000000..73d2448e50c1
--- /dev/null
+++ b/devel/yajl-tcl/pkg-descr
@@ -0,0 +1,6 @@
+Yajl-tcl is a Tcl wrapper for the Yet Another JSON Library (YAJL).
+Although there is already a package in the tcllib library, huddle,
+that can generate JSON, the big advantage in using yajl-tcl is
+performance.
+
+WWW: https://github.com/flightaware/yajl-tcl