aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2019-09-22 02:42:40 +0800
committerpi <pi@FreeBSD.org>2019-09-22 02:42:40 +0800
commitaf23967558a5292c96d0b12b4c2f8789021afe09 (patch)
treea9a52a45513652727e2929e0c027fffc4e912446
parentb34a13e6130eb88c281a3249ffc9c51e7ea2cbee (diff)
downloadfreebsd-ports-gnome-af23967558a5292c96d0b12b4c2f8789021afe09.tar.gz
freebsd-ports-gnome-af23967558a5292c96d0b12b4c2f8789021afe09.tar.zst
freebsd-ports-gnome-af23967558a5292c96d0b12b4c2f8789021afe09.zip
New port: sysutils/p5-File-Rename
rename renames the filenames supplied according to the rule specified as the first argument. The perlexpr argument is a Perl expression which is expected to modify the $_ string in Perl for at least some of the filenames specified. If a given filename is not modified by the expression, it will not be renamed. If no filenames are given on the command line, filenames will be read via standard input. WWW: https://metacpan.org/release/File-Rename PR: 240728 Submitted by: Vidar Karlsen <vidar@karlsen.tech>
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/p5-File-Rename/Makefile19
-rw-r--r--sysutils/p5-File-Rename/distinfo3
-rw-r--r--sysutils/p5-File-Rename/pkg-descr8
-rw-r--r--sysutils/p5-File-Rename/pkg-plist6
5 files changed, 37 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 33c40a974379..25c904bc1487 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -776,6 +776,7 @@
SUBDIR += p5-File-Listing
SUBDIR += p5-File-Log
SUBDIR += p5-File-Next
+ SUBDIR += p5-File-Rename
SUBDIR += p5-File-Signature
SUBDIR += p5-File-Stat-Bits
SUBDIR += p5-File-Stat-ModeString
diff --git a/sysutils/p5-File-Rename/Makefile b/sysutils/p5-File-Rename/Makefile
new file mode 100644
index 000000000000..f0a9b5867504
--- /dev/null
+++ b/sysutils/p5-File-Rename/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= File-Rename
+PORTVERSION= 1.10
+CATEGORIES= sysutils perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= vidar@karlsen.tech
+COMMENT= Rename multiple files
+
+LICENSE= ART10
+
+USES= perl5
+USE_PERL5= configure
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/sysutils/p5-File-Rename/distinfo b/sysutils/p5-File-Rename/distinfo
new file mode 100644
index 000000000000..c2fbeb37279c
--- /dev/null
+++ b/sysutils/p5-File-Rename/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1569010631
+SHA256 (File-Rename-1.10.tar.gz) = 054ebb366c36e55140f7765f5ea13e34e1a3520bb964ba231ac0926c8046f58c
+SIZE (File-Rename-1.10.tar.gz) = 13674
diff --git a/sysutils/p5-File-Rename/pkg-descr b/sysutils/p5-File-Rename/pkg-descr
new file mode 100644
index 000000000000..e421f4578ced
--- /dev/null
+++ b/sysutils/p5-File-Rename/pkg-descr
@@ -0,0 +1,8 @@
+rename renames the filenames supplied according to the rule specified as the
+first argument. The perlexpr argument is a Perl expression which is expected
+to modify the $_ string in Perl for at least some of the filenames specified.
+If a given filename is not modified by the expression, it will not be renamed.
+If no filenames are given on the command line, filenames will be read via
+standard input.
+
+WWW: https://metacpan.org/release/File-Rename
diff --git a/sysutils/p5-File-Rename/pkg-plist b/sysutils/p5-File-Rename/pkg-plist
new file mode 100644
index 000000000000..dc874cac2d3a
--- /dev/null
+++ b/sysutils/p5-File-Rename/pkg-plist
@@ -0,0 +1,6 @@
+bin/rename
+%%SITE_PERL%%/File/Rename.pm
+%%SITE_PERL%%/File/Rename/Options.pm
+%%PERL5_MAN1%%/rename.1.gz
+%%PERL5_MAN3%%/File::Rename.3.gz
+%%PERL5_MAN3%%/File::Rename::Options.3.gz