aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2019-03-25 17:57:05 +0800
committermat <mat@FreeBSD.org>2019-03-25 17:57:05 +0800
commitaf5c0110b120bcb6dca167955f4efaf797047b50 (patch)
treea95bfd1eaadf3ae9ae45c6725d8cefeb47573d49
parent3611691c24ced88b32ad2e1c0dbf6da7c3d0e785 (diff)
downloadfreebsd-ports-gnome-af5c0110b120bcb6dca167955f4efaf797047b50.tar.gz
freebsd-ports-gnome-af5c0110b120bcb6dca167955f4efaf797047b50.tar.zst
freebsd-ports-gnome-af5c0110b120bcb6dca167955f4efaf797047b50.zip
Update to latest commit.
-rw-r--r--dns/bind9-devel/Makefile4
-rw-r--r--dns/bind9-devel/distinfo6
-rw-r--r--dns/bind9-devel/files/extrapatch-bind-min-override-ttl12
-rw-r--r--dns/bind9-devel/files/patch-configure8
-rw-r--r--dns/bind9-devel/pkg-plist1
5 files changed, 15 insertions, 16 deletions
diff --git a/dns/bind9-devel/Makefile b/dns/bind9-devel/Makefile
index c70ef7f1764b..e4769dad92fe 100644
--- a/dns/bind9-devel/Makefile
+++ b/dns/bind9-devel/Makefile
@@ -38,13 +38,13 @@ LIB_DEPENDS= libxml2.so:textproc/libxml2
# XXX: remove tar:bz2
USES= compiler:c11 cpe libedit ssl tar:bz2
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.15.0a0.2019.03.18
+ISCVERSION= 9.15.0a0.2019.03.22
# XXX: Remove gitlab
USE_GITLAB= yes
GL_SITE= https://gitlab.isc.org
GL_ACCOUNT= isc-projects
GL_PROJECT= bind9
-GL_COMMIT= c3fb2c4c7733a4372ade1ed3e226fa8ab4980634
+GL_COMMIT= d089387d7f98b26eff89e75200e0d2cb4b7eec6b
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
diff --git a/dns/bind9-devel/distinfo b/dns/bind9-devel/distinfo
index ef6db4c9ea7d..cf0bd715e873 100644
--- a/dns/bind9-devel/distinfo
+++ b/dns/bind9-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1552919265
-SHA256 (isc-projects-bind9-c3fb2c4c7733a4372ade1ed3e226fa8ab4980634_GL0.tar.gz) = b856c2c3f41dba288a422d55dae0334a2c9d529ef22826a824b42987b78ae12d
-SIZE (isc-projects-bind9-c3fb2c4c7733a4372ade1ed3e226fa8ab4980634_GL0.tar.gz) = 6336896
+TIMESTAMP = 1553504621
+SHA256 (isc-projects-bind9-d089387d7f98b26eff89e75200e0d2cb4b7eec6b_GL0.tar.gz) = 4388e1035c0794491affabd1275286e55e5c697261a5d7352a48236ebae95076
+SIZE (isc-projects-bind9-d089387d7f98b26eff89e75200e0d2cb4b7eec6b_GL0.tar.gz) = 6337543
diff --git a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
index a2e9feca8ee6..04da72edb4e0 100644
--- a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
@@ -1,4 +1,4 @@
---- bin/named/config.c.orig 2019-03-18 10:46:01 UTC
+--- bin/named/config.c.orig 2019-03-22 10:58:02 UTC
+++ bin/named/config.c
@@ -176,6 +176,7 @@ options {\n\
notify-source *;\n\
@@ -8,9 +8,9 @@
provide-ixfr true;\n\
qname-minimization relaxed;\n\
query-source address *;\n\
---- bin/named/server.c.orig 2019-03-18 10:46:01 UTC
+--- bin/named/server.c.orig 2019-03-22 10:58:02 UTC
+++ bin/named/server.c
-@@ -4164,6 +4164,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
+@@ -4231,6 +4231,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
}
obj = NULL;
@@ -22,7 +22,7 @@
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asuint32(obj);
---- lib/dns/include/dns/view.h.orig 2019-03-18 10:46:01 UTC
+--- lib/dns/include/dns/view.h.orig 2019-03-22 10:58:02 UTC
+++ lib/dns/include/dns/view.h
@@ -152,6 +152,7 @@ struct dns_view {
bool requestnsid;
@@ -32,7 +32,7 @@
dns_ttl_t maxncachettl;
dns_ttl_t mincachettl;
dns_ttl_t minncachettl;
---- lib/dns/resolver.c.orig 2019-03-18 10:46:01 UTC
+--- lib/dns/resolver.c.orig 2019-03-22 10:58:02 UTC
+++ lib/dns/resolver.c
@@ -6008,6 +6008,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_adb
}
@@ -47,7 +47,7 @@
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2019-03-18 10:46:01 UTC
+--- lib/isccfg/namedconf.c.orig 2019-03-22 10:58:02 UTC
+++ lib/isccfg/namedconf.c
@@ -1899,6 +1899,7 @@ view_clauses[] = {
#endif
diff --git a/dns/bind9-devel/files/patch-configure b/dns/bind9-devel/files/patch-configure
index c2717212fa9b..e0fdb25d1867 100644
--- a/dns/bind9-devel/files/patch-configure
+++ b/dns/bind9-devel/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2019-03-11 12:28:13 UTC
+--- configure.orig 2019-03-22 10:58:02 UTC
+++ configure
-@@ -16594,27 +16594,9 @@ done
+@@ -16593,27 +16593,9 @@ done
# problems start to show up.
saved_libs="$LIBS"
for TRY_LIBS in \
@@ -30,7 +30,7 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking linking as $TRY_LIBS" >&5
$as_echo_n "checking linking as $TRY_LIBS... " >&6; }
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-@@ -16657,47 +16639,7 @@ $as_echo "no" >&6; } ;;
+@@ -16656,47 +16638,7 @@ $as_echo "no" >&6; } ;;
no) as_fn_error $? "could not determine proper GSSAPI linkage" "$LINENO" 5 ;;
esac
@@ -79,7 +79,7 @@
DNS_GSSAPI_LIBS="$LIBS"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: using GSSAPI from $use_gssapi/lib and $use_gssapi/include" >&5
-@@ -21186,7 +21128,7 @@ $as_echo "" >&6; }
+@@ -21182,7 +21124,7 @@ $as_echo "" >&6; }
# Check other locations for includes.
# Order is important (sigh).
diff --git a/dns/bind9-devel/pkg-plist b/dns/bind9-devel/pkg-plist
index ec879674a533..45bc62392a12 100644
--- a/dns/bind9-devel/pkg-plist
+++ b/dns/bind9-devel/pkg-plist
@@ -44,7 +44,6 @@ include/dns/dns64.h
include/dns/dnsrps.h
include/dns/dnssec.h
include/dns/dnstap.h
-%%DNSTAP%%include/dns/dnstap.pb-c.h
include/dns/ds.h
include/dns/dsdigest.h
include/dns/dyndb.h