aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2012-02-13 13:20:41 +0800
committerpgj <pgj@FreeBSD.org>2012-02-13 13:20:41 +0800
commitaff31ba4a5daf317f3b30556d0096237dff6c37c (patch)
tree40e452c3a4a8167ce7f2b6de7b7602d24590bafa
parentfc7b68dda52e77574574155ece822e01f0ae764a (diff)
downloadfreebsd-ports-gnome-aff31ba4a5daf317f3b30556d0096237dff6c37c.tar.gz
freebsd-ports-gnome-aff31ba4a5daf317f3b30556d0096237dff6c37c.tar.zst
freebsd-ports-gnome-aff31ba4a5daf317f3b30556d0096237dff6c37c.zip
- Update to 0.5.1
Obtained from: FreeBSD Haskell
-rw-r--r--science/hs-bio/Makefile6
-rw-r--r--science/hs-bio/distinfo4
-rw-r--r--science/hs-bio/files/patch-bio.cabal6
-rw-r--r--science/hs-bio/files/patch-examples__RSelectPE.hs8
-rw-r--r--science/hs-bio/pkg-descr2
5 files changed, 16 insertions, 10 deletions
diff --git a/science/hs-bio/Makefile b/science/hs-bio/Makefile
index 4af48ccdc898..7a5d97672cd8 100644
--- a/science/hs-bio/Makefile
+++ b/science/hs-bio/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= bio
-PORTVERSION= 0.5.0.1
+PORTVERSION= 0.5.1
CATEGORIES= science haskell
MAINTAINER= haskell@FreeBSD.org
@@ -17,9 +17,7 @@ LICENSE= LGPL21
CABAL_SETUP= Setup.hs
USE_CABAL= binary>=0.4 mtl parallel parsec QuickCheck>=2 tagsoup>=0.8
-EXECUTABLE= fastout flx frecover frename
-
-PORTDATA= *
+EXECUTABLE= fastout flx frecover frename flowclip orf rselect-pe
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/science/hs-bio/distinfo b/science/hs-bio/distinfo
index ad7fee4a7456..793e98b3825f 100644
--- a/science/hs-bio/distinfo
+++ b/science/hs-bio/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/bio-0.5.0.1.tar.gz) = 0bb62961c38c4437fcfaaf08922d16a967681a3d244d4a9fc414538050cf662b
-SIZE (cabal/bio-0.5.0.1.tar.gz) = 100323
+SHA256 (cabal/bio-0.5.1.tar.gz) = 256e1b34fc0c7fd21b3ec36e1e3903bed2afc56b6a819f26d8368dbea21561a9
+SIZE (cabal/bio-0.5.1.tar.gz) = 103846
diff --git a/science/hs-bio/files/patch-bio.cabal b/science/hs-bio/files/patch-bio.cabal
index 0dc3382c45dd..c34a3277d73c 100644
--- a/science/hs-bio/files/patch-bio.cabal
+++ b/science/hs-bio/files/patch-bio.cabal
@@ -1,11 +1,11 @@
---- ./bio.cabal.orig 2011-01-26 15:07:16.000000000 +0100
-+++ ./bio.cabal 2011-03-13 15:52:53.711304695 +0100
+--- ./bio.cabal.orig 2011-12-15 12:56:28.000000000 +0100
++++ ./bio.cabal 2011-12-17 11:02:26.000000000 +0100
@@ -38,7 +38,7 @@
Default: True
Library
- Build-Depends: base>=4 && <5, binary >=0.4 && <0.5, tagsoup>=0.8, bytestring >= 0.9.1,
+ Build-Depends: base>=4 && <5, binary >=0.4, tagsoup>=0.8, bytestring >= 0.9.1,
- containers, array, parallel, parsec, mtl, directory
+ containers, array, parallel, parsec, mtl, directory, QuickCheck >= 2
Exposed-modules: Bio.Sequence,
diff --git a/science/hs-bio/files/patch-examples__RSelectPE.hs b/science/hs-bio/files/patch-examples__RSelectPE.hs
new file mode 100644
index 000000000000..6ca244b9f7c4
--- /dev/null
+++ b/science/hs-bio/files/patch-examples__RSelectPE.hs
@@ -0,0 +1,8 @@
+--- ./examples/RSelectPE.hs.orig 2011-12-15 12:56:28.000000000 +0100
++++ ./examples/RSelectPE.hs 2011-12-17 11:46:58.000000000 +0100
+@@ -1,5 +1,3 @@
+-{- | Randomly select paired end (illumina) reads -}
+-
+ import System.Environment (getArgs)
+ import Data.List (isSuffixOf)
+ import System.Random
diff --git a/science/hs-bio/pkg-descr b/science/hs-bio/pkg-descr
index a43395813f95..91946cc0ba3f 100644
--- a/science/hs-bio/pkg-descr
+++ b/science/hs-bio/pkg-descr
@@ -4,4 +4,4 @@ for building bioinformatics-related tools and utilities.
Current list of features includes: a Sequence data type supporting
protein and nucleotide sequences and conversion between them.
-WWW: http://blog.malde.org/index.php/the-haskell-bioinformatics-library/
+WWW: http://biohaskell.org/Libraries/Bio