aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorglarkin <glarkin@FreeBSD.org>2009-05-01 01:51:57 +0800
committerglarkin <glarkin@FreeBSD.org>2009-05-01 01:51:57 +0800
commitb0578a5baa58b75694d3a11a157d3bd9462f266d (patch)
tree25cec415242810c8360469ba385af1a0a0ab0f5a
parent510a30b2447f59c3cdf49b7c5cffe0d041d7c05b (diff)
downloadfreebsd-ports-gnome-b0578a5baa58b75694d3a11a157d3bd9462f266d.tar.gz
freebsd-ports-gnome-b0578a5baa58b75694d3a11a157d3bd9462f266d.tar.zst
freebsd-ports-gnome-b0578a5baa58b75694d3a11a157d3bd9462f266d.zip
This module comes with a set of methods to use with htaccess password
files. These files (and htaccess) are used to do Basic Authentication on a web server. The password file is a flat-file with login names and their associated crypted password. You can use this for non-Apache files if you wish, but it was written specifically for .htaccess style files. WWW: http://search.cpan.org/dist/Apache-Htpasswd/
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Apache-Htpasswd/Makefile26
-rw-r--r--security/p5-Apache-Htpasswd/distinfo3
-rw-r--r--security/p5-Apache-Htpasswd/pkg-descr9
-rw-r--r--security/p5-Apache-Htpasswd/pkg-plist5
5 files changed, 44 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 80ecd1360653..7fb198f7514e 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -338,6 +338,7 @@
SUBDIR += ossec-hids-server
SUBDIR += osslsigncode
SUBDIR += outguess
+ SUBDIR += p5-Apache-Htpasswd
SUBDIR += p5-Authen-Bitcard
SUBDIR += p5-Authen-Captcha
SUBDIR += p5-Authen-CyrusSASL
diff --git a/security/p5-Apache-Htpasswd/Makefile b/security/p5-Apache-Htpasswd/Makefile
new file mode 100644
index 000000000000..5f931f9568b0
--- /dev/null
+++ b/security/p5-Apache-Htpasswd/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Apache-Htpasswd
+# Date created: 30 Apr 2009
+# Whom: Greg Larkin <glarkin@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Apache-Htpasswd
+PORTVERSION= 1.8
+CATEGORIES= security perl5 www
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= glarkin@FreeBSD.org
+COMMENT= Manage Unix crypt-style password file
+
+BUILD_DEPENDS= p5-Crypt-PasswdMD5>=0:${PORTSDIR}/security/p5-Crypt-PasswdMD5 \
+ p5-Digest-SHA1>=2.0:${PORTSDIR}/security/p5-Digest-SHA1 \
+ p5-MIME-Base64>=0:${PORTSDIR}/converters/p5-MIME-Base64
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Apache::Htpasswd.3
+
+.include <bsd.port.mk>
diff --git a/security/p5-Apache-Htpasswd/distinfo b/security/p5-Apache-Htpasswd/distinfo
new file mode 100644
index 000000000000..db52286d3f37
--- /dev/null
+++ b/security/p5-Apache-Htpasswd/distinfo
@@ -0,0 +1,3 @@
+MD5 (Apache-Htpasswd-1.8.tar.gz) = ee2048044096b4259e89c9ed1c88ed92
+SHA256 (Apache-Htpasswd-1.8.tar.gz) = 57709488c85555403fafcadf7e84d511630aa3f3c94750b59aa5bc1d3d75221c
+SIZE (Apache-Htpasswd-1.8.tar.gz) = 8397
diff --git a/security/p5-Apache-Htpasswd/pkg-descr b/security/p5-Apache-Htpasswd/pkg-descr
new file mode 100644
index 000000000000..90be3cc2f9ae
--- /dev/null
+++ b/security/p5-Apache-Htpasswd/pkg-descr
@@ -0,0 +1,9 @@
+This module comes with a set of methods to use with htaccess password
+files. These files (and htaccess) are used to do Basic Authentication
+on a web server.
+
+The password file is a flat-file with login names and their associated
+crypted password. You can use this for non-Apache files if you wish,
+but it was written specifically for .htaccess style files.
+
+WWW: http://search.cpan.org/dist/Apache-Htpasswd/
diff --git a/security/p5-Apache-Htpasswd/pkg-plist b/security/p5-Apache-Htpasswd/pkg-plist
new file mode 100644
index 000000000000..a0e1c504f0a0
--- /dev/null
+++ b/security/p5-Apache-Htpasswd/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Apache/Htpasswd.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache/Htpasswd/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache/Htpasswd
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache
+@dirrmtry %%SITE_PERL%%/Apache