aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2018-03-17 18:44:07 +0800
committersunpoet <sunpoet@FreeBSD.org>2018-03-17 18:44:07 +0800
commitb0801697786cea0570a07050179b5b1c450e154d (patch)
tree23d1d2da6169fc3439d567460166f207d04c192a
parentc476e2ecb589e706674c57a7ad50e154b2741546 (diff)
downloadfreebsd-ports-gnome-b0801697786cea0570a07050179b5b1c450e154d.tar.gz
freebsd-ports-gnome-b0801697786cea0570a07050179b5b1c450e154d.tar.zst
freebsd-ports-gnome-b0801697786cea0570a07050179b5b1c450e154d.zip
Add p5-Progress-Any 0.211
Progress::Any is an interface for applications that want to display progress to users. It decouples progress updating and output, rather similar to how Log::Any decouples log producers and consumers (output). The API is also rather similar to Log::Any, except Adapter is called Output and category is called task. Progress::Any records position/target and calculates elapsed time, estimated remaining time, and percentage of completion. One or more output modules (Progress::Any::Output::*) display this information. WWW: http://search.cpan.org/dist/Progress-Any/
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Progress-Any/Makefile26
-rw-r--r--devel/p5-Progress-Any/distinfo3
-rw-r--r--devel/p5-Progress-Any/pkg-descr10
-rw-r--r--devel/p5-Progress-Any/pkg-plist6
5 files changed, 46 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 2b268b417379..dd2c8888e3d7 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3211,6 +3211,7 @@
SUBDIR += p5-Proc-Simple
SUBDIR += p5-Proc-Wait3
SUBDIR += p5-Proc-WaitStat
+ SUBDIR += p5-Progress-Any
SUBDIR += p5-Project-Gantt
SUBDIR += p5-Project-Libs
SUBDIR += p5-Pthread-GetThreadId
diff --git a/devel/p5-Progress-Any/Makefile b/devel/p5-Progress-Any/Makefile
new file mode 100644
index 000000000000..5ac04a4b18b3
--- /dev/null
+++ b/devel/p5-Progress-Any/Makefile
@@ -0,0 +1,26 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Progress-Any
+PORTVERSION= 0.211
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:PERLANCAR
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Record progress to any output
+
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= p5-Time-Duration>=0:devel/p5-Time-Duration
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-Test-Exception>=0:devel/p5-Test-Exception
+
+NO_ARCH= yes
+USE_PERL5= configure
+USES= perl5
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Progress-Any/distinfo b/devel/p5-Progress-Any/distinfo
new file mode 100644
index 000000000000..b44ee633beac
--- /dev/null
+++ b/devel/p5-Progress-Any/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1521282457
+SHA256 (Progress-Any-0.211.tar.gz) = 435c6fc71d3a7a09cd0a30beb8baed6bb5ea6a18484eead5957beafb57b8a0f5
+SIZE (Progress-Any-0.211.tar.gz) = 29996
diff --git a/devel/p5-Progress-Any/pkg-descr b/devel/p5-Progress-Any/pkg-descr
new file mode 100644
index 000000000000..4a2382d15016
--- /dev/null
+++ b/devel/p5-Progress-Any/pkg-descr
@@ -0,0 +1,10 @@
+Progress::Any is an interface for applications that want to display progress to
+users. It decouples progress updating and output, rather similar to how Log::Any
+decouples log producers and consumers (output). The API is also rather similar
+to Log::Any, except Adapter is called Output and category is called task.
+
+Progress::Any records position/target and calculates elapsed time, estimated
+remaining time, and percentage of completion. One or more output modules
+(Progress::Any::Output::*) display this information.
+
+WWW: http://search.cpan.org/dist/Progress-Any/
diff --git a/devel/p5-Progress-Any/pkg-plist b/devel/p5-Progress-Any/pkg-plist
new file mode 100644
index 000000000000..96a190af95e7
--- /dev/null
+++ b/devel/p5-Progress-Any/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/Progress/Any.pm
+%%SITE_PERL%%/Progress/Any/Output.pm
+%%SITE_PERL%%/Progress/Any/Output/Null.pm
+%%PERL5_MAN3%%/Progress::Any.3.gz
+%%PERL5_MAN3%%/Progress::Any::Output.3.gz
+%%PERL5_MAN3%%/Progress::Any::Output::Null.3.gz