aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2020-09-23 00:20:01 +0800
committerStefan Eßer <se@FreeBSD.org>2020-09-23 00:20:01 +0800
commitb0a411162e00f4f449fac188094170736c117884 (patch)
tree916c79763e915c125089753760d581c289abaf8b
parent4ddba349f5c1b77ee0ffe8e49cb33755ab786b30 (diff)
downloadfreebsd-ports-gnome-b0a411162e00f4f449fac188094170736c117884.tar.gz
freebsd-ports-gnome-b0a411162e00f4f449fac188094170736c117884.tar.zst
freebsd-ports-gnome-b0a411162e00f4f449fac188094170736c117884.zip
Fix build with -fno-common
-rw-r--r--lang/ccl/Makefile1
-rw-r--r--lang/ccl/files/patch-lisp-kernel_area.h11
-rw-r--r--lang/ccl/files/patch-lisp-kernel_gc-common.c12
-rw-r--r--lang/ccl/files/patch-lisp-kernel_gc.h66
-rw-r--r--lang/ccl/files/patch-lisp-kernel_pmcl-kernel.c11
-rw-r--r--lang/ccl/files/patch-lisp-kernel_threads.h11
6 files changed, 112 insertions, 0 deletions
diff --git a/lang/ccl/Makefile b/lang/ccl/Makefile
index bf355e2c6bf7..741926d1b539 100644
--- a/lang/ccl/Makefile
+++ b/lang/ccl/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ccl
DISTVERSIONPREFIX= v
DISTVERSION= 1.12
+PORTREVISION= 1
CATEGORIES= lang lisp
MASTER_SITES+= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/releases/download/v${PORTVERSION}/:bootstrap
DISTFILES= freebsdx86.tar.gz:bootstrap
diff --git a/lang/ccl/files/patch-lisp-kernel_area.h b/lang/ccl/files/patch-lisp-kernel_area.h
new file mode 100644
index 000000000000..29a44b9fb311
--- /dev/null
+++ b/lang/ccl/files/patch-lisp-kernel_area.h
@@ -0,0 +1,11 @@
+--- lisp-kernel/area.h.orig 2020-04-19 21:32:56 UTC
++++ lisp-kernel/area.h
+@@ -108,7 +108,7 @@ Boolean grow_dynamic_area(natural);
+ Boolean shrink_dynamic_area(natural);
+
+ /* serialize add_area/remove_area, and also the tcr queue */
+-void *tcr_area_lock;
++extern void *tcr_area_lock;
+
+ #define reserved_area ((area *)(all_areas))
+ #define active_dynamic_area ((area *)(reserved_area->succ))
diff --git a/lang/ccl/files/patch-lisp-kernel_gc-common.c b/lang/ccl/files/patch-lisp-kernel_gc-common.c
new file mode 100644
index 000000000000..e03167c2bf01
--- /dev/null
+++ b/lang/ccl/files/patch-lisp-kernel_gc-common.c
@@ -0,0 +1,12 @@
+--- lisp-kernel/gc-common.c.orig 2020-04-19 21:32:56 UTC
++++ lisp-kernel/gc-common.c
+@@ -24,6 +24,9 @@
+ #include <stdlib.h>
+ #include <string.h>
+
++LispObj *GCrelocptr, *global_reloctab;
++LispObj GCfirstunmarked;
++
+ #ifndef WINDOWS
+ #include <sys/time.h>
+ #endif
diff --git a/lang/ccl/files/patch-lisp-kernel_gc.h b/lang/ccl/files/patch-lisp-kernel_gc.h
new file mode 100644
index 000000000000..bf1546d2a061
--- /dev/null
+++ b/lang/ccl/files/patch-lisp-kernel_gc.h
@@ -0,0 +1,66 @@
+--- lisp-kernel/gc.h.orig 2020-04-19 21:32:56 UTC
++++ lisp-kernel/gc.h
+@@ -62,8 +62,8 @@
+ extern LispObj GCarealow, GCareadynamiclow;
+ extern natural GCndnodes_in_area, GCndynamic_dnodes_in_area;
+ extern bitvector GCmarkbits, GCdynamic_markbits,managed_static_refbits,global_refidx,dynamic_refidx,managed_static_refidx;
+-LispObj *global_reloctab, *GCrelocptr;
+-LispObj GCfirstunmarked;
++extern LispObj *global_reloctab, *GCrelocptr;
++extern LispObj GCfirstunmarked;
+
+ extern natural lisp_heap_gc_threshold;
+ extern natural lisp_heap_notify_threshold;
+@@ -83,7 +83,7 @@ void gc(TCR *, signed_natural);
+ int change_hons_area_size(TCR *, signed_natural);
+ void delete_protected_area(protected_area_ptr);
+ Boolean egc_control(Boolean, BytePtr);
+-Boolean free_segments_zero_filled_by_OS;
++extern Boolean free_segments_zero_filled_by_OS;
+ Boolean new_heap_segment(ExceptionInformation *, natural, Boolean , TCR *, Boolean *);
+ void platform_new_heap_segment(ExceptionInformation *, TCR*, BytePtr, BytePtr);
+ /* an type representing 1/4 of a natural word */
+@@ -153,19 +153,19 @@ void report_paging_info_delta(FILE*, paging_info *, pa
+ #define GC_TRAP_FUNCTION_FREEZE 129
+ #define GC_TRAP_FUNCTION_THAW 130
+
+-Boolean GCDebug, GCverbose, just_purified_p;
+-bitvector GCmarkbits, GCdynamic_markbits;
+-LispObj GCarealow, GCareadynamiclow;
+-natural GCndnodes_in_area, GCndynamic_dnodes_in_area;
+-LispObj GCweakvll,GCdwsweakvll;
+-LispObj GCephemeral_low;
+-natural GCn_ephemeral_dnodes;
+-natural GCstack_limit;
++extern Boolean GCDebug, GCverbose, just_purified_p;
++extern bitvector GCmarkbits, GCdynamic_markbits;
++extern LispObj GCarealow, GCareadynamiclow;
++extern natural GCndnodes_in_area, GCndynamic_dnodes_in_area;
++extern LispObj GCweakvll,GCdwsweakvll;
++extern LispObj GCephemeral_low;
++extern natural GCn_ephemeral_dnodes;
++extern natural GCstack_limit;
+
+ #if WORD_SIZE == 64
+-unsigned short *_one_bits;
++extern unsigned short *_one_bits;
+ #else
+-const unsigned char _one_bits[256];
++extern const unsigned char _one_bits[256];
+ #endif
+
+ #define one_bits(x) _one_bits[x]
+@@ -195,11 +195,11 @@ void gc(TCR *, signed_natural);
+ /* backend-interface */
+
+ typedef void (*weak_mark_fun) (LispObj);
+-weak_mark_fun mark_weak_htabv, dws_mark_weak_htabv;
++extern weak_mark_fun mark_weak_htabv, dws_mark_weak_htabv;
+
+ typedef void (*weak_process_fun)(void);
+
+-weak_process_fun markhtabvs;
++extern weak_process_fun markhtabvs;
+
+
+ #define hash_table_vector_header_count (sizeof(hash_table_vector_header)/sizeof(LispObj))
diff --git a/lang/ccl/files/patch-lisp-kernel_pmcl-kernel.c b/lang/ccl/files/patch-lisp-kernel_pmcl-kernel.c
new file mode 100644
index 000000000000..1b7a8c8f689a
--- /dev/null
+++ b/lang/ccl/files/patch-lisp-kernel_pmcl-kernel.c
@@ -0,0 +1,11 @@
+--- lisp-kernel/pmcl-kernel.c.orig 2020-04-19 21:32:56 UTC
++++ lisp-kernel/pmcl-kernel.c
+@@ -151,7 +151,7 @@ wperror(char* message)
+
+ LispObj lisp_nil = (LispObj) 0;
+ bitvector global_mark_ref_bits = NULL, dynamic_mark_ref_bits = NULL, relocatable_mark_ref_bits = NULL, global_refidx = NULL, dynamic_refidx = NULL,managed_static_refidx = NULL;
+-
++void *tcr_area_lock;
+
+ /* These are all "persistent" : they're initialized when
+ subprims are first loaded and should never change. */
diff --git a/lang/ccl/files/patch-lisp-kernel_threads.h b/lang/ccl/files/patch-lisp-kernel_threads.h
new file mode 100644
index 000000000000..25255bc91718
--- /dev/null
+++ b/lang/ccl/files/patch-lisp-kernel_threads.h
@@ -0,0 +1,11 @@
+--- lisp-kernel/threads.h.orig 2020-04-19 21:32:56 UTC
++++ lisp-kernel/threads.h
+@@ -187,7 +187,7 @@ void tsd_set(LispObj, void *);
+ void *tsd_get(LispObj);
+ TCR *new_tcr(natural, natural);
+ void thread_init_tcr(TCR *tcr, void *stack_base, natural stack_size);
+-TCR *initial_thread_tcr;
++extern TCR *initial_thread_tcr;
+
+ #define DEFAULT_THREAD_STACK_SIZE ((size_t) -1)
+ #define MINIMAL_THREAD_STACK_SIZE ((size_t) 0)