aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorolivierd <olivierd@FreeBSD.org>2014-01-28 01:14:55 +0800
committerolivierd <olivierd@FreeBSD.org>2014-01-28 01:14:55 +0800
commitb1ffef49bf10c38c363ba02f9078a4dddbf99d78 (patch)
tree55bbc20d10b55be1fa585386a93ff56a0c2fa5f4
parent8e2cfff5f6ede1faea2cd664e23e9764e17a2693 (diff)
downloadfreebsd-ports-gnome-b1ffef49bf10c38c363ba02f9078a4dddbf99d78.tar.gz
freebsd-ports-gnome-b1ffef49bf10c38c363ba02f9078a4dddbf99d78.tar.zst
freebsd-ports-gnome-b1ffef49bf10c38c363ba02f9078a4dddbf99d78.zip
- Support STAGEDIR
- Fix Python version - Remove indefinite article in COMMENT entry - Use new LIB_DEPENDS syntax - Replace USE_GNOME= desktopfileutils to USES= desktop-file-utils - Replace tab by space in WWW entry (pkg-descr)
-rw-r--r--graphics/electrix/Makefile19
-rw-r--r--graphics/electrix/pkg-descr2
-rw-r--r--graphics/electrix/pkg-plist2
3 files changed, 8 insertions, 15 deletions
diff --git a/graphics/electrix/Makefile b/graphics/electrix/Makefile
index 50470e8f0e8f..8ea31e059d67 100644
--- a/graphics/electrix/Makefile
+++ b/graphics/electrix/Makefile
@@ -7,17 +7,16 @@ CATEGORIES= graphics print
MASTER_SITES= SF/${PORTNAME:L}/${PORTVERSION}
MAINTAINER= olivierd@FreeBSD.org
-COMMENT= An application to view PDF files
+COMMENT= Application to view PDF files
LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/COPYING
-USES= pkgconfig
+USES= pkgconfig desktop-file-utils
USE_BZIP2= yes
-USE_GNOME= gtk20 desktopfileutils intltool intlhack
-USE_PYTHON= yes
+USE_GNOME= gtk20 glib20 intltool intlhack
+USE_PYTHON= 2
-CONFIGURE_ARGS= --prefix=${PREFIX}
+CONFIGURE_ARGS= --prefix=${STAGEDIR}${PREFIX}
OPTIONS_DEFINE= DBUS NLS PDF PS
OPTIONS_DEFAULT= DBUS PDF
@@ -25,11 +24,10 @@ OPTIONS_DEFAULT= DBUS PDF
PDF_DESC= Portable Document Format Support
PS_DESC= PostScript Support
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDBUS}
-LIB_DEPENDS+= dbus-glib-1:${PORTSDIR}/devel/dbus-glib
+LIB_DEPENDS+= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib
.else
CONFIGURE_ARGS+= --disable-dbus
.endif
@@ -49,7 +47,7 @@ CONFIGURE_ARGS+= --disable-pdf
.endif
.if ${PORT_OPTIONS:MPS}
-LIB_DEPENDS+= spectre:${PORTSDIR}/print/libspectre
+LIB_DEPENDS+= libspectre.so:${PORTSDIR}/print/libspectre
.else
CONFIGURE_ARGS+= --disable-ps
.endif
@@ -64,7 +62,4 @@ do-build:
do-install:
@cd ${WRKSRC} && ${SETENV} ${PYTHON_CMD} waf install && ${TRUE}
-post-install:
- @-update-desktop-database
-
.include <bsd.port.mk>
diff --git a/graphics/electrix/pkg-descr b/graphics/electrix/pkg-descr
index 83c6c9f72034..09d48eae5e7c 100644
--- a/graphics/electrix/pkg-descr
+++ b/graphics/electrix/pkg-descr
@@ -6,4 +6,4 @@ Features:
- fullscreen mode
- tabs
-WWW: http://electrix.sourceforge.net/
+WWW: http://electrix.sourceforge.net/
diff --git a/graphics/electrix/pkg-plist b/graphics/electrix/pkg-plist
index 16a34fcf1af8..552230519941 100644
--- a/graphics/electrix/pkg-plist
+++ b/graphics/electrix/pkg-plist
@@ -3,5 +3,3 @@ share/applications/electrix.desktop
%%NLS%%share/locale/ru/LC_MESSAGES/electrix.mo
%%NLS%%share/locale/sv/LC_MESSAGES/electrix.mo
%%NLS%%share/locale/tr/LC_MESSAGES/electrix.mo
-@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
-@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true