aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2013-09-05 16:06:33 +0800
committerthierry <thierry@FreeBSD.org>2013-09-05 16:06:33 +0800
commitb21c7c2eb4cc702f65405fd4cf99bfb02f76e12a (patch)
tree9db7f86a00644ca77488c38971a02304e7c756ff
parent7b43e138c4037ef88e25add066ccf27d2c5bab1c (diff)
downloadfreebsd-ports-gnome-b21c7c2eb4cc702f65405fd4cf99bfb02f76e12a.tar.gz
freebsd-ports-gnome-b21c7c2eb4cc702f65405fd4cf99bfb02f76e12a.tar.zst
freebsd-ports-gnome-b21c7c2eb4cc702f65405fd4cf99bfb02f76e12a.zip
Fix with clang.
Since I'm there, define the license. Reported by: pkg-fallout
-rw-r--r--sysutils/uniutils/Makefile8
-rw-r--r--sysutils/uniutils/files/patch-unifuzz.c11
2 files changed, 14 insertions, 5 deletions
diff --git a/sysutils/uniutils/Makefile b/sysutils/uniutils/Makefile
index faf13831d054..4686ec34fec7 100644
--- a/sysutils/uniutils/Makefile
+++ b/sysutils/uniutils/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: unidesc
-# Date created: Sun 15 May 2005
-# Whom: thierry@pompo.net
-#
+# Created by: thierry@pompo.net
# $FreeBSD$
-#
PORTNAME= uniutils
PORTVERSION= 2.27
@@ -14,6 +10,8 @@ MASTER_SITES= http://billposer.org/Software/Downloads/
MAINTAINER= thierry@FreeBSD.org
COMMENT= Unicode Description Utilities
+LICENSE= GPLv3
+
RUN_DEPENDS= ascii2binary:${PORTSDIR}/converters/ascii2binary
GNU_CONFIGURE= yes
diff --git a/sysutils/uniutils/files/patch-unifuzz.c b/sysutils/uniutils/files/patch-unifuzz.c
new file mode 100644
index 000000000000..1cbf01b5fab0
--- /dev/null
+++ b/sysutils/uniutils/files/patch-unifuzz.c
@@ -0,0 +1,11 @@
+--- unifuzz.c.orig 2008-04-04 06:30:58.000000000 +0200
++++ unifuzz.c 2013-09-05 09:50:49.000000000 +0200
+@@ -97,7 +97,7 @@
+ }
+
+ /* Emit the middle character from each range */
+-EmitAllRanges(short AboveBMPP) {
++void EmitAllRanges(short AboveBMPP) {
+ int i;
+ UTF32 scp;
+ extern int Ranges_Defined;