aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpkubaj <pkubaj@FreeBSD.org>2019-05-01 03:25:23 +0800
committerpkubaj <pkubaj@FreeBSD.org>2019-05-01 03:25:23 +0800
commitb22ba99c62b38af45271f8b860e39b37ee1910a0 (patch)
tree4953361a7aec2cb87e369835fd0d357354e79672
parent134bcd672a0fe9eac925ebdeab2eae6aae1265b4 (diff)
downloadfreebsd-ports-gnome-b22ba99c62b38af45271f8b860e39b37ee1910a0.tar.gz
freebsd-ports-gnome-b22ba99c62b38af45271f8b860e39b37ee1910a0.tar.zst
freebsd-ports-gnome-b22ba99c62b38af45271f8b860e39b37ee1910a0.zip
benchmarks/netperfmeter: fix build with GCC-based architectures
Remove option -Wno-array-bounds from CMakeLists.txt to fix build on GCC architectures. PR: 237041 Approved by: dreibh@iem.uni-due.de (maintainer timeout), mat (mentor) Differential Revision: https://reviews.freebsd.org/D20107
-rw-r--r--benchmarks/netperfmeter/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/benchmarks/netperfmeter/Makefile b/benchmarks/netperfmeter/Makefile
index 3863e16e7d2d..66af8f266012 100644
--- a/benchmarks/netperfmeter/Makefile
+++ b/benchmarks/netperfmeter/Makefile
@@ -12,14 +12,15 @@ COMMENT= Network Performance Meter
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_powerpc64= fails to compile: unrecognized command line option "-Wno-array-bounds"
-
USES= cmake shebangfix
CMAKE_ON= BUILD_PLOT_PROGRAMS
CMAKE_OFF= BUILD_TEST_PROGRAMS WITH_NEAT
SHEBANG_FILES= src/pdfembedfonts src/pdfmetadata src/plot-netperfmeter-results
post-patch:
+.if exists(/usr/lib/libstdc++.so)
+ @${REINPLACE_CMD} 's, -Wno-array-bounds,,g' ${WRKSRC}/CMakeLists.txt
+.endif
@${REINPLACE_CMD} 's,share/man,man,' ${WRKSRC}/CMakeLists.txt
.include <bsd.port.mk>