aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2006-11-28 06:37:42 +0800
committerkuriyama <kuriyama@FreeBSD.org>2006-11-28 06:37:42 +0800
commitb282ca878f3d7b32c421ea6b9948ffadfb4dd05b (patch)
tree8d0d8391d10f25ddb45a20aef6b595c05077d933
parentb1271be9c34c6aeff73c7fea41c0b0f01c141042 (diff)
downloadfreebsd-ports-gnome-b282ca878f3d7b32c421ea6b9948ffadfb4dd05b.tar.gz
freebsd-ports-gnome-b282ca878f3d7b32c421ea6b9948ffadfb4dd05b.tar.zst
freebsd-ports-gnome-b282ca878f3d7b32c421ea6b9948ffadfb4dd05b.zip
Fix buffer overflow.
References: http://lists.gnupg.org/pipermail/gnupg-announce/2006q4/000241.html
-rw-r--r--security/gnupg/Makefile2
-rw-r--r--security/gnupg/files/patch-openfile.c12
-rw-r--r--security/gnupg1/Makefile2
-rw-r--r--security/gnupg1/files/patch-openfile.c12
4 files changed, 26 insertions, 2 deletions
diff --git a/security/gnupg/Makefile b/security/gnupg/Makefile
index 92377e4eb934..902f7dcefaf7 100644
--- a/security/gnupg/Makefile
+++ b/security/gnupg/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnupg
PORTVERSION= 1.4.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNUPG}
MASTER_SITE_SUBDIR= gnupg
diff --git a/security/gnupg/files/patch-openfile.c b/security/gnupg/files/patch-openfile.c
new file mode 100644
index 000000000000..833b06cdafbf
--- /dev/null
+++ b/security/gnupg/files/patch-openfile.c
@@ -0,0 +1,12 @@
+--- g10/openfile.c.orig Tue Nov 28 07:13:53 2006
++++ g10/openfile.c Tue Nov 28 07:18:30 2006
+@@ -144,8 +144,8 @@
+
+ s = _("Enter new filename");
+
+- n = strlen(s) + namelen + 10;
+ defname = name && namelen? make_printable_string( name, namelen, 0): NULL;
++ n = strlen(s) + (defname?strlen (defname):0) + 10;
+ prompt = xmalloc(n);
+ if( defname )
+ sprintf(prompt, "%s [%s]: ", s, defname );
diff --git a/security/gnupg1/Makefile b/security/gnupg1/Makefile
index 92377e4eb934..902f7dcefaf7 100644
--- a/security/gnupg1/Makefile
+++ b/security/gnupg1/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnupg
PORTVERSION= 1.4.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNUPG}
MASTER_SITE_SUBDIR= gnupg
diff --git a/security/gnupg1/files/patch-openfile.c b/security/gnupg1/files/patch-openfile.c
new file mode 100644
index 000000000000..833b06cdafbf
--- /dev/null
+++ b/security/gnupg1/files/patch-openfile.c
@@ -0,0 +1,12 @@
+--- g10/openfile.c.orig Tue Nov 28 07:13:53 2006
++++ g10/openfile.c Tue Nov 28 07:18:30 2006
+@@ -144,8 +144,8 @@
+
+ s = _("Enter new filename");
+
+- n = strlen(s) + namelen + 10;
+ defname = name && namelen? make_printable_string( name, namelen, 0): NULL;
++ n = strlen(s) + (defname?strlen (defname):0) + 10;
+ prompt = xmalloc(n);
+ if( defname )
+ sprintf(prompt, "%s [%s]: ", s, defname );