aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorskreuzer <skreuzer@FreeBSD.org>2014-10-01 00:02:18 +0800
committerskreuzer <skreuzer@FreeBSD.org>2014-10-01 00:02:18 +0800
commitb2f9cc88668b645002c0f44abf66f89d455ab431 (patch)
tree4bf4fc180b64f12f6118216708a8337cdefb1fc4
parent33947d6b24d2a38c5321bd2f71b8a81093e4268d (diff)
downloadfreebsd-ports-gnome-b2f9cc88668b645002c0f44abf66f89d455ab431.tar.gz
freebsd-ports-gnome-b2f9cc88668b645002c0f44abf66f89d455ab431.tar.zst
freebsd-ports-gnome-b2f9cc88668b645002c0f44abf66f89d455ab431.zip
This API is mainly for Terminal Emulator implementors -- any python program
that attempts to determine the printable width of a string on a Terminal. It is certainly possible to use your Operating System's wcwidth() and wcswidth() calls if it is POSIX-conforming, but this would not be possible on non-POSIX platforms, such as Windows, or for alternative Python implementations, such as jython. WWW: https://github.com/jquast/wcwidth
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-wcwidth/Makefile18
-rw-r--r--devel/py-wcwidth/distinfo2
-rw-r--r--devel/py-wcwidth/pkg-descr9
4 files changed, 30 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 629baf575059..f860f6e9b4d1 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3978,6 +3978,7 @@
SUBDIR += py-virtualenv-clone
SUBDIR += py-virtualenvwrapper
SUBDIR += py-watchdog
+ SUBDIR += py-wcwidth
SUBDIR += py-wheel
SUBDIR += py-wsgi_xmlrpc
SUBDIR += py-wsgitools
diff --git a/devel/py-wcwidth/Makefile b/devel/py-wcwidth/Makefile
new file mode 100644
index 000000000000..c6d261406a9e
--- /dev/null
+++ b/devel/py-wcwidth/Makefile
@@ -0,0 +1,18 @@
+# Created by: Steven Kreuzer <skreuzer@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= wcwidth
+PORTVERSION= 0.1.1
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= skreuzer@FreeBSD.org
+COMMENT= Determine the printable width of the terminal
+
+LICENSE= MIT
+
+USES= python:2
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/devel/py-wcwidth/distinfo b/devel/py-wcwidth/distinfo
new file mode 100644
index 000000000000..3598760fabc3
--- /dev/null
+++ b/devel/py-wcwidth/distinfo
@@ -0,0 +1,2 @@
+SHA256 (wcwidth-0.1.1.tar.gz) = 019b71c91209e44c50a2cc97f50a60ed9bc35ca37b6f3f8fe3a6fdaafe58fc55
+SIZE (wcwidth-0.1.1.tar.gz) = 16349
diff --git a/devel/py-wcwidth/pkg-descr b/devel/py-wcwidth/pkg-descr
new file mode 100644
index 000000000000..9881559d2585
--- /dev/null
+++ b/devel/py-wcwidth/pkg-descr
@@ -0,0 +1,9 @@
+This API is mainly for Terminal Emulator implementors -- any python program
+that attempts to determine the printable width of a string on a Terminal.
+
+It is certainly possible to use your Operating System's wcwidth() and
+wcswidth() calls if it is POSIX-conforming, but this would not be possible on
+non-POSIX platforms, such as Windows, or for alternative Python
+implementations, such as jython.
+
+WWW: https://github.com/jquast/wcwidth