aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2004-07-28 08:38:58 +0800
committermezz <mezz@FreeBSD.org>2004-07-28 08:38:58 +0800
commitb3e257555cbec43c296150245e812a9523081271 (patch)
tree77666c03f64a012684c40c33228ef6e009d154d6
parent6d8bbfa3e3033573306c367e21aebbbd4e1010b0 (diff)
downloadfreebsd-ports-gnome-b3e257555cbec43c296150245e812a9523081271.tar.gz
freebsd-ports-gnome-b3e257555cbec43c296150245e812a9523081271.tar.zst
freebsd-ports-gnome-b3e257555cbec43c296150245e812a9523081271.zip
-Add aspell dependency with a new knob, WITHOUT_ASPELL.
-Bump the PORTREVISION for add a dependency. It's kind of shame that Opera needs libXm.so.2, but we have libXm.so.3 in the ports tree since 2002. The Linux version supports 1 to 3 but on FreeBSD version only support 1 to 2 that aren't exist in the ports tree. Speak of open-motif; not lesstif. Three ways to do: Create a new downgrade port of open-motif, add a symlink of libXm.so.2 in current open-motif or tell the users to use the libmap.conf for libXm.so.2 -> libXm.so.3? Any suggest? BTW: libXm.so.x is need for the plugins function.
-rw-r--r--www/opera/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/www/opera/Makefile b/www/opera/Makefile
index 37d37fd9cf5c..6ad180137869 100644
--- a/www/opera/Makefile
+++ b/www/opera/Makefile
@@ -7,6 +7,7 @@
PORTNAME= opera
PORTVERSION= ${OPERA_VER}.${OPERA_DATE}
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://ftp.scarlet.be/pub/opera/unix/freebsd/${OPERA_VER:S/.//}/${OPERA_REL}/en/static/ \
ftp://ftp.planetmirror.com/pub/opera/unix/freebsd/${OPERA_VER:S/.//}/${OPERA_REL}/en/static/ \
@@ -44,6 +45,10 @@ ONLY_FOR_ARCHS= i386
NO_BUILD= yes
NO_FILTER_SHLIBS=yes
+.ifndef(WITHOUT_ASPELL)
+LIB_DEPENDS+= aspell.15:${PORTSDIR}/textproc/aspell
+.endif
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500000
@@ -62,6 +67,13 @@ PLIST_SUB+= KDE=""
PLIST_SUB+= KDE="@comment "
.endif
+pre-everything::
+.if !defined(WITHOUT_ASPELL)
+ @${ECHO_CMD} '===> The following options are available for this port:'
+ @${ECHO_CMD} '===>'
+ @${ECHO_CMD} '===> Define WITHOUT_ASPELL to not install aspell.'
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g ; \
s|%%LOCALBASE%%|${LOCALBASE}|g ; s|%%X11BASE%%|${X11BASE}|g' \