aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-07-10 14:44:19 +0800
committerbapt <bapt@FreeBSD.org>2013-07-10 14:44:19 +0800
commitb41e4c8ce508f1206eba1b3746328e966b5be209 (patch)
tree53027539336e3d44fc38ec5b2d75f65850a46380
parentb538c21e15cd2d2b3273c4dcee114315bf927f0e (diff)
downloadfreebsd-ports-gnome-b41e4c8ce508f1206eba1b3746328e966b5be209.tar.gz
freebsd-ports-gnome-b41e4c8ce508f1206eba1b3746328e966b5be209.tar.zst
freebsd-ports-gnome-b41e4c8ce508f1206eba1b3746328e966b5be209.zip
Error message when not able to create the optiondir directory.
optiondir being defined in a subshell wasn't defined when the error message is printed. PR: ports/176849 Submitted by: Oleg Ginzburg <olevole@olevole.ru>
-rw-r--r--Mk/bsd.port.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index fb3f78abae5f..325ab7bc0019 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -6091,14 +6091,14 @@ do-config:
(${ECHO_MSG} "===> Cannot create $${optionsdir}, check permissions"; exit 1); \
${ECHO_MSG} "===> Returning to user credentials"
.else
- @(optionsdir=${OPTIONS_FILE}; optionsdir=$${optionsdir%/*}; \
+ @optionsdir=${OPTIONS_FILE}; optionsdir=$${optionsdir%/*}; \
oldoptionsdir=${OPTIONSFILE}; oldoptionsdir=$${oldoptionsdir%/*}; \
if [ -d $${oldoptionsdir} -a ! -d $${optionsdir} ]; then \
${MV} $${oldoptionsdir} $${optionsdir}; \
elif [ -d $${oldoptionsdir} -a -d $${optionsdir} ]; then \
${RM} -rf $${oldoptionsdir} ; \
fi ; \
- ${MKDIR} $${optionsdir} 2> /dev/null) || \
+ ${MKDIR} $${optionsdir} 2> /dev/null || \
(${ECHO_MSG} "===> Cannot create $${optionsdir}, check permissions"; exit 1)
.endif
@TMPOPTIONSFILE=$$(mktemp -t portoptions); \