aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2014-07-06 21:09:19 +0800
committerjohans <johans@FreeBSD.org>2014-07-06 21:09:19 +0800
commitb430cc859f4346ddb538c5719d9ae3f83865f351 (patch)
tree940c26b085a735109854e2d2be1737f3648005f7
parentf3ac29733749be9607ca2769e9677b4a9d259423 (diff)
downloadfreebsd-ports-gnome-b430cc859f4346ddb538c5719d9ae3f83865f351.tar.gz
freebsd-ports-gnome-b430cc859f4346ddb538c5719d9ae3f83865f351.tar.zst
freebsd-ports-gnome-b430cc859f4346ddb538c5719d9ae3f83865f351.zip
- Modernise options
- Tindy STAGEDIR - Bump PORTREVISON for plist changes
-rw-r--r--lang/pfe/Makefile20
-rw-r--r--lang/pfe/pkg-plist19
2 files changed, 11 insertions, 28 deletions
diff --git a/lang/pfe/Makefile b/lang/pfe/Makefile
index 47f9224f6279..78f9e3f463b0 100644
--- a/lang/pfe/Makefile
+++ b/lang/pfe/Makefile
@@ -3,28 +3,28 @@
PORTNAME= pfe
PORTVERSION= 0.33.71
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= SF
MAINTAINER= johans@FreeBSD.org
COMMENT= Implementation of ANSI Forth
-USE_BZIP2= yes
-USES= gmake perl5
+GNU_CONFIGURE= yes
+USES= gmake perl5 libtool tar:bzip2
USE_PERL5= build
-USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
-LIBTOOLFILES= pfe/configure
MAKE_ARGS= pkgconfigdir="${PREFIX}/libdata/pkgconfig"
+INSTALL_TARGET= install-strip
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "powerpc"
-BROKEN= does not compile
-.endif
+BROKEN_powerpc= does not compile
post-patch:
@${REINPLACE_CMD} -e 's|^CFLAGS=|#CFLAGS=|g ; \
s|-O$$opt_level||g' ${WRKSRC}/pfe/configure
-.include <bsd.port.post.mk>
+post-install:
+ @test -d "${STAGEDIR}" && ${RM} -rf ${STAGEDIR}/usr/ports
+ ${LN} -s libpfe-0-forth.so.33 ${STAGEDIR}${PREFIX}/lib/libpfe-0-forth.so
+
+.include <bsd.port.mk>
diff --git a/lang/pfe/pkg-plist b/lang/pfe/pkg-plist
index b7be01e317bb..2a1941bfb0b8 100644
--- a/lang/pfe/pkg-plist
+++ b/lang/pfe/pkg-plist
@@ -103,35 +103,26 @@ include/pfe/version-sub.h
include/pfe/your-ext.h
lib/libpfe-0-forth.so
lib/libpfe-0-forth.so.33
+lib/libpfe-0-forth.so.33.0.71
lib/libpfe.a
-lib/libpfe.la
lib/libpfe.so
lib/pfe-forth/assembler.a
-lib/pfe-forth/assembler.la
lib/pfe-forth/assembler.so
lib/pfe-forth/complex.a
-lib/pfe-forth/complex.la
lib/pfe-forth/complex.so
lib/pfe-forth/dstrings.a
-lib/pfe-forth/dstrings.la
lib/pfe-forth/dstrings.so
lib/pfe-forth/edit.a
-lib/pfe-forth/edit.la
lib/pfe-forth/edit.so
lib/pfe-forth/floating.a
-lib/pfe-forth/floating.la
lib/pfe-forth/floating.so
lib/pfe-forth/fpnostack.a
-lib/pfe-forth/fpnostack.la
lib/pfe-forth/fpnostack.so
lib/pfe-forth/gforth.a
-lib/pfe-forth/gforth.la
lib/pfe-forth/gforth.so
lib/pfe-forth/help.a
-lib/pfe-forth/help.la
lib/pfe-forth/help.so
lib/pfe-forth/module.a
-lib/pfe-forth/module.la
lib/pfe-forth/module.so
lib/pfe-forth/renamed/libassembler.so
lib/pfe-forth/renamed/libcomplex.so
@@ -151,28 +142,20 @@ lib/pfe-forth/renamed/libtermcatch.so
lib/pfe-forth/renamed/libtoolbelt.so
lib/pfe-forth/renamed/libzchar.so
lib/pfe-forth/smart-go.a
-lib/pfe-forth/smart-go.la
lib/pfe-forth/smart-go.so
lib/pfe-forth/socket.a
-lib/pfe-forth/socket.la
lib/pfe-forth/socket.so
lib/pfe-forth/stackhelp.a
-lib/pfe-forth/stackhelp.la
lib/pfe-forth/stackhelp.so
lib/pfe-forth/struct.a
-lib/pfe-forth/struct.la
lib/pfe-forth/struct.so
lib/pfe-forth/structs.a
-lib/pfe-forth/structs.la
lib/pfe-forth/structs.so
lib/pfe-forth/termcatch.a
-lib/pfe-forth/termcatch.la
lib/pfe-forth/termcatch.so
lib/pfe-forth/toolbelt.a
-lib/pfe-forth/toolbelt.la
lib/pfe-forth/toolbelt.so
lib/pfe-forth/zchar.a
-lib/pfe-forth/zchar.la
lib/pfe-forth/zchar.so
libdata/pkgconfig/pfe.pc
man/man1/pfe.1.gz