aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2013-12-17 04:45:37 +0800
committerThierry Thomas <thierry@FreeBSD.org>2013-12-17 04:45:37 +0800
commitb43152157fbe991034a8a5049993764bf93e74bf (patch)
tree71e2f6e3e053162ebda5df850de3c4f56d636180
parentc466b96f3b1081da803d35068ac8bea8beecf4e5 (diff)
downloadfreebsd-ports-gnome-b43152157fbe991034a8a5049993764bf93e74bf.tar.gz
freebsd-ports-gnome-b43152157fbe991034a8a5049993764bf93e74bf.tar.zst
freebsd-ports-gnome-b43152157fbe991034a8a5049993764bf93e74bf.zip
Fix a problem with the control applet and playbar.
Submitted by: bar Approved by: maintainer
-rw-r--r--multimedia/mplayer/Makefile2
-rw-r--r--multimedia/mplayer/files/patch-gui_ws_ws.c10
2 files changed, 11 insertions, 1 deletions
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index e621815cef7a..0f786d2042f2 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mplayer
PORTVERSION= ${MPLAYER_PORT_VERSION}
-PORTREVISION= 0
+PORTREVISION= 1
COMMENT= High performance media player supporting many formats
diff --git a/multimedia/mplayer/files/patch-gui_ws_ws.c b/multimedia/mplayer/files/patch-gui_ws_ws.c
new file mode 100644
index 000000000000..0a9e87701ebd
--- /dev/null
+++ b/multimedia/mplayer/files/patch-gui_ws_ws.c
@@ -0,0 +1,10 @@
+--- gui/wm/ws.c.orig 2013-08-03 00:42:05.000000000 +0200
++++ gui/wm/ws.c 2013-12-16 10:13:26.000000000 +0100
+@@ -1322,6 +1322,7 @@
+ win->xImage->data = win->Shminfo.shmaddr;
+ win->Shminfo.readOnly = False;
+ XShmAttach(wsDisplay, &win->Shminfo);
++ XSync(wsDisplay, False);
+ shmctl(win->Shminfo.shmid, IPC_RMID, 0);
+ } else
+ #endif