aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2005-02-09 18:00:04 +0800
committerleeym <leeym@FreeBSD.org>2005-02-09 18:00:04 +0800
commitb45e234b45c145237c2e8d03e2e0a0c6f3100347 (patch)
tree0c2985ba19c3903add0955b57f1439c06efc1679
parentf44b183830a4ec5f0d73d1b944bb48914b1910aa (diff)
downloadfreebsd-ports-gnome-b45e234b45c145237c2e8d03e2e0a0c6f3100347.tar.gz
freebsd-ports-gnome-b45e234b45c145237c2e8d03e2e0a0c6f3100347.tar.zst
freebsd-ports-gnome-b45e234b45c145237c2e8d03e2e0a0c6f3100347.zip
- use external libintl to avoid updating lib/charset.alias problem
Noticed by: kris
-rw-r--r--sysutils/dar/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/sysutils/dar/Makefile b/sysutils/dar/Makefile
index 954fa8fe8778..19936aeec3e9 100644
--- a/sysutils/dar/Makefile
+++ b/sysutils/dar/Makefile
@@ -16,12 +16,14 @@ COMMENT= A full featured command-line backup tool, aimed for disks
INSTALLS_SHLIB= yes
USE_LIBTOOL_VER=15
+USE_REINPLACE= yes
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS+=--with-libintl-prefix=${PREFIX}
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
.else
CONFIGURE_ARGS+=--disable-nls
@@ -30,4 +32,8 @@ PLIST_SUB+= NLS="@comment "
MAN1= dar.1 dar_cp.1 dar_manager.1 dar_slave.1 dar_xform.1
+post-patch:
+ @${REINPLACE_CMD} -Ee 's,(_nl_expand_alias) \(0\),\1 (),g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+
.include <bsd.port.mk>