aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2006-06-29 19:18:18 +0800
committeritetcu <itetcu@FreeBSD.org>2006-06-29 19:18:18 +0800
commitb60ef2bc732197f2ed40e3f3d93c9e8fb1f843d1 (patch)
treeb6b4b19b2cdf89e6fd61ecd0c7d7d4ec1d07055d
parent611d0db6114fa1477cbf5a396cd1b7f381ec37dc (diff)
downloadfreebsd-ports-gnome-b60ef2bc732197f2ed40e3f3d93c9e8fb1f843d1.tar.gz
freebsd-ports-gnome-b60ef2bc732197f2ed40e3f3d93c9e8fb1f843d1.tar.zst
freebsd-ports-gnome-b60ef2bc732197f2ed40e3f3d93c9e8fb1f843d1.zip
TaskStep is a list and to-do manager for local php servers. It requires a
server (preferably local) and a decent browser (Firefox, not IE6). It is designed to work vaguely with fans of GTD and act as a slightly more advanced task manager which can be kept on your computer, rather than over the internet (although in theory you can put it up on the internet). Here is a quick summary of the main features: * Sections for tasks organising them by immediate, this week, this month, this year and lifetime tasks * Add and filter by contexts and projects (for Getting Things Done fans) * Print lists on 3 x 5 index cards * Automatically list all items for today * Highlighting of current and overdue items * Mark items as done on the spot, with a done button for each * Small. As in really really ridiculously small (~160KB download file) * It's free, but that's probably stating the obvious WWW: http://taskstep.cunningtitle.co.uk/ - Babak Farrokhi babak@farrokhi.net PR: ports/99180 Submitted by: Babak Farrokhi <babak@farrokhi.net>
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/taskstep/Makefile41
-rw-r--r--deskutils/taskstep/distinfo3
-rw-r--r--deskutils/taskstep/files/pkg-message.in12
-rw-r--r--deskutils/taskstep/pkg-descr22
-rw-r--r--deskutils/taskstep/pkg-plist165
6 files changed, 244 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index 1d0a1036ad57..c2e97ffd7ea2 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -142,6 +142,7 @@
SUBDIR += superkaramba-lwp
SUBDIR += superswitcher
SUBDIR += taskjuggler
+ SUBDIR += taskstep
SUBDIR += teapot
SUBDIR += timer-applet
SUBDIR += tomboy
diff --git a/deskutils/taskstep/Makefile b/deskutils/taskstep/Makefile
new file mode 100644
index 000000000000..84c7616d05e4
--- /dev/null
+++ b/deskutils/taskstep/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: taskstep
+# Date created: 2006-06-19
+# Whom: Babak Farrokhi <babak@farrokhi.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= taskstep
+PORTVERSION= 0.5
+CATEGORIES= deskutils www
+MASTER_SITES= http://taskstep.cunningtitle.co.uk/releases/
+DISTNAME= ${PORTNAME}-05
+
+MAINTAINER= babak@farrokhi.net
+COMMENT= Web based to-do list manager written in php
+
+NO_BUILD= YES
+USE_PHP= mysql
+WANT_PHP_WEB= YES
+USE_ZIP= YES
+EXTRACT_AFTER_ARGS= -d ${WRKSRC}
+
+TASKSTEP?= www/taskstep
+PLIST_SUB+= TASKSTEP=${TASKSTEP}
+SUB_LIST+= TASKSTEP=${TASKSTEP}
+SUB_FILES= pkg-message
+
+pre-everything::
+ @${ECHO_CMD}
+ @${ECHO_CMD} "Set, if you need, relative to PREFIX (default: /usr/local):"
+ @${ECHO_CMD} "TASKSTEP=${TASKSTEP} (default: www/taskstep)"
+ @${ECHO_CMD}
+
+do-install:
+ @${MKDIR} ${PREFIX}/${TASKSTEP}
+ @${CP} -R ${WRKSRC}/ ${PREFIX}/${TASKSTEP}
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${TASKSTEP}
+ @${CHMOD} -R 755 ${PREFIX}/${TASKSTEP}
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/deskutils/taskstep/distinfo b/deskutils/taskstep/distinfo
new file mode 100644
index 000000000000..d748be45af07
--- /dev/null
+++ b/deskutils/taskstep/distinfo
@@ -0,0 +1,3 @@
+MD5 (taskstep-05.zip) = f1bf5e4ae17bd26ce9d1987282f3b013
+SHA256 (taskstep-05.zip) = 6a3806b632bfd7f5e6a0c812ce25b448099b4cfb85ffa2f53e2037fd36d5f913
+SIZE (taskstep-05.zip) = 258415
diff --git a/deskutils/taskstep/files/pkg-message.in b/deskutils/taskstep/files/pkg-message.in
new file mode 100644
index 000000000000..19f784c63321
--- /dev/null
+++ b/deskutils/taskstep/files/pkg-message.in
@@ -0,0 +1,12 @@
+
+===========================================================
+
+To set up TASKSTEP:
+
+ 1- edit %%PREFIX%%/%%TASKSTEP%%/install/config.php and
+ setup your mysql login
+ 2- create taskstep database in your mysql server
+ 3- point your browser to:
+ http://YOUR_SERVER/TASKSTEP_PATH/install/install.php
+
+===========================================================
diff --git a/deskutils/taskstep/pkg-descr b/deskutils/taskstep/pkg-descr
new file mode 100644
index 000000000000..e8eae1d0e7e9
--- /dev/null
+++ b/deskutils/taskstep/pkg-descr
@@ -0,0 +1,22 @@
+TaskStep is a list and to-do manager for local php servers. It requires a
+server (preferably local) and a decent browser (Firefox, not IE6).
+
+It is designed to work vaguely with fans of GTD and act as a slightly more
+advanced task manager which can be kept on your computer, rather than over the
+internet (although in theory you can put it up on the internet).
+
+Here is a quick summary of the main features:
+ * Sections for tasks organising them by immediate, this week, this month,
+this year and lifetime tasks
+ * Add and filter by contexts and projects (for Getting Things Done fans)
+ * Print lists on 3 x 5 index cards
+ * Automatically list all items for today
+ * Highlighting of current and overdue items
+ * Mark items as done on the spot, with a done button for each
+ * Small. As in really really ridiculously small (~160KB download file)
+ * It's free, but that's probably stating the obvious
+
+WWW: http://taskstep.cunningtitle.co.uk/
+
+- Babak Farrokhi
+babak@farrokhi.net
diff --git a/deskutils/taskstep/pkg-plist b/deskutils/taskstep/pkg-plist
new file mode 100644
index 000000000000..cc85101f5e34
--- /dev/null
+++ b/deskutils/taskstep/pkg-plist
@@ -0,0 +1,165 @@
+%%TASKSTEP%%/action.php
+%%TASKSTEP%%/add.php
+%%TASKSTEP%%/config/__xc2_default.js
+%%TASKSTEP%%/config/xc2_default.js
+%%TASKSTEP%%/css/xc2_default.css
+%%TASKSTEP%%/css/xc2_image.css
+%%TASKSTEP%%/display.php
+%%TASKSTEP%%/display_context.php
+%%TASKSTEP%%/display_project.php
+%%TASKSTEP%%/edit.php
+%%TASKSTEP%%/edit_contexts.php
+%%TASKSTEP%%/edit_projects.php
+%%TASKSTEP%%/exported_results.csv
+%%TASKSTEP%%/google_display.php
+%%TASKSTEP%%/google_style.css
+%%TASKSTEP%%/header.php
+%%TASKSTEP%%/images/Thumbs.db
+%%TASKSTEP%%/images/accept.png
+%%TASKSTEP%%/images/add.png
+%%TASKSTEP%%/images/application_get.png
+%%TASKSTEP%%/images/bin.png
+%%TASKSTEP%%/images/bin_empty.png
+%%TASKSTEP%%/images/bomb.png
+%%TASKSTEP%%/images/bookmarklet.jpg
+%%TASKSTEP%%/images/calendar.png
+%%TASKSTEP%%/images/calendar_view_day.png
+%%TASKSTEP%%/images/cart.png
+%%TASKSTEP%%/images/chart_bar.png
+%%TASKSTEP%%/images/cog_edit.png
+%%TASKSTEP%%/images/cross.png
+%%TASKSTEP%%/images/date.png
+%%TASKSTEP%%/images/door_in.png
+%%TASKSTEP%%/images/exclamation.png
+%%TASKSTEP%%/images/flag_red.png
+%%TASKSTEP%%/images/flag_yellow.png
+%%TASKSTEP%%/images/folder.png
+%%TASKSTEP%%/images/folder_edit.png
+%%TASKSTEP%%/images/help.png
+%%TASKSTEP%%/images/icon.png
+%%TASKSTEP%%/images/information.png
+%%TASKSTEP%%/images/lightbulb.png
+%%TASKSTEP%%/images/lightning.png
+%%TASKSTEP%%/images/newspaper.png
+%%TASKSTEP%%/images/note_go.png
+%%TASKSTEP%%/images/page.png
+%%TASKSTEP%%/images/page_white_excel.png
+%%TASKSTEP%%/images/pencil.png
+%%TASKSTEP%%/images/pencil_go.png
+%%TASKSTEP%%/images/printer.png
+%%TASKSTEP%%/images/shield.png
+%%TASKSTEP%%/images/shield_error.png
+%%TASKSTEP%%/images/table.png
+%%TASKSTEP%%/images/table_edit.png
+%%TASKSTEP%%/images/textfield_rename.png
+%%TASKSTEP%%/images/tick.png
+%%TASKSTEP%%/images/undone.png
+%%TASKSTEP%%/images/user.png
+%%TASKSTEP%%/images/world.png
+%%TASKSTEP%%/index.php
+%%TASKSTEP%%/install/Crystal_package.png
+%%TASKSTEP%%/install/accept.png
+%%TASKSTEP%%/install/cog_error.png
+%%TASKSTEP%%/install/cog_go.png
+%%TASKSTEP%%/install/config.php
+%%TASKSTEP%%/install/database_error.png
+%%TASKSTEP%%/install/database_go.png
+%%TASKSTEP%%/install/exclamation.png
+%%TASKSTEP%%/install/install-icon.png
+%%TASKSTEP%%/install/install-style.css
+%%TASKSTEP%%/install/install.php
+%%TASKSTEP%%/install/shield.png
+%%TASKSTEP%%/install/table_error.png
+%%TASKSTEP%%/install/table_go.png
+%%TASKSTEP%%/install/update-latest.php
+%%TASKSTEP%%/install/update-old-2&3.php
+%%TASKSTEP%%/login.php
+%%TASKSTEP%%/logout.php
+%%TASKSTEP%%/modern.css
+%%TASKSTEP%%/print-style.css
+%%TASKSTEP%%/print.css
+%%TASKSTEP%%/print.php
+%%TASKSTEP%%/print_context.php
+%%TASKSTEP%%/print_project.php
+%%TASKSTEP%%/print_today.php
+%%TASKSTEP%%/readme.htm
+%%TASKSTEP%%/script/fat.js
+%%TASKSTEP%%/script/mod_date.js
+%%TASKSTEP%%/script/mod_days.js
+%%TASKSTEP%%/script/mod_info.js
+%%TASKSTEP%%/script/mod_journal.js
+%%TASKSTEP%%/script/mod_link.js
+%%TASKSTEP%%/script/mod_list.js
+%%TASKSTEP%%/script/mod_long.js
+%%TASKSTEP%%/script/mod_tiles.js
+%%TASKSTEP%%/script/mod_time.js
+%%TASKSTEP%%/script/mod_tips.js
+%%TASKSTEP%%/script/xc2_control.js
+%%TASKSTEP%%/script/xc2_inpage.js
+%%TASKSTEP%%/script/xc2_template.html
+%%TASKSTEP%%/script/xc2_window.js
+%%TASKSTEP%%/sessioncheck.php
+%%TASKSTEP%%/settings.php
+%%TASKSTEP%%/sidebar.php
+%%TASKSTEP%%/style.css
+%%TASKSTEP%%/styles/Styles and themes system.txt
+%%TASKSTEP%%/styles/images/Thumbs.db
+%%TASKSTEP%%/styles/images/accept.png
+%%TASKSTEP%%/styles/images/add.png
+%%TASKSTEP%%/styles/images/bin.png
+%%TASKSTEP%%/styles/images/bin_empty.png
+%%TASKSTEP%%/styles/images/calendar.png
+%%TASKSTEP%%/styles/images/cart.png
+%%TASKSTEP%%/styles/images/cog_edit.png
+%%TASKSTEP%%/styles/images/exclamation.png
+%%TASKSTEP%%/styles/images/flag_red.png
+%%TASKSTEP%%/styles/images/flag_yellow.png
+%%TASKSTEP%%/styles/images/folder.png
+%%TASKSTEP%%/styles/images/folder_edit.png
+%%TASKSTEP%%/styles/images/help.png
+%%TASKSTEP%%/styles/images/icon.png
+%%TASKSTEP%%/styles/images/information.png
+%%TASKSTEP%%/styles/images/lightbulb.png
+%%TASKSTEP%%/styles/images/lightning.png
+%%TASKSTEP%%/styles/images/mcfc/Thumbs.db
+%%TASKSTEP%%/styles/images/mcfc/crest_faded.jpg
+%%TASKSTEP%%/styles/images/modern/Thumbs.db
+%%TASKSTEP%%/styles/images/modern/currentback.png
+%%TASKSTEP%%/styles/images/modern/infoback.png
+%%TASKSTEP%%/styles/images/modern/logo.png
+%%TASKSTEP%%/styles/images/modern/navbarback.png
+%%TASKSTEP%%/styles/images/modern/oldback.png
+%%TASKSTEP%%/styles/images/modern/sort_back.png
+%%TASKSTEP%%/styles/images/modern/splash.jpg
+%%TASKSTEP%%/styles/images/modern/trans_back.png
+%%TASKSTEP%%/styles/images/newspaper.png
+%%TASKSTEP%%/styles/images/note_go.png
+%%TASKSTEP%%/styles/images/page.png
+%%TASKSTEP%%/styles/images/pencil.png
+%%TASKSTEP%%/styles/images/pencil_go.png
+%%TASKSTEP%%/styles/images/printer.png
+%%TASKSTEP%%/styles/images/pro/Thumbs.db
+%%TASKSTEP%%/styles/images/pro/headerback.jpg
+%%TASKSTEP%%/styles/images/pro/user_gray.png
+%%TASKSTEP%%/styles/images/table.png
+%%TASKSTEP%%/styles/images/table_edit.png
+%%TASKSTEP%%/styles/images/textfield_rename.png
+%%TASKSTEP%%/styles/images/undone.png
+%%TASKSTEP%%/styles/images/user.png
+%%TASKSTEP%%/styles/images/world.png
+%%TASKSTEP%%/styles/mcfc.css
+%%TASKSTEP%%/styles/modern.css
+%%TASKSTEP%%/styles/professional.css
+%%TASKSTEP%%/tips.txt
+%%TASKSTEP%%/today.php
+@dirrm %%TASKSTEP%%/styles/images/pro
+@dirrm %%TASKSTEP%%/styles/images/modern
+@dirrm %%TASKSTEP%%/styles/images/mcfc
+@dirrm %%TASKSTEP%%/styles/images
+@dirrm %%TASKSTEP%%/styles
+@dirrm %%TASKSTEP%%/script
+@dirrm %%TASKSTEP%%/install
+@dirrm %%TASKSTEP%%/images
+@dirrm %%TASKSTEP%%/css
+@dirrm %%TASKSTEP%%/config
+@dirrm %%TASKSTEP%%