aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-07-08 19:29:29 +0800
committeredwin <edwin@FreeBSD.org>2004-07-08 19:29:29 +0800
commitb75d53957ab219d97dcab2cf79c4557670315280 (patch)
tree76db8ee402716fed53b5df2adc515a7236a9e831
parent51416b2ad075032c326215f31cecc1075c03681a (diff)
downloadfreebsd-ports-gnome-b75d53957ab219d97dcab2cf79c4557670315280.tar.gz
freebsd-ports-gnome-b75d53957ab219d97dcab2cf79c4557670315280.tar.zst
freebsd-ports-gnome-b75d53957ab219d97dcab2cf79c4557670315280.zip
Upgrade to version 1.8
- Better handling of timeout (instead of a static value, start with five seconds and double it each retry) - Warnings are printed if you receive a different RR type than the one you asked for (for example when you ask for an A record and receive a CNAME) - Fixed problems when records received in the authority field are shorter than the domain the nameserver is authoritative for. - When compiled without IPv6 support on an IPv6 capable machine the machine tried to query the IPv6 translated IPv5 address anyway. - -C caches hosts which haven't answered too.
-rw-r--r--dns/dnstracer/Makefile3
-rw-r--r--dns/dnstracer/distinfo4
-rw-r--r--dns/dnstracer/files/patch-dnstracer.c11
3 files changed, 3 insertions, 15 deletions
diff --git a/dns/dnstracer/Makefile b/dns/dnstracer/Makefile
index a78462c4706f..04dd920b645d 100644
--- a/dns/dnstracer/Makefile
+++ b/dns/dnstracer/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= dnstracer
-PORTVERSION= 1.7
-PORTREVISION= 1
+PORTVERSION= 1.8
CATEGORIES= dns
MASTER_SITES= http://www.mavetju.org/download/
diff --git a/dns/dnstracer/distinfo b/dns/dnstracer/distinfo
index c42a9648c37e..e603f871d4e7 100644
--- a/dns/dnstracer/distinfo
+++ b/dns/dnstracer/distinfo
@@ -1,2 +1,2 @@
-MD5 (dnstracer-1.7.tar.gz) = fa965fdc0fc8f3e05a1d2877a548f564
-SIZE (dnstracer-1.7.tar.gz) = 94125
+MD5 (dnstracer-1.8.tar.gz) = f779daf30d3bc7824a4daa1c325310cc
+SIZE (dnstracer-1.8.tar.gz) = 130198
diff --git a/dns/dnstracer/files/patch-dnstracer.c b/dns/dnstracer/files/patch-dnstracer.c
deleted file mode 100644
index 7262031e6546..000000000000
--- a/dns/dnstracer/files/patch-dnstracer.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- dnstracer.c.orig Sun Jan 25 11:23:52 2004
-+++ dnstracer.c Sun Jan 25 11:24:01 2004
-@@ -729,7 +729,7 @@
- hints.ai_family = PF_INET;
- hints.ai_socktype = SOCK_DGRAM;
- error = getaddrinfo(global_source_address, 0, &hints, &src_res);
-- if (error == EAI_NODATA) {
-+ if (error == EAI_NONAME) {
- hints.ai_flags = 0;
- error = getaddrinfo(global_source_address, 0, &hints, &src_res);
- }