aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-01-31 21:34:42 +0800
committermarino <marino@FreeBSD.org>2016-01-31 21:34:42 +0800
commitb85f0d67a7ee67bcdc08c8ca007d4fd831708db1 (patch)
tree1042f1a487ae0a36b13e29b724040d3c3e78fb98
parent05926e35b58cb3194c9b45c0243a9d2f352f162e (diff)
downloadfreebsd-ports-gnome-b85f0d67a7ee67bcdc08c8ca007d4fd831708db1.tar.gz
freebsd-ports-gnome-b85f0d67a7ee67bcdc08c8ca007d4fd831708db1.tar.zst
freebsd-ports-gnome-b85f0d67a7ee67bcdc08c8ca007d4fd831708db1.zip
editors/gate: USES+= ncurses, respect LDFLAGS
while here, link with ncurses, not termcap or curses
-rw-r--r--editors/gate/Makefile1
-rw-r--r--editors/gate/files/patch-Makefile.in11
-rw-r--r--editors/gate/files/patch-configure11
3 files changed, 23 insertions, 0 deletions
diff --git a/editors/gate/Makefile b/editors/gate/Makefile
index b7c9e6751f95..4834d08b6ee8 100644
--- a/editors/gate/Makefile
+++ b/editors/gate/Makefile
@@ -13,6 +13,7 @@ COMMENT= Simple and unobtrusive line-oriented text editor
BUILD_DEPENDS= aspell:${PORTSDIR}/textproc/aspell
RUN_DEPENDS= aspell:${PORTSDIR}/textproc/aspell
+USES= ncurses
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-aspell=${LOCALBASE}/bin/aspell
diff --git a/editors/gate/files/patch-Makefile.in b/editors/gate/files/patch-Makefile.in
new file mode 100644
index 000000000000..215976d53d47
--- /dev/null
+++ b/editors/gate/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2003-06-19 16:47:56 UTC
++++ Makefile.in
+@@ -25,7 +25,7 @@ DIST= README $(SRCS) gate.h config.h.in
+ Makefile.in gate.1.C gate.help CHANGES
+
+ gate: $(OBJS)
+- $(CC) -o gate $(CFLAGS) $(OBJS) $(LIBS)
++ $(CC) -o gate $(CFLAGS) $(OBJS) $(LDFLAGS) $(LIBS)
+
+ main.o: main.c gate.h config.h
+ util.o: util.c gate.h config.h
diff --git a/editors/gate/files/patch-configure b/editors/gate/files/patch-configure
new file mode 100644
index 000000000000..579cf63aaf5b
--- /dev/null
+++ b/editors/gate/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2005-01-24 06:35:15 UTC
++++ configure
+@@ -1766,7 +1766,7 @@ else
+ cat conftest.$ac_ext >&5
+ fi
+ rm -f conftest*
+-test "$ac_cv_search_tgetent" = "no" && for i in termcap curses; do
++test "$ac_cv_search_tgetent" = "no" && for i in ncurses; do
+ LIBS="-l$i $ac_func_search_save_LIBS"
+ cat > conftest.$ac_ext <<EOF
+ #line 1773 "configure"