aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-05-10 23:11:16 +0800
committertijl <tijl@FreeBSD.org>2014-05-10 23:11:16 +0800
commitb893623f2ac1a96c7635729138f207b20080e234 (patch)
treee76c857e1d071f1df2f3893ab4932648d53d85dd
parent8a180503902ce95fc1f9272022f061b8f39c2667 (diff)
downloadfreebsd-ports-gnome-b893623f2ac1a96c7635729138f207b20080e234.tar.gz
freebsd-ports-gnome-b893623f2ac1a96c7635729138f207b20080e234.tar.zst
freebsd-ports-gnome-b893623f2ac1a96c7635729138f207b20080e234.zip
- USES=libtool:keepla tar:bzip2.
- Remove a clang hack.
-rw-r--r--x11-wm/xfce4-panel/Makefile15
-rw-r--r--x11-wm/xfce4-panel/pkg-plist1
2 files changed, 6 insertions, 10 deletions
diff --git a/x11-wm/xfce4-panel/Makefile b/x11-wm/xfce4-panel/Makefile
index beafcfa64273..ea0dc3d2022f 100644
--- a/x11-wm/xfce4-panel/Makefile
+++ b/x11-wm/xfce4-panel/Makefile
@@ -3,6 +3,7 @@
PORTNAME= xfce4-panel
PORTVERSION= 4.10.1
+PORTREVISION= 1
CATEGORIES= x11-wm xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR= src/xfce/${PORTNAME}/${PORTVERSION:R}
@@ -15,10 +16,10 @@ LIB_DEPENDS= libwnck-1.so:${PORTSDIR}/x11-toolkits/libwnck \
libcairo.so:${PORTSDIR}/graphics/cairo \
libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib
-USES= desktop-file-utils gmake pathfix perl5 pkgconfig compiler
+USES= desktop-file-utils gmake libtool:keepla pathfix perl5 \
+ pkgconfig tar:bzip2
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
-USE_BZIP2= yes
USE_GNOME= glib20 gtk20 intltool intlhack
USE_LDCONFIG= yes
USE_XFCE= configenv garcon libexo libmenu libutil xfconf
@@ -28,13 +29,7 @@ CONFIGURE_ARGS+=--enable-gio-unix
OPTIONS_DEFINE= NLS DOCS
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 1000000
-.if ${COMPILER_TYPE} == clang
-CFLAGS_amd64= -fPIC
-.endif
-.endif
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
USES+= gettext
@@ -53,4 +48,4 @@ CONFIGURE_ARGS+=--without-html-dir
PLIST_SUB+= APIDOCS="@comment "
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-wm/xfce4-panel/pkg-plist b/x11-wm/xfce4-panel/pkg-plist
index 19c01661c1a1..bfff45dfbd29 100644
--- a/x11-wm/xfce4-panel/pkg-plist
+++ b/x11-wm/xfce4-panel/pkg-plist
@@ -18,6 +18,7 @@ include/xfce4/libxfce4panel-1.0/libxfce4panel/xfce-panel-plugin.h
lib/libxfce4panel-1.0.la
lib/libxfce4panel-1.0.so
lib/libxfce4panel-1.0.so.4
+lib/libxfce4panel-1.0.so.4.0.0
lib/xfce4/panel/migrate
lib/xfce4/panel/plugins/libactions.la
lib/xfce4/panel/plugins/libactions.so