aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2015-11-27 11:50:59 +0800
committervanilla <vanilla@FreeBSD.org>2015-11-27 11:50:59 +0800
commitb9f66ae218d5ab94cb9359a1e3e0d090a057c696 (patch)
tree0139a7991bbfe6a7dacea293534b32f38088d41e
parent1a81f7843a44cc90d64616502e1da2f428698426 (diff)
downloadfreebsd-ports-gnome-b9f66ae218d5ab94cb9359a1e3e0d090a057c696.tar.gz
freebsd-ports-gnome-b9f66ae218d5ab94cb9359a1e3e0d090a057c696.tar.zst
freebsd-ports-gnome-b9f66ae218d5ab94cb9359a1e3e0d090a057c696.zip
Add py-django-pipeline14 for py-django16 (copy from py-django-pipiline).
-rw-r--r--www/Makefile1
-rw-r--r--www/py-django-pipeline14/Makefile21
-rw-r--r--www/py-django-pipeline14/distinfo2
-rw-r--r--www/py-django-pipeline14/pkg-descr5
4 files changed, 29 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 4368d636acf5..a7f9227d0f13 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1551,6 +1551,7 @@
SUBDIR += py-django-picklefield
SUBDIR += py-django-pipeline
SUBDIR += py-django-pipeline12
+ SUBDIR += py-django-pipeline14
SUBDIR += py-django-piston
SUBDIR += py-django-profiles
SUBDIR += py-django-redis
diff --git a/www/py-django-pipeline14/Makefile b/www/py-django-pipeline14/Makefile
new file mode 100644
index 000000000000..0517d1cf7af9
--- /dev/null
+++ b/www/py-django-pipeline14/Makefile
@@ -0,0 +1,21 @@
+# Created by: Cheng-Lung Sung <clsung@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= django-pipeline
+PORTVERSION= 1.4.7
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Asset (css/js) packaging library for Django
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django16>0:${PORTSDIR}/www/py-django16
+
+NO_ARCH= yes
+USES= python:2
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/www/py-django-pipeline14/distinfo b/www/py-django-pipeline14/distinfo
new file mode 100644
index 000000000000..eedacb757cf7
--- /dev/null
+++ b/www/py-django-pipeline14/distinfo
@@ -0,0 +1,2 @@
+SHA256 (django-pipeline-1.4.7.tar.gz) = 5626def8d3f58bd2f59deebbbe7efe29c922006a451506e5c07dd5b4a490ffc3
+SIZE (django-pipeline-1.4.7.tar.gz) = 199328
diff --git a/www/py-django-pipeline14/pkg-descr b/www/py-django-pipeline14/pkg-descr
new file mode 100644
index 000000000000..1b0d8d34e54c
--- /dev/null
+++ b/www/py-django-pipeline14/pkg-descr
@@ -0,0 +1,5 @@
+Pipeline is an asset packaging library for Django, providing
+both CSS and JavaScript concatenation and compression, built-in
+JavaScript template support, and optional data-URI image embedding.
+
+WWW: https://github.com/cyberdelia/django-pipeline