aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2014-05-21 09:16:53 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2014-05-21 09:16:53 +0800
commitba0113547beb521f18d9dcafcb22540a8a845b6f (patch)
tree351039e752089519d935497c3d65fe9c638f9aff
parent5375c0a945509931ac9fbc0beeee9bda18951f82 (diff)
downloadfreebsd-ports-gnome-ba0113547beb521f18d9dcafcb22540a8a845b6f.tar.gz
freebsd-ports-gnome-ba0113547beb521f18d9dcafcb22540a8a845b6f.tar.zst
freebsd-ports-gnome-ba0113547beb521f18d9dcafcb22540a8a845b6f.zip
- Stagify
Approved by: portmgr blanket
-rw-r--r--math/suitesparse/Makefile31
-rw-r--r--math/suitesparse/pkg-descr2
2 files changed, 16 insertions, 17 deletions
diff --git a/math/suitesparse/Makefile b/math/suitesparse/Makefile
index d05d07364510..9dbec686c484 100644
--- a/math/suitesparse/Makefile
+++ b/math/suitesparse/Makefile
@@ -17,14 +17,13 @@ LICENSE_COMB= multi
USES= fortran gmake
.if defined (WITH_METIS)
-LIB_DEPENDS= metis.1:${PORTSDIR}/math/metis4
+LIB_DEPENDS= libmetis.so:${PORTSDIR}/math/metis4
RESTRICTED= GPL and METIS licenses are contradictory
.endif
CONFLICTS= umfpack-*
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if exists(${LOCALBASE}/lib/libopenblas.so)
@@ -41,21 +40,21 @@ CFLAGS+= ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib
.if ${WITH_BLAS} == reference
-LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
-LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
+LIB_DEPENDS+= libblas.so:${PORTSDIR}/math/blas
+LIB_DEPENDS+= liblapack.so:${PORTSDIR}/math/lapack
BLAS= -lblas
LAPACK= -llapack
.elif ${WITH_BLAS} == openblas
-LIB_DEPENDS+= openblas:${PORTSDIR}/math/openblas
+LIB_DEPENDS+= libopenblas.so:${PORTSDIR}/math/openblas
BLAS= -lopenblasp
LAPACK= -lopenblasp
.elif ${WITH_BLAS} == gotoblas
-LIB_DEPENDS+= goto2:${PORTSDIR}/math/gotoblas
-LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
+LIB_DEPENDS+= libgoto2.so:${PORTSDIR}/math/gotoblas
+LIB_DEPENDS+= liblapack.so:${PORTSDIR}/math/lapack
BLAS = -lgoto2p
LAPACK = -lgoto2p
.elif ${WITH_BLAS} == atlas
-LIB_DEPENDS+= atlas:${PORTSDIR}/math/atlas
+LIB_DEPENDS+= libatlas.so:${PORTSDIR}/math/atlas
BLAS= -lptf77blas
LAPACK = -lalapack -lptcblas
.endif
@@ -114,18 +113,18 @@ post-build:
done
do-install:
- @${MKDIR} ${PREFIX}/include/suitesparse
- @${LN} -sf ${PREFIX}/include/suitesparse ${PREFIX}/include/ufsparse
+ @${MKDIR} ${STAGEDIR}${PREFIX}/include/suitesparse
+ @${LN} -sf ${PREFIX}/include/suitesparse ${STAGEDIR}${PREFIX}/include/ufsparse
.for d in AMD BTF CAMD CCOLAMD CHOLMOD COLAMD CXSparse KLU SPQR UMFPACK
- @${INSTALL_DATA} ${WRKSRC}/${d}/Include/*.h ${PREFIX}/include/suitesparse
+ @${INSTALL_DATA} ${WRKSRC}/${d}/Include/*.h ${STAGEDIR}${PREFIX}/include/suitesparse
.endfor
- @${INSTALL_DATA} ${WRKSRC}/SuiteSparse_config/SuiteSparse_config.h ${PREFIX}/include/suitesparse
- @${INSTALL_DATA} ${WRKSRC}/UMFPACK/Source/umf_config.h ${PREFIX}/include/suitesparse
- @${INSTALL_DATA} ${WRKSRC}/SPQR/Include/*.hpp ${PREFIX}/include/suitesparse
+ @${INSTALL_DATA} ${WRKSRC}/SuiteSparse_config/SuiteSparse_config.h ${STAGEDIR}${PREFIX}/include/suitesparse
+ @${INSTALL_DATA} ${WRKSRC}/UMFPACK/Source/umf_config.h ${STAGEDIR}${PREFIX}/include/suitesparse
+ @${INSTALL_DATA} ${WRKSRC}/SPQR/Include/*.hpp ${STAGEDIR}${PREFIX}/include/suitesparse
@for i in `find ${WRKSRC_SHARED} -type f -name '*.a'` ; do \
${INSTALL_DATA} ${WRKSRC}/$${i##${WRKSRC_SHARED}/} \
- $${i%.a}.so.${SVERSION} ${PREFIX}/lib ; \
- j=$${i##*/} ; ${LN} -sf $${j%.a}.so.${SVERSION} ${PREFIX}/lib/$${j%.a}.so ; \
+ $${i%.a}.so.${SVERSION} ${STAGEDIR}${PREFIX}/lib ; \
+ j=$${i##*/} ; ${LN} -sf $${j%.a}.so.${SVERSION} ${STAGEDIR}${PREFIX}/lib/$${j%.a}.so ; \
done
.include <bsd.port.post.mk>
diff --git a/math/suitesparse/pkg-descr b/math/suitesparse/pkg-descr
index 907dfe72b760..8da2b59d32cd 100644
--- a/math/suitesparse/pkg-descr
+++ b/math/suitesparse/pkg-descr
@@ -12,4 +12,4 @@ It contains:
* CSparse: a concise sparse matrix package
* CXSparse: and extended version of CSparse
-WWW: http://www.cise.ufl.edu/research/sparse/SuiteSparse/
+WWW: http://www.cise.ufl.edu/research/sparse/SuiteSparse/