aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2004-06-08 17:50:44 +0800
committerijliao <ijliao@FreeBSD.org>2004-06-08 17:50:44 +0800
commitba293949da8be090eafa636018797b8a7404e803 (patch)
treeeed5e054e43d8e248d5d6f79150afdc6394cda40
parente566266c3c61937bdc274f9a8a8e98a3e39c3537 (diff)
downloadfreebsd-ports-gnome-ba293949da8be090eafa636018797b8a7404e803.tar.gz
freebsd-ports-gnome-ba293949da8be090eafa636018797b8a7404e803.tar.zst
freebsd-ports-gnome-ba293949da8be090eafa636018797b8a7404e803.zip
add py-PyX 0.6.3
A Python package for the creation of encapsulated PostScript figures
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py-PyX/Makefile34
-rw-r--r--graphics/py-PyX/distinfo2
-rw-r--r--graphics/py-PyX/pkg-descr17
4 files changed, 54 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index ec672e360164..e13804bb6a86 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -333,6 +333,7 @@
SUBDIR += pstoedit
SUBDIR += pstoepsi
SUBDIR += pvmpov
+ SUBDIR += py-PyX
SUBDIR += py-cgkit
SUBDIR += py-chart
SUBDIR += py-exif
diff --git a/graphics/py-PyX/Makefile b/graphics/py-PyX/Makefile
new file mode 100644
index 000000000000..43595db05593
--- /dev/null
+++ b/graphics/py-PyX/Makefile
@@ -0,0 +1,34 @@
+# ex:ts=8
+# Ports collection makefile for: PyX
+# Date created: Jun 8, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= PyX
+PORTVERSION= 0.6.3
+CATEGORIES= graphics python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A Python package for the creation of encapsulated PostScript figures
+
+BUILD_DEPENDS= kpsewhich:${PORTSDIR}/print/teTeX
+
+USE_PYTHON= 2.0+
+USE_PYDISTUTILS= yes
+
+post-install:
+ @${FIND} ${PYTHON_SITELIBDIR}/pyx ! -type d | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${PYTHON_SITELIBDIR}/pyx -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/share/pyx ! -type d | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/share/pyx -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/graphics/py-PyX/distinfo b/graphics/py-PyX/distinfo
new file mode 100644
index 000000000000..cc0da87039a9
--- /dev/null
+++ b/graphics/py-PyX/distinfo
@@ -0,0 +1,2 @@
+MD5 (PyX-0.6.3.tar.gz) = ff3427b4deb265c448da8aec8cbd7e77
+SIZE (PyX-0.6.3.tar.gz) = 1323242
diff --git a/graphics/py-PyX/pkg-descr b/graphics/py-PyX/pkg-descr
new file mode 100644
index 000000000000..ed0d80b6f720
--- /dev/null
+++ b/graphics/py-PyX/pkg-descr
@@ -0,0 +1,17 @@
+PyX is a Python package for the creation of encapsulated PostScript figures.
+It provides both an abstraction of PostScript and a TeX/LaTeX interface.
+Complex tasks like 2d and 3d plots in publication-ready quality are built out
+of these primitives.
+
+Features
+ * PostScript output for device independent, free scalable figures
+ * seamless TeX/LaTeX integration
+ * full access to PostScript features like paths, linestyles, fill patterns,
+ transformations, clipping, etc.
+ * advanced geometric operations on paths like intersections, transformations,
+ splitting, etc.
+ * sophisticated graph generation: modular design, pluggable axes, axes
+ partitioning based on rational number arithmetics, flexible graph styles,
+ etc.
+
+WWW: http://pyx.sourceforge.net/