aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2012-08-25 14:08:48 +0800
committerjgh <jgh@FreeBSD.org>2012-08-25 14:08:48 +0800
commitbaa20fed1ca1bb962b4dba163e846a504fcb7a5d (patch)
tree807d2e2412893d0e7d9dee069ea0bf1a853b2b5e
parent904d6dfbf639eb6b0d8d1677b4c4ca700775707e (diff)
downloadfreebsd-ports-gnome-baa20fed1ca1bb962b4dba163e846a504fcb7a5d.tar.gz
freebsd-ports-gnome-baa20fed1ca1bb962b4dba163e846a504fcb7a5d.tar.zst
freebsd-ports-gnome-baa20fed1ca1bb962b4dba163e846a504fcb7a5d.zip
- update to optionsNG for DOCS
PR: 170749 Submitted by: nemysis@gmx.ch
-rw-r--r--graphics/founts/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/graphics/founts/Makefile b/graphics/founts/Makefile
index 8874e9456e85..85d49869969e 100644
--- a/graphics/founts/Makefile
+++ b/graphics/founts/Makefile
@@ -18,10 +18,12 @@ LICENSE= GPLv2
USE_SDL= sdl
-PLIST_FILES= bin/founts
+PLIST_FILES= bin/${PORTNAME}
PORTDOCS= Changelog README
+.include <bsd.port.options.mk>
+
do-build:
cd ${WRKSRC} && ${CC} -o ${PORTNAME} ${CFLAGS} \
-lm `${SDL_CONFIG} --cflags --libs` founts.c
@@ -29,8 +31,9 @@ do-build:
do-install:
# Executable
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
# Documentation
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
. for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}