aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgj <gj@FreeBSD.org>2002-08-27 17:18:36 +0800
committergj <gj@FreeBSD.org>2002-08-27 17:18:36 +0800
commitbad38c8c34490b402ca24c53bd2990aa9e7289b9 (patch)
tree65ddc374d56c8264997d2491457cb5704a240d76
parent6bb9078e8132724853c3d57183a2b25532b4afe6 (diff)
downloadfreebsd-ports-gnome-bad38c8c34490b402ca24c53bd2990aa9e7289b9.tar.gz
freebsd-ports-gnome-bad38c8c34490b402ca24c53bd2990aa9e7289b9.tar.zst
freebsd-ports-gnome-bad38c8c34490b402ca24c53bd2990aa9e7289b9.zip
Add patch-file.c to fix an error in checking the return value from
mkdtemp. Bump PORTREVISION to reflect the fix.
-rw-r--r--editors/vile/Makefile1
-rw-r--r--editors/vile/files/patch-file.c11
-rw-r--r--editors/xvile/Makefile1
-rw-r--r--editors/xvile/files/patch-file.c11
4 files changed, 24 insertions, 0 deletions
diff --git a/editors/vile/Makefile b/editors/vile/Makefile
index f9478ff2ac0c..176fa87e7aff 100644
--- a/editors/vile/Makefile
+++ b/editors/vile/Makefile
@@ -7,6 +7,7 @@
PORTNAME= vile
PORTVERSION= 9.3c
+PORTREVISION= 1
CATEGORIES= editors
MASTER_SITES= ftp://ftp.phred.org/pub/vile/ \
ftp://dickey.his.com/vile/
diff --git a/editors/vile/files/patch-file.c b/editors/vile/files/patch-file.c
new file mode 100644
index 000000000000..ba624d2b6137
--- /dev/null
+++ b/editors/vile/files/patch-file.c
@@ -0,0 +1,11 @@
+--- file.c.orig Tue Aug 27 10:14:57 2002
++++ file.c Tue Aug 27 10:15:35 2002
+@@ -2351,7 +2351,7 @@
+
+ /* on failure, keep going */
+ #if defined(HAVE_MKSTEMP) && defined(HAVE_MKDTEMP)
+- result = (vl_mkdtemp(dirnam) == 0);
++ result = (vl_mkdtemp(dirnam) != 0);
+ #else
+ result = (vl_mkdir(dirnam, 0700) == 0);
+ #endif
diff --git a/editors/xvile/Makefile b/editors/xvile/Makefile
index 7f7ba614c0b8..d8357c6dcb1b 100644
--- a/editors/xvile/Makefile
+++ b/editors/xvile/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xvile
PORTVERSION= 9.3c
+PORTREVISION= 1
CATEGORIES= editors
MASTER_SITES= ftp://ftp.phred.org/pub/vile/ \
ftp://dickey.his.com/vile/
diff --git a/editors/xvile/files/patch-file.c b/editors/xvile/files/patch-file.c
new file mode 100644
index 000000000000..ba624d2b6137
--- /dev/null
+++ b/editors/xvile/files/patch-file.c
@@ -0,0 +1,11 @@
+--- file.c.orig Tue Aug 27 10:14:57 2002
++++ file.c Tue Aug 27 10:15:35 2002
+@@ -2351,7 +2351,7 @@
+
+ /* on failure, keep going */
+ #if defined(HAVE_MKSTEMP) && defined(HAVE_MKDTEMP)
+- result = (vl_mkdtemp(dirnam) == 0);
++ result = (vl_mkdtemp(dirnam) != 0);
+ #else
+ result = (vl_mkdir(dirnam, 0700) == 0);
+ #endif