aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2018-02-08 03:06:39 +0800
committerpi <pi@FreeBSD.org>2018-02-08 03:06:39 +0800
commitbc71cab5649a663037ab55a2db6b4fc7b696f640 (patch)
tree10ce9d3e9e5ceb28cf2a85a84c714bd2310e63ef
parentc1bbc9cee2ca7c88b9e1a11f010d426a61cfb92f (diff)
downloadfreebsd-ports-gnome-bc71cab5649a663037ab55a2db6b4fc7b696f640.tar.gz
freebsd-ports-gnome-bc71cab5649a663037ab55a2db6b4fc7b696f640.tar.zst
freebsd-ports-gnome-bc71cab5649a663037ab55a2db6b4fc7b696f640.zip
net/avahi-app: fix rc scripts for a working 'service avahi-daemon status'
PR: 206325 Submitted by: Yuichiro NAITO <naito.yuichiro@gmail.com> Reviewed by: w.schwarzenfeld@utanet.at
-rw-r--r--net/avahi-app/Makefile2
-rw-r--r--net/avahi-app/files/patch-initscript_freebsd_avahi-daemon.sh.in13
-rw-r--r--net/avahi-app/files/patch-initscript_freebsd_avahi-dnsconfd.sh.in13
3 files changed, 21 insertions, 7 deletions
diff --git a/net/avahi-app/Makefile b/net/avahi-app/Makefile
index 04153d877df8..fc023467c629 100644
--- a/net/avahi-app/Makefile
+++ b/net/avahi-app/Makefile
@@ -3,7 +3,7 @@
PORTNAME= avahi
PORTVERSION= 0.6.31
-PORTREVISION?= 5
+PORTREVISION?= 6
CATEGORIES?= net dns
MASTER_SITES= http://www.avahi.org/download/
PKGNAMESUFFIX?= -app
diff --git a/net/avahi-app/files/patch-initscript_freebsd_avahi-daemon.sh.in b/net/avahi-app/files/patch-initscript_freebsd_avahi-daemon.sh.in
index acf93597a63b..91b122f91df6 100644
--- a/net/avahi-app/files/patch-initscript_freebsd_avahi-daemon.sh.in
+++ b/net/avahi-app/files/patch-initscript_freebsd_avahi-daemon.sh.in
@@ -1,6 +1,6 @@
---- initscript/freebsd/avahi-daemon.sh.in.orig 2010-08-26 00:51:39 UTC
-+++ initscript/freebsd/avahi-daemon.sh.in
-@@ -9,13 +9,15 @@
+--- initscript/freebsd/avahi-daemon.sh.in.orig 2010-08-26 09:51:39.036153000 +0900
++++ initscript/freebsd/avahi-daemon.sh.in 2016-01-17 11:59:38.578756000 +0900
+@@ -9,18 +9,22 @@
# Avahi's mDNSResponder, a Zeroconf (Bonjour) service advertisement daemon.
#
@@ -18,3 +18,10 @@
start_cmd=avahi_daemon_start
stop_cmd=avahi_daemon_stop
+
+ avahi_daemon_bin=@sbindir@/avahi-daemon
++command=${avahi_daemon_bin}
++pidfile="/var/run/avahi-daemon/pid"
+
+ avahi_daemon_start() {
+ checkyesno avahi_daemon_enable && echo "Starting avahi-daemon." && \
diff --git a/net/avahi-app/files/patch-initscript_freebsd_avahi-dnsconfd.sh.in b/net/avahi-app/files/patch-initscript_freebsd_avahi-dnsconfd.sh.in
index 7c10b14fd7dd..03bcfe9f210c 100644
--- a/net/avahi-app/files/patch-initscript_freebsd_avahi-dnsconfd.sh.in
+++ b/net/avahi-app/files/patch-initscript_freebsd_avahi-dnsconfd.sh.in
@@ -1,6 +1,6 @@
---- initscript/freebsd/avahi-dnsconfd.sh.in.orig 2010-08-26 00:51:39 UTC
-+++ initscript/freebsd/avahi-dnsconfd.sh.in
-@@ -12,13 +12,15 @@
+--- initscript/freebsd/avahi-dnsconfd.sh.in.orig 2010-08-26 09:51:39.037153000 +0900
++++ initscript/freebsd/avahi-dnsconfd.sh.in 2016-01-17 11:59:50.394307000 +0900
+@@ -12,18 +12,22 @@
# DNS servers in a DHCP-like fashion with mDNS.
#
@@ -18,3 +18,10 @@
start_cmd=avahi_dnsconfd_start
stop_cmd=avahi_dnsconfd_stop
+
+ avahi_dnsconfd_bin=@sbindir@/avahi-dnsconfd
++command=${avahi_dnsconfd_bin}
++pidfile="/var/run/avahi-dnsconfd.pid"
+
+ avahi_dnsconfd_start() {
+ checkyesno avahi_dnsconfd_enable && echo "Starting avahi-dnsconfd." && \