aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorshaun <shaun@FreeBSD.org>2006-06-27 02:15:19 +0800
committershaun <shaun@FreeBSD.org>2006-06-27 02:15:19 +0800
commitbd3c8a3ce4c28bb9cfeabcb3f16781b8021058f4 (patch)
tree4f0692df43801a72c923b3c856de1f4cab74ffef
parentf120a60c70c4841907f33e15a44e3a20879c804f (diff)
downloadfreebsd-ports-gnome-bd3c8a3ce4c28bb9cfeabcb3f16781b8021058f4.tar.gz
freebsd-ports-gnome-bd3c8a3ce4c28bb9cfeabcb3f16781b8021058f4.tar.zst
freebsd-ports-gnome-bd3c8a3ce4c28bb9cfeabcb3f16781b8021058f4.zip
Upgrade to 0.27
PR: ports/99092 Submitted by: Arseny Nasokin <tarc@tarc.po.cs.msu.su> Approved by: Lapo Luchini <lapo@lapo.it> (maintainer), ahze (mentor)
-rw-r--r--devel/monotone/Makefile9
-rw-r--r--devel/monotone/distinfo6
-rw-r--r--devel/monotone/files/patch-Makefile.in19
3 files changed, 24 insertions, 10 deletions
diff --git a/devel/monotone/Makefile b/devel/monotone/Makefile
index 964fd84e954c..f9fd25bc6e5b 100644
--- a/devel/monotone/Makefile
+++ b/devel/monotone/Makefile
@@ -6,15 +6,13 @@
#
PORTNAME= monotone
-PORTVERSION= 0.26
+PORTVERSION= 0.27
CATEGORIES= devel
MASTER_SITES= http://www.venge.net/monotone/downloads/
MAINTAINER= lapo@lapo.it
COMMENT= A distributed version control system with digital signatures
-LIB_DEPENDS= boost_regex.3:${PORTSDIR}/devel/boost
-
SUB_FILES= pkg-message
USE_GCC= 3.4+
USE_PERL5_BUILD=yes
@@ -22,6 +20,7 @@ USE_ICONV= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --infodir=${PREFIX}/${INFO_PATH} --mandir=${PREFIX}/man
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
MAKEINFO="makeinfo --no-split"
@@ -34,7 +33,9 @@ PORTDOCS= NEWS UPGRADE monotone.html
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
-BROKEN= wcswidth() not present in libc on FreeBSD < 5.0
+LIB_DEPENDS= boost_regex.3:${PORTSDIR}/devel/boost-gcc3
+.else
+LIB_DEPENDS= boost_regex.3:${PORTSDIR}/devel/boost
.endif
.if defined(WITHOUT_NLS)
diff --git a/devel/monotone/distinfo b/devel/monotone/distinfo
index f367a2dcb03b..3e1649890be3 100644
--- a/devel/monotone/distinfo
+++ b/devel/monotone/distinfo
@@ -1,3 +1,3 @@
-MD5 (monotone-0.26.tar.gz) = 21b902d1b48ffb868536d04c4ad38155
-SHA256 (monotone-0.26.tar.gz) = 4ced85ad82f7f74bc75f08d93009fa2f25b7516f11e78ece1f775a3db433054a
-SIZE (monotone-0.26.tar.gz) = 5630955
+MD5 (monotone-0.27.tar.gz) = cf3d8f26b7570d0d65834c3949913e2d
+SHA256 (monotone-0.27.tar.gz) = 0a817e08b06141d78f2b8b0073aafd7110147679efb49c3e88c96a486532cacd
+SIZE (monotone-0.27.tar.gz) = 6084853
diff --git a/devel/monotone/files/patch-Makefile.in b/devel/monotone/files/patch-Makefile.in
index 4a99f0008fb6..1ee1184d46fa 100644
--- a/devel/monotone/files/patch-Makefile.in
+++ b/devel/monotone/files/patch-Makefile.in
@@ -1,11 +1,15 @@
---- Makefile.in.orig Sun Apr 9 04:46:33 2006
-+++ Makefile.in Tue Apr 11 15:12:05 2006
-@@ -1824,10 +1824,10 @@
+--- Makefile.in.orig Sat Jun 17 22:50:36 2006
++++ Makefile.in Sun Jun 25 23:30:15 2006
+@@ -1909,13 +1909,13 @@
-test -z "$(noinst_PROGRAMS)" || rm -f $(noinst_PROGRAMS)
mtn$(EXEEXT): $(mtn_OBJECTS) $(mtn_DEPENDENCIES)
@rm -f mtn$(EXEEXT)
- $(CXXLINK) $(mtn_LDFLAGS) $(mtn_OBJECTS) $(mtn_LDADD) $(LIBS)
+ $(CXXLINK) $(mtn_LDFLAGS) $(mtn_OBJECTS) $(mtn_LDADD) $(LIBS) $(LIBINTL) $(LIBICONV)
+ tester$(EXEEXT): $(tester_OBJECTS) $(tester_DEPENDENCIES)
+ @rm -f tester$(EXEEXT)
+- $(CXXLINK) $(tester_LDFLAGS) $(tester_OBJECTS) $(tester_LDADD) $(LIBS)
++ $(CXXLINK) $(tester_LDFLAGS) $(tester_OBJECTS) $(tester_LDADD) $(LIBS) $(LIBINTL) $(LIBICONV)
unit_tests$(EXEEXT): $(unit_tests_OBJECTS) $(unit_tests_DEPENDENCIES)
@rm -f unit_tests$(EXEEXT)
- $(CXXLINK) $(unit_tests_LDFLAGS) $(unit_tests_OBJECTS) $(unit_tests_LDADD) $(LIBS)
@@ -13,3 +17,12 @@
contrib/$(am__dirstamp):
@$(mkdir_p) contrib
@: > contrib/$(am__dirstamp)
+@@ -1926,7 +1926,7 @@
+ contrib/$(DEPDIR)/$(am__dirstamp)
+ usher$(EXEEXT): $(usher_OBJECTS) $(usher_DEPENDENCIES)
+ @rm -f usher$(EXEEXT)
+- $(CXXLINK) $(usher_LDFLAGS) $(usher_OBJECTS) $(usher_LDADD) $(LIBS)
++ $(CXXLINK) $(usher_LDFLAGS) $(usher_OBJECTS) $(usher_LDADD) $(LIBS) $(LIBINTL) $(LIBICONV)
+
+ mostlyclean-compile:
+ -rm -f *.$(OBJEXT)