aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordd <dd@FreeBSD.org>2005-02-11 16:25:11 +0800
committerdd <dd@FreeBSD.org>2005-02-11 16:25:11 +0800
commitbd88a9c16618501383bbe747b5747d3955c9dc4a (patch)
treedd8363b11a9b4e1f56de7d158d8145a496334182
parent3cd9bb323bafee6f187a634172c20f0b67b26312 (diff)
downloadfreebsd-ports-gnome-bd88a9c16618501383bbe747b5747d3955c9dc4a.tar.gz
freebsd-ports-gnome-bd88a9c16618501383bbe747b5747d3955c9dc4a.tar.zst
freebsd-ports-gnome-bd88a9c16618501383bbe747b5747d3955c9dc4a.zip
Add ses, the Simple Emacs Spreadsheet
-rw-r--r--math/Makefile1
-rw-r--r--math/ses/Makefile50
-rw-r--r--math/ses/distinfo2
-rw-r--r--math/ses/pkg-descr20
4 files changed, 73 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index bf1e4d419f9c..75f54ecf572b 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -227,6 +227,7 @@
SUBDIR += scilab
SUBDIR += sdpa
SUBDIR += sdpara
+ SUBDIR += ses
SUBDIR += slsc
SUBDIR += snns
SUBDIR += solitaire
diff --git a/math/ses/Makefile b/math/ses/Makefile
new file mode 100644
index 000000000000..e6f99e4ec08b
--- /dev/null
+++ b/math/ses/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: ses
+# Date created: 11 February 2005
+# Whom: dd
+#
+# $FreeBSD$
+#
+
+PORTNAME= ses
+PORTVERSION= 031130
+CATEGORIES= math elisp
+MASTER_SITES= http://home.comcast.net/~jyavner/ses/
+DISTNAME= ses21-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= dd@FreeBSD.org
+COMMENT= Simple Emacs Spreadsheet
+
+BUILD_DEPENDS= emacs:${PORTSDIR}/editors/emacs
+RUN_DEPENDS= emacs:${PORTSDIR}/editors/emacs
+
+DOC_FILES= ses-example.ses ses-readme.txt \
+ ses-coverage.el testcover.el unsafep-coverage.el
+DOC_DIR= share/doc/ses
+ELISP_FILES= ses.el unsafep.el
+ELISP_DIR= share/emacs/site-lisp/ses
+
+PLIST_FILES= ${ELISP_FILES:S/^/${ELISP_DIR}\//} \
+ ${ELISP_FILES:S/^/${ELISP_DIR}\//S/$/c/} \
+ ${DOC_FILES:S/^/${DOC_DIR}\//}
+PLIST_DIRS= ${ELISP_DIR} ${DOC_DIR}
+
+do-build:
+.for __f in ${ELISP_FILES}
+ cd ${WRKSRC} && echo '(setq load-path (cons "." load-path)) \
+ (batch-byte-compile)' | \
+ emacs -batch -q -l /dev/stdin ${__f} 2> /dev/null
+.endfor
+
+do-install:
+ ${MKDIR} ${PREFIX}/${ELISP_DIR}
+.for __f in ${ELISP_FILES}
+ ${INSTALL_DATA} ${WRKSRC}/${__f} ${WRKSRC}/${__f}c \
+ ${PREFIX}/${ELISP_DIR}
+.endfor
+ ${MKDIR} ${PREFIX}/${DOC_DIR}
+.for __f in ${DOC_FILES}
+ ${INSTALL_DATA} ${WRKSRC}/${__f} ${PREFIX}/${DOC_DIR}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/math/ses/distinfo b/math/ses/distinfo
new file mode 100644
index 000000000000..9a8de5b24c00
--- /dev/null
+++ b/math/ses/distinfo
@@ -0,0 +1,2 @@
+MD5 (ses21-031130.tgz) = 6677af3bd7545a001ba4927318752de6
+SIZE (ses21-031130.tgz) = 97010
diff --git a/math/ses/pkg-descr b/math/ses/pkg-descr
new file mode 100644
index 000000000000..d4c92b227cc5
--- /dev/null
+++ b/math/ses/pkg-descr
@@ -0,0 +1,20 @@
+SES - Simple Emacs Spreadsheet
+
+Sales pitch from the readme file:
+
+ * Create and edit simple spreadsheets with a minimum of fuss.
+ * Full undo/redo/autosave.
+ * Immune to viruses in spreadsheet files.
+ * Cell formulas are straight Emacs Lisp.
+ * Printer functions for control of cell appearance.
+ * Intuitive keystroke commands: C-o = insert row, M-o = insert column, etc.
+ * "Spillover" of lengthy cell values into following blank cells.
+ * Header line shows column letters or a selected row.
+ * Completing-read for entering symbols as cell values.
+ * Cut, copy, and paste can transfer formulas and printer functions.
+ * Import and export of tab-separated values or tab-separated formulas.
+ * Plaintext, easily-hacked file format.
+
+Documentation is installed into share/doc/ses
+
+WWW: http://home.comcast.net/~jyavner/ses/