aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2006-09-03 05:03:43 +0800
committermaho <maho@FreeBSD.org>2006-09-03 05:03:43 +0800
commitbd9829af47717cc548bee9cb101c44e92e395597 (patch)
tree8b972f7e5f8698589f2095231d3767fc3111ccfe
parentb2696e40ac992f26bb038131990f1dd16096c2dd (diff)
downloadfreebsd-ports-gnome-bd9829af47717cc548bee9cb101c44e92e395597.tar.gz
freebsd-ports-gnome-bd9829af47717cc548bee9cb101c44e92e395597.tar.zst
freebsd-ports-gnome-bd9829af47717cc548bee9cb101c44e92e395597.zip
Do not hard code some libraries
-rw-r--r--editors/openoffice-3-devel/Makefile4
-rw-r--r--editors/openoffice.org-2-devel/Makefile4
-rw-r--r--editors/openoffice.org-2.0-devel/Makefile4
-rw-r--r--editors/openoffice.org-3-devel/Makefile4
-rw-r--r--editors/openoffice.org-vcltesttool/Makefile4
5 files changed, 10 insertions, 10 deletions
diff --git a/editors/openoffice-3-devel/Makefile b/editors/openoffice-3-devel/Makefile
index 975ac1f0bbe3..3421029d04bf 100644
--- a/editors/openoffice-3-devel/Makefile
+++ b/editors/openoffice-3-devel/Makefile
@@ -146,7 +146,7 @@ ANT_VERSION= 1.6.5
BUILD_DEPENDS+= ant:${PORTSDIR}/devel/apache-ant
.endif
.if !defined(WITH_GPC)
-LIB_DEPENDS= art_lgpl_2:${PORTSDIR}/graphics/libart_lgpl
+LIB_DEPENDS+= art_lgpl_2:${PORTSDIR}/graphics/libart_lgpl
.endif
GNU_CONFIGURE= yes
@@ -166,7 +166,7 @@ CONFIGURE_ARGS+= --with-gnu-cp=${LOCALBASE}/bin/gcp --with-gnu-patch=${LOCALBASE
WITHOUT_MOZILLA= yes
.endif
.if (${GCCVER} == 41)
-LIB_DEPENDS= boost_regex:${PORTSDIR}/devel/boost
+LIB_DEPENDS+= boost_regex:${PORTSDIR}/devel/boost
CONFIGURE_ARGS+= --with-system-boost=yes #i58343#
.endif
.if (${OSVERSION} <= 492000)
diff --git a/editors/openoffice.org-2-devel/Makefile b/editors/openoffice.org-2-devel/Makefile
index 975ac1f0bbe3..3421029d04bf 100644
--- a/editors/openoffice.org-2-devel/Makefile
+++ b/editors/openoffice.org-2-devel/Makefile
@@ -146,7 +146,7 @@ ANT_VERSION= 1.6.5
BUILD_DEPENDS+= ant:${PORTSDIR}/devel/apache-ant
.endif
.if !defined(WITH_GPC)
-LIB_DEPENDS= art_lgpl_2:${PORTSDIR}/graphics/libart_lgpl
+LIB_DEPENDS+= art_lgpl_2:${PORTSDIR}/graphics/libart_lgpl
.endif
GNU_CONFIGURE= yes
@@ -166,7 +166,7 @@ CONFIGURE_ARGS+= --with-gnu-cp=${LOCALBASE}/bin/gcp --with-gnu-patch=${LOCALBASE
WITHOUT_MOZILLA= yes
.endif
.if (${GCCVER} == 41)
-LIB_DEPENDS= boost_regex:${PORTSDIR}/devel/boost
+LIB_DEPENDS+= boost_regex:${PORTSDIR}/devel/boost
CONFIGURE_ARGS+= --with-system-boost=yes #i58343#
.endif
.if (${OSVERSION} <= 492000)
diff --git a/editors/openoffice.org-2.0-devel/Makefile b/editors/openoffice.org-2.0-devel/Makefile
index 975ac1f0bbe3..3421029d04bf 100644
--- a/editors/openoffice.org-2.0-devel/Makefile
+++ b/editors/openoffice.org-2.0-devel/Makefile
@@ -146,7 +146,7 @@ ANT_VERSION= 1.6.5
BUILD_DEPENDS+= ant:${PORTSDIR}/devel/apache-ant
.endif
.if !defined(WITH_GPC)
-LIB_DEPENDS= art_lgpl_2:${PORTSDIR}/graphics/libart_lgpl
+LIB_DEPENDS+= art_lgpl_2:${PORTSDIR}/graphics/libart_lgpl
.endif
GNU_CONFIGURE= yes
@@ -166,7 +166,7 @@ CONFIGURE_ARGS+= --with-gnu-cp=${LOCALBASE}/bin/gcp --with-gnu-patch=${LOCALBASE
WITHOUT_MOZILLA= yes
.endif
.if (${GCCVER} == 41)
-LIB_DEPENDS= boost_regex:${PORTSDIR}/devel/boost
+LIB_DEPENDS+= boost_regex:${PORTSDIR}/devel/boost
CONFIGURE_ARGS+= --with-system-boost=yes #i58343#
.endif
.if (${OSVERSION} <= 492000)
diff --git a/editors/openoffice.org-3-devel/Makefile b/editors/openoffice.org-3-devel/Makefile
index 975ac1f0bbe3..3421029d04bf 100644
--- a/editors/openoffice.org-3-devel/Makefile
+++ b/editors/openoffice.org-3-devel/Makefile
@@ -146,7 +146,7 @@ ANT_VERSION= 1.6.5
BUILD_DEPENDS+= ant:${PORTSDIR}/devel/apache-ant
.endif
.if !defined(WITH_GPC)
-LIB_DEPENDS= art_lgpl_2:${PORTSDIR}/graphics/libart_lgpl
+LIB_DEPENDS+= art_lgpl_2:${PORTSDIR}/graphics/libart_lgpl
.endif
GNU_CONFIGURE= yes
@@ -166,7 +166,7 @@ CONFIGURE_ARGS+= --with-gnu-cp=${LOCALBASE}/bin/gcp --with-gnu-patch=${LOCALBASE
WITHOUT_MOZILLA= yes
.endif
.if (${GCCVER} == 41)
-LIB_DEPENDS= boost_regex:${PORTSDIR}/devel/boost
+LIB_DEPENDS+= boost_regex:${PORTSDIR}/devel/boost
CONFIGURE_ARGS+= --with-system-boost=yes #i58343#
.endif
.if (${OSVERSION} <= 492000)
diff --git a/editors/openoffice.org-vcltesttool/Makefile b/editors/openoffice.org-vcltesttool/Makefile
index 975ac1f0bbe3..3421029d04bf 100644
--- a/editors/openoffice.org-vcltesttool/Makefile
+++ b/editors/openoffice.org-vcltesttool/Makefile
@@ -146,7 +146,7 @@ ANT_VERSION= 1.6.5
BUILD_DEPENDS+= ant:${PORTSDIR}/devel/apache-ant
.endif
.if !defined(WITH_GPC)
-LIB_DEPENDS= art_lgpl_2:${PORTSDIR}/graphics/libart_lgpl
+LIB_DEPENDS+= art_lgpl_2:${PORTSDIR}/graphics/libart_lgpl
.endif
GNU_CONFIGURE= yes
@@ -166,7 +166,7 @@ CONFIGURE_ARGS+= --with-gnu-cp=${LOCALBASE}/bin/gcp --with-gnu-patch=${LOCALBASE
WITHOUT_MOZILLA= yes
.endif
.if (${GCCVER} == 41)
-LIB_DEPENDS= boost_regex:${PORTSDIR}/devel/boost
+LIB_DEPENDS+= boost_regex:${PORTSDIR}/devel/boost
CONFIGURE_ARGS+= --with-system-boost=yes #i58343#
.endif
.if (${OSVERSION} <= 492000)