aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2018-09-11 04:26:47 +0800
committersunpoet <sunpoet@FreeBSD.org>2018-09-11 04:26:47 +0800
commitbdfa443714dec55f78bfec39aa68b12d0cf00890 (patch)
treeb106fc1519c7dbf1ba50c041a134febb07753cb8
parentb3e760a64ec50a91fbeb9ae834578f068c39c489 (diff)
downloadfreebsd-ports-gnome-bdfa443714dec55f78bfec39aa68b12d0cf00890.tar.gz
freebsd-ports-gnome-bdfa443714dec55f78bfec39aa68b12d0cf00890.tar.zst
freebsd-ports-gnome-bdfa443714dec55f78bfec39aa68b12d0cf00890.zip
Update to 0.5.2
Changes: https://github.com/intel/tinycbor/commits/master
-rw-r--r--devel/tinycbor/Makefile3
-rw-r--r--devel/tinycbor/distinfo6
-rw-r--r--devel/tinycbor/files/patch-tools-json2cbor-json2cbor.c10
3 files changed, 14 insertions, 5 deletions
diff --git a/devel/tinycbor/Makefile b/devel/tinycbor/Makefile
index dc5d24ec24d2..169b703cfe0a 100644
--- a/devel/tinycbor/Makefile
+++ b/devel/tinycbor/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= tinycbor
-PORTVERSION= 0.5.1
+PORTVERSION= 0.5.2
DISTVERSIONPREFIX= v
CATEGORIES= devel
@@ -28,7 +28,6 @@ do-configure:
@cd ${WRKSRC}/ && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} configure
post-install:
- ${INSTALL_DATA} ${WRKSRC}/src/tinycbor-version.h ${STAGEDIR}${PREFIX}/include/tinycbor/tinycbor-version.h
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libtinycbor.so.${PORTVERSION}
${LN} -fs libtinycbor.so.${PORTVERSION} ${STAGEDIR}${PREFIX}/lib/libtinycbor.so
${LN} -fs libtinycbor.so.${PORTVERSION} ${STAGEDIR}${PREFIX}/lib/libtinycbor.so.${PORTVERSION:R:R}
diff --git a/devel/tinycbor/distinfo b/devel/tinycbor/distinfo
index c1ad879f9639..fb305906dc9c 100644
--- a/devel/tinycbor/distinfo
+++ b/devel/tinycbor/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1522750653
-SHA256 (intel-tinycbor-v0.5.1_GH0.tar.gz) = f9d2ec366a38382c1b7bb989c45620dca168ad28107b4ef9a306ee93c3dbb832
-SIZE (intel-tinycbor-v0.5.1_GH0.tar.gz) = 86485
+TIMESTAMP = 1536590931
+SHA256 (intel-tinycbor-v0.5.2_GH0.tar.gz) = dfa2a4550eb145a5f62ffff39e36accf2704987922c194e8e845124175c00441
+SIZE (intel-tinycbor-v0.5.2_GH0.tar.gz) = 87775
diff --git a/devel/tinycbor/files/patch-tools-json2cbor-json2cbor.c b/devel/tinycbor/files/patch-tools-json2cbor-json2cbor.c
new file mode 100644
index 000000000000..84ccf2ccb08e
--- /dev/null
+++ b/devel/tinycbor/files/patch-tools-json2cbor-json2cbor.c
@@ -0,0 +1,10 @@
+--- tools/json2cbor/json2cbor.c.orig 2018-09-09 05:33:57 UTC
++++ tools/json2cbor/json2cbor.c
+@@ -25,6 +25,7 @@
+ #define _POSIX_C_SOURCE 200809L
+ #define _GNU_SOURCE
+ #include "cbor.h"
++#include "cborinternal_p.h"
+ #include "compilersupport_p.h"
+
+ #include <cjson/cJSON.h>