aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2019-08-22 22:21:03 +0800
committerlinimon <linimon@FreeBSD.org>2019-08-22 22:21:03 +0800
commitbff15f99ede28c6aa0a7a471f30bc1745e451e52 (patch)
tree1ee2591f57c4af6790d5f5cce714c59cdc2362d0
parentd206d4dc459fa1a93d829aa66ec7c5ec75b5fc05 (diff)
downloadfreebsd-ports-gnome-bff15f99ede28c6aa0a7a471f30bc1745e451e52.tar.gz
freebsd-ports-gnome-bff15f99ede28c6aa0a7a471f30bc1745e451e52.tar.zst
freebsd-ports-gnome-bff15f99ede28c6aa0a7a471f30bc1745e451e52.zip
Mark as not for powerpc*/sparc64:
-- Check if the system is big endian - big endian CMake Error at CMakeLists.txt:24 (message): solidity currently does not support big endian systems. Approved by: portmgr (tier-2 blanket)
-rw-r--r--lang/solidity/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/lang/solidity/Makefile b/lang/solidity/Makefile
index 9a88c6266643..b5f4d0b3b902 100644
--- a/lang/solidity/Makefile
+++ b/lang/solidity/Makefile
@@ -16,6 +16,9 @@ LICENSE= GPLv3
BUILD_DEPENDS= boost-libs>=0:devel/boost-libs
LIB_DEPENDS= libjsoncpp.so:devel/jsoncpp
+NOT_FOR_ARCHS= powerpc powerpc64 powerpcspe sparc64
+NOT_FOR_ARCHS_REASON= solidity currently does not support big endian systems
+
USES= cmake compiler:c++14-lang
OPTIONS_DEFINE= Z3 CVC4