aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2010-11-05 03:17:48 +0800
committermakc <makc@FreeBSD.org>2010-11-05 03:17:48 +0800
commitc003b9cf1970f277da246a9715c65c8e344b7a81 (patch)
treeacc58823cffa5c0004cff6bf26788b32f0e7ade6
parenta0ed644a43217a1484d017ba77fdc60a016c20e9 (diff)
downloadfreebsd-ports-gnome-c003b9cf1970f277da246a9715c65c8e344b7a81.tar.gz
freebsd-ports-gnome-c003b9cf1970f277da246a9715c65c8e344b7a81.tar.zst
freebsd-ports-gnome-c003b9cf1970f277da246a9715c65c8e344b7a81.zip
Add new port games/opensfx:
OpenSFX is free alternative sounds for OpenTTD game engine. WWW: http://dev.openttdcoop.org/projects/opensfx PR: ports/151916 Submitted by: Ilya A. Arhipov <admin at gorodkirov.ru>
-rw-r--r--games/opensfx/Makefile29
-rw-r--r--games/opensfx/distinfo2
-rw-r--r--games/opensfx/pkg-descr3
-rw-r--r--games/opensfx/pkg-plist7
4 files changed, 41 insertions, 0 deletions
diff --git a/games/opensfx/Makefile b/games/opensfx/Makefile
new file mode 100644
index 000000000000..44dee3330891
--- /dev/null
+++ b/games/opensfx/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: opensfx
+# Date created: 2010-11-04
+# Whom: Ilya A. Arhipov
+#
+# $FreeBSD$
+#
+
+PORTNAME= opensfx
+PORTVERSION= 0.2.3
+CATEGORIES= games
+MASTER_SITES= http://ftp.snt.utwente.nl/pub/games/openttd/binaries/extra/opensfx/${PORTVERSION}/ \
+ http://gb.binaries.openttd.org/binaries/extra/opensfx/${PORTVERSION}/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-all
+
+MAINTAINER= micro@heavennet.ru
+COMMENT= Free alternative sounds for OpenTTD game engine
+
+USE_ZIP= yes
+NO_BUILD= yes
+
+post-extract:
+ @${FIND} ${WRKDIR}/opensfx-${PORTVERSION} -type f -name "*.txt" -exec ${MV} {} {}-sfx \;
+
+do-install:
+ ${MKDIR} ${PREFIX}/share/openttd/data
+ ${INSTALL_DATA} ${WRKDIR}/opensfx-${PORTVERSION}/* \
+ ${PREFIX}/share/openttd/data
+
+.include <bsd.port.mk>
diff --git a/games/opensfx/distinfo b/games/opensfx/distinfo
new file mode 100644
index 000000000000..ecdd27f71592
--- /dev/null
+++ b/games/opensfx/distinfo
@@ -0,0 +1,2 @@
+SHA256 (opensfx-0.2.3-all.zip) = 6831b651b3dc8b494026f7277989a1d757961b67c17b75d3c2e097451f75af02
+SIZE (opensfx-0.2.3-all.zip) = 11359588
diff --git a/games/opensfx/pkg-descr b/games/opensfx/pkg-descr
new file mode 100644
index 000000000000..8bc928dc21dd
--- /dev/null
+++ b/games/opensfx/pkg-descr
@@ -0,0 +1,3 @@
+OpenSFX is free alternative sounds for OpenTTD game engine.
+
+WWW: http://dev.openttdcoop.org/projects/opensfx
diff --git a/games/opensfx/pkg-plist b/games/opensfx/pkg-plist
new file mode 100644
index 000000000000..b76cf71feb4a
--- /dev/null
+++ b/games/opensfx/pkg-plist
@@ -0,0 +1,7 @@
+share/openttd/data/changelog.txt-sfx
+share/openttd/data/license.txt-sfx
+share/openttd/data/opensfx.cat
+share/openttd/data/opensfx.obs
+share/openttd/data/readme.txt-sfx
+@dirrmtry share/openttd/data
+@dirrmtry share/openttd